Routing Issue with GE 45604 Outdoor Module

Hi, I searched the forum and the only thing that I found close was this thread (,23135.msg156720.html#msg156720), but I was not able to arrive a resolution after reading the post.

I have about 50 z-wave devices and 1 of them was a GE 45604 outdoor module controlling my yard lighting. It was working fine for weeks and I don’t know exactly when, but I assumed after I continued to add more devices to the network, it started to act up - on some days, the On/Off command is not responsive, sometimes the On/Off command went through, but it was not reporting the status back to Vera properly (e.g. even though the light is turned on, Vera still shows “off” because it’s not getting the latest status back).

I wish I can do an exclude/include command, but I could not because I also have a GE 45631 keypad, which could only control the first 32 devices in network. If I exclude/include my outdoor module, it will get a new device ID like 70 which takes out my keypad control.

I did many “heal” commands, both at the network level, as well as at the device level. None of them solved it.

Can someone educate me in terms of how to read the “routing table”, or how to “manually route”, or any suggestions for me please?

Thank you.

If you search the Wiki and forums you will find more details about Vera routing. There’s also the fine manual.

If you look at the Autoroute field on the Advanced tab of your outdoor module you will see numbers similar to this [tt]20-19x,34-21,18.71-25,8-28[/tt] The following chart should explain its meaning:
Node Metric(Qual/Pref) Failed
20 19 x
34 21
18.71 25
8 28

The first route has failed. This route should no longer be used and it should trigger a network heal that night to determine valid routes.

The third route says that to reach the outdoor module(say node ID 99) the route goes from Vera(0)===>Switch(18)===>Outlet(71)===>OutdoorModule(99)
and that quality or preference(metric) for that route is 25. Lower numbers indicate a better metric or more reliable route.

To force Vera to use a manual route, if you are positive about which intermediate nodes Vera should utilize, then you would enter something like this in the Manual Z-Wave route (advanced) field on the Outdoor module’s Device options tab. [tt]7[/tt] or [tt]31.9[/tt] These options tell Vera to route as: Vera(0)===>Switch(7)===>OutdoorModule(99)


respectively. Note that you do not specify a routing metric with manual routes.

It is my opinion that manual routes are a last resort. It is better to determine where problem routes are and add intermediate nodes(or relocate nodes) to resolve the issue and allow automatic routing to keep the network healthy. If you stipulate a manual route and the route becomes bad for any reason, Vera will not automatically try to figure out another route and recover or route around the failure.

Thanks for the explanation, Z-Waver!

Looking at my UI5, first my “AllRoutesFailed” setting is 1 (which I assume this is a bad sign), and then looking at my “AutoRoute” setting I have the following:

2 - 141 x,
37.2 - 150 x,
3.2 - 151 x,
9.2 - 151 x

This looks like all routes have failed (as indicated), and the common node is 2. Is this correct?

So, node 2 is a GE On/Off switch (Binary Switch) controlling my kitchen ceiling lights. This device by itself is functioning properly so I am not sure why it is “failing” there? Or does it really mean it “stops” there and can’t go further?

In this case, any recommendation for me to try to heal this?


Yes, this indicates that Vera has failed to reach the outdoor module on all of those routes. Yes, the deduction that node 2 is the issue is a good one, as it is the common intermediate node in all the failed routes. But, also note that the metrics for all of the routes is very high, which causes me to guess that the outdoor module is far away or obstructed from node 2.

All that we know for sure is that Vera thinks it should go node 2 to get to the Outdoor module, but Vera is unable to reach the outdoor module. Since node 2 is working, I would assume that either the outdoor module is beyond the reach of node 2(likely), or the outdoor module is powered off/failed.

I would try moving the outdoor module closer to node 2 and see if it starts working. If it does, then you need put a reliable intermediate node between node 2 and the outdoor module, or establish a better node than 2 to talk to the outdoor module.

Your next question is likely to be; why did it stop working when it use to work fine? Lots of things affect radio frequency(RF) signals. I would guess that the outdoor module was at the periphery of the signal range and that something(of a million possibilities) cause the signal to weaken or be interfered with, causing the module to now be beyond the signal range.

Improve your signal to the outdoor module.