root password vera3 not on bottom of unit... how to find?

Captain Obvious here…
just replaced a vera2 with a vera3. Would like to login as root on the vera3. (No crisis, I made needed tweaks via the
test luup code window and things are great). I would like to login as root so that if/when I need to its not a 3 day task.
I see no root password on bottom of the unit. There is serial #, wifi key, mac address (tried them all just in case). No other
passwords I can see. I figure I have overlooked something in instructions/forum posts but no luck.

Mmm, should have been the [tt]WiFi Pass[/tt].

See if (the bottom of) this page helps.

Very odd indeed… I got in using remote / password from tech support url. Nvram show confirms root password
is wifi password but its not working for root login. Any thoughts on that?

Case sensitive maybe?

Was caps lock on?


Evidently it restored root password from vera2, nvram showed correct wifi password (matching bottom label). Following wiki pages for ssh login I reset root password and all is fine. Thanks oTi@ for the link to the wiki page. I need to dig into that a bit more before
begging for help next time… :o

If you backed up your Vera 2 and restored it to your Vera 3 it will restore the root/WiFi password from the Vera 2 onto your Vera 3 as that value is part of the backup. It’s been mentioned a few times in the Vera 2 to Vera 3 upgrade thread as most of us, including myself, at one time oranother ran into that issue.

BOFH, I should have done my homework on this. My home vera2 to 3 upgrade was very easy and clean. Was only down at the vacation rental for 2 days and needed to do upgrade here as well as general winter chores around the place. Took the lazy way out asking you guys for help. I appreciate the assistance from everyone, if I was at home and not under a time limit I would have spent quite a bit more time searching and reading before hitting the ‘help me button’ in the forums… :slight_smile: Again… thanks to everyone on this and
some other threads on getting me through a few bumps on this upgrade.


I upgrade the Vera2 to Vera3. The migration was fine,(Restore my backup from Vera2)

But my new Vera3’sroot password will the old Vera2’s password, not a Vera3 bottom number.
Is this correct?

That is correct as that password setting is part of the backup.

Hi…i restored my vera plus from old vera plus unit that died in a firmware upgrade…i do not have the bricked unit anymore. How can i get my root pw again?

maybe support can help me?

Hi @otolosa , this might help, run this code either via the LuaTest add-on, or via Apps/Develop Apps/Test luup code option and check the logs

local function myverapassword()
	local cmh_conf ="/etc/cmh/cmh.conf")
	for line in cmh_conf:lines() do
		local match = line:match("^Password=(.+)$")
		if (match) then


Hi…tks fr the reply

the password is the same as the one on the back of new vera plus…however it doesnt work using winscp

btw…using the “remote” user pw worked

Yep, that’s always your back up, but as you’ll notice it’s just a temporary one…