"Replace failed" no longer working

I’m trying to replace a failed node (a FIbare door sensor) by using the “replaced failed” function. However Vera never goes into inclusing mode, and shows an error message instead: “Cannot contact device, error code: 1”

This on a Vera Plus on firmware 1.7.4453.

+1 here. Any attempt I make to replace a failed node (and is showing failed in the UI) gives me this brief sequence of logged events:

08	12/03/19 19:39:00.742	JobHandler_LuaUPnP::HandleActionRequest device: 64 service: urn:micasaverde-com:serviceId:HaDevice1 action: ReplaceFailedNode <0x71995520>
08	12/03/19 19:39:00.743	JobHandler_LuaUPnP::HandleActionRequest argument id=lu_action <0x71995520>
08	12/03/19 19:39:00.743	JobHandler_LuaUPnP::HandleActionRequest argument serviceId=urn:micasaverde-com:serviceId:HaDevice1 <0x71995520>
08	12/03/19 19:39:00.743	JobHandler_LuaUPnP::HandleActionRequest argument action=ReplaceFailedNode <0x71995520>
08	12/03/19 19:39:00.743	JobHandler_LuaUPnP::HandleActionRequest argument DeviceNum=64 <0x71995520>
08	12/03/19 19:39:00.743	JobHandler_LuaUPnP::HandleActionRequest argument rand=0.4237526735088051 <0x71995520>
02	12/03/19 19:39:00.744	ZWave::HandleActionRequest_ReplaceFailedNode replace node 74 device 64 <0x71995520>
04	12/03/19 19:39:00.848	<Job ID="44" Name="rfn_bs_74" Device="64" Created="2019-12-03 19:39:00" Started="2019-12-03 19:39:00" Completed="2019-12-03 19:39:00" Duration="0.103638000" Runtime="0.103028000" Status="Successful" LastNote="SUCCESS! Transmit was OK" Node="74" NodeType="ZWaveDimmableLight" NodeDescription="MBR Fan Light"/> <0x76e64520>
02	12/03/19 19:39:20.100	ZWaveJobHandler::AlarmCallback skipping check because of jobs <0x76e64520>
01	12/03/19 19:39:20.874	ZWaveSerial::Send m_iFrameID 417 type 0x0 command 0x63 expected 3 got ack 1 response 44649520 request 0 failed to get at time 253873 start time 233863 wait 20000 ack 1 m_iSendsWithoutReceive 0 <0x76864520>
01	12/03/19 19:39:20.874	ZWJob_GenericSendFrame::Run failed to run job#45 :rfn dev:1 (0x288e720) P:50 S:7 Id: 45 type 0x0 command 0x63 abort 1 lower priority 0 retries 0 node 0 <0x76864520>
04	12/03/19 19:39:20.875	<Job ID="45" Name="rfn" Device="1" Created="2019-12-03 19:39:00" Started="2019-12-03 19:39:00" Completed="2019-12-03 19:39:20" Duration="20.129832000" Runtime="20.25589000" Status="Aborted" LastNote=""/> <0x76864520>

Oh, and I’m on 4783.

Also +1. Noticed this a while back on 1.7.4453 .

@rigpapa as I replied to your message, I saw this post.
Yeah I have had issues with it though I have not done this in a long time. If I need to do this type of manipulations I tend to use a secondary controller, either zway or the silabs pc controller.

There is a workaround: You can renumber the device ID and then reset the Dev_Num_Next attribute to bring it back down if you need to maintain your automation. The problem is that the awful luup engine reload thinks it is smart to delete all the scenes with this device id as its trigger and can cause a mess.
This problem can be mitigated by using ALTUI to avoid luup reloads after changing device ids but it is tedious. You will end up with a different zwave node id though

So the sequence is:

  1. Add your new device. Luup will reload
  2. Use ALTUI to change the id of the device you want to replace to any available number (no luup reload)
  3. Still using ALTUI change the new device’s id to the old id you want it to have. (no luup reload)
  4. Delete the old bad device (make sure you factory reset it) or exclude it. Luup will reload.

Hope this helps. Short of that you would have to go manipulate the user-data.json file which… hmm is very error prone.


Yeah, I know the workaround and used it, but still, it (replace failed) is a useful feature that should work.

1 Like

Especially when you’re doing it because Vera excluded a device for you. :slight_smile:

Don’t start with me. I’ve been including “holiday switches” all day, and my nerves are a little frail. I’ve already done one complete burn-down and restore. And I’m denying myself the comfort of a calming beverage until I’m finished–don’t drink and device, you know. :smiley:

Incidentally, the “workaround” I used is a little different. Rather than change device IDs, I changed ZWave nodes. I left the dead device in place, and since the switch was a Leviton, reset it with the paddle (easy air-gap then hold-to-red sequence). Then I included it as a new device. Once settled, I noted the new ZWave node number, and then simply swapped the altids on the dead and new device. Reload, delete the now-dead new device, done. This leaves my scenes untouched.


I like your workaround. Pretty clever if the device needs no user configuration.

1 Like

I do the same. In very extreme situation, I also had to directly edit user data Json file.

so we still dont have official reply to this?
if the device is the same one (excluded for some reason) can i include it as new then swap the altid with no problems please?

This hasn’t made any problems for me, but I always back up my Vera before I do it (or really, pretty much any include/exclude for any reason). It is not an officially sanctioned thing to do, may not work for every device, YMMV, caveat hax0r.

1 Like

+1 - Replace failed is an invaluable tool in the toolbox. Have used it many times.

1 Like

Hi Rig, i could not get it to work, here is what i did:

  • I reset the device on the wall (MCO light switch)
  • add the device as a new one
  • after it was configured and running, i tried to swap the altid, but nothing changed.
  • tried to swap the names and Vera says configuring your devices please wait, then it will rest both devices to their original settings, so the old one will get back its latid and original name and the new one too.
    is there anything i am doing wrong?

Must be, and most likely didn’t hard-reload your browser. It’s very reliable for me. I often change device names and room assignments using the same general pattern… change one device on its Advanced > Param tab, change the other (same way), immediately reload Luup (Advanced > New service and use the button–closest tool for the job), hard-reload the browser. That last step is key, as the UI does not easily pick up the changes, and will happily show you old device data, and if you go in and do more editing based on that incorrect cached data, you can really make things confusing, or worse…

Just an obvious question but…

Which device’s altid did you change? From your description of “swap” it almost sounds like you tried changing the altid of the newly included device number. This should indeed work 100% but what @rigpapa is suggesting is changing the altid of the old, disabled device to the altid number of the newly added device. This is how you make the old device id connect to the newly included device. You can then delete the newly included device id.

@rafale77 is correct… you must take the altid of the new device and put it on the old device and take the altid of the old device and put it in the new device. Literally, swap… exchange…altids between them. A becomes B and B becomes A. Don’t change names or anything else just yet–that’s just going to create confusion (and it’s actually wrong). Swap the two devices, reload, hard refresh, make sure the old device is now working with the new altid, and once it is, delete the new device that now has the old altid.

1 Like

Also you know we are using ALTUI to do this right? If you try doing it on UI7 the vera will likely reload luup between changes and try to correct things so it won’t work.

I do this in UI7. Vera does not reload when you make changes to device attributes on Advanced > Params, which is why I use that almost exclusively to change device names and rooms as well–Vera will reboot if you use the fields for name and room on the device control panel “Control” (typical) tab, but not on Advanced > Params.

Interesting. When doing manipulations like these, I now exclusively use ALTUI. I’ve been bitten too many times with unnecessary and unwanted luup reloads upon parameter changes. Good to know that at least this one doesn’t cause a reload. I remember indeed that a device id number doesn’t cause a reload either.

Ok, i guess it is because i am trying to change the names and room assignment at the same time, this is forcing luup reload… maybe this is the issue.
so to make sure i am doing it right, i put the OLD altid in the OLD unresponsive device, then i put the OLD altid in the NEW working device, reload luup and hard reload the browser, right?