Reolink RLC-411WS

In case anybody is interested…
I just successfully connected my new Reolink RLC-411WS to Vera following and adapting some guidelines I found on the forum for other cameras.
Here the step by step setup:

  1. Navigate to the camera tab and click add new camera
  2. Select “IP Camera (Other IP Camera)” from the list hit ok and then 3 times next until Vera tries to detect the camera, then hit “Manually install the camera (advanced)”
  3. Select your camera’s IP in the list
  4. In the dropdown for the camera type scroll to the bottom and select “Other IP Camera”
    5 Enter camera URL as follow, replacing the value in parenthesis with yours: http://(ip address)/cgi-bin/api.cgi?cmd=Snap&channel=0&rs=(any combination of numbers and letters)&user=(user name)&password=(user password)
  5. Fill Username and Password
  6. Hit Test, the camera should be detected and saved

To configure the live stream now, you have to go into your camera again:
1.navigate to the “settings” tab, click on “Advanced” scroll down and click on “Extra Parameters”
2. Check the number at the end of the device_file e.g. for D_DigitalSecurityCamera1.xml, the value would be “1”
3. Navigate to the “New service” tab
4. Enter the value as following:
New service: urn:micasaverde-com:serviceId:Camera1 (PS: the ending number should match the one you found in step 2.)
New Variable: DirectStreamURL
New value: rtsp://(user name):(password)@(ip address)/h264Preview_01_sub (Replace the values in parenthesis with your own)
5. Click “add” then “reload engine”

Regarding the camera, I wasn’t sure at the beginning since I found no mention of Reolink in the Forum, but I have to say it’s working great and has a fantastic image quality.
Can’t wait for Vera to implement native ONVIF support to integrate even better

Make also sure to remove the MAC address under Extra Parameters to avoid regularly losing connection due to a cleared IP address. (see topic here:,20738.0.html)

The streaming portion of this is not working for me but the snapshot is working fine. Is there something I need to change in the settings for the DirectStreamURL to work?

I am having a similar issue with the stream. both _sub and _main should work and do in iSpy. Should also note that the ip of the stream should include the rtsp port of 554 (ip:554).

Still can’t get it to work. Also tried adding DirectStreamingURL and RtspURL services.

Should also note if you forget to fill in the username and password you can’t change them later and it will annoy you to about using the default user name and password whenever you access the camera.

It would be nice if this could be an app that way it would actually automate the urls and associate with IP, username, and password for URLs.

Even I was also undergoing with the similar circumstances.I totally agree with your viewpoint.I have two co related queries in this regard that Why does it takes a lot of time for gopro videos to get uploaded and other one I am unable to connect the Arlo ultra with my Mac book Air.I have tried out the following arlo security camera review to resolve this circumstances.Hope this might help.

With the steps documented in the first post, I got streaming to work in the web interface…
I think at some point it also worked in my Winows Mobile App, but have no way to verify this since I switched to Android.
In the Android app though, streaming is not working for me either.
So considering all this, I’d guess that the limitation is not in the settings but rather somewhere in the mobile app.