Release Notes - RTOS firmware v.8.528

We’ve released a new RTOS firmware v.8.528 for Ezlo Atom and Ezlo PlugHub controllers.
New Features:

  • Implement API for controller settings (hour and date format, temperature scale). Please note that the UI support for this feature will come at a later time with new mobile apps release.
  • Added support for Configuration Command Class version 4


  • Improvements on working with SMART START
  • Improvements on working with reachable/unreachable status of devices


  • Fixed bugs on Network Settings

  • Fixed the issues with the weekly PIN code restrictions not being set correctly

  • Fixed the issue with battery devices became unreachable in a network with more than 5 devices

  • Fixed the issues with devices not changing their status to unreachable

  • Fixed several issues that were affecting Thermostats.

  • Fixed the issue about being unable to remove configuration parameters on RTOS

  • Bug fixing for integrated Z-Wave devices

Known issues:

  • Issue with incorrect sunrise/sunset time for scene in case the time zone is changed after enrolment. The sunrise/sunset scenes are calculated based on location and for the moment we do not have UI support to change it after enrollment (API is in progress of being integrated in UI)
  • Issue on devices that support Tamper where the broadcasts and notifications generated are opposite to the actual tamper state.
  • Issue about being unable to reset Zwave Settings network

With this firmware update it has broken my EZLO test unit. Each time I try to open the app it just keeps showing the date and time settings. Resets, nothing works. Same each time. Factory defaults even. Nothing works. What’s with this ? It was working fine with the other versions prior. I’ve already logged cases with support about it.

I have the same problem and, according to the Ezlo developers, this is a known, but not fatal issue. The timezone is set but an associated property does not match what the app expects so it throws the prompt every time it “checks” the timezone which is frequently. While this is annoying and interferes with the app use somewhat, your Atom should work properly after you set the timezone once. I’m sure they will fix this soon.

The problem is that it started with that and now has turned into the Ezlo constantly rebooting on it’s own. Does it when it’s got nothing configured even. Was working fine with the previous version of firmware (and software) Yes, back in the beginning of the beta test it was problematic due to buggy software but lately it had improved and was reliable and useful. I have been able to get my devices back on it but with it hanging and then rebooting so often it’s just not reliable at this point.

@stevem5215, I factory reset my Atom (>10 second reset) and when it rebooted the blue LED stayed blue for a long time. Eventually, I decided to power-cycle it and it came back fine. I made sure it is running the 0.858 firmware and it is not rebooting on its own. Perhaps try a factory reset again?

Today I tried rolling it back to the (15) software instead of the (17). It reset perfectly (although reset perfectly is a lie, it still took at least 3 or 4 tries to get it to reset to defaults because it gets a dimly blue light and never does anything after that till i pull the power and try it again and again till it finally shows bright blue and then i can get it to do something. And that something was another full factory reset and reload of all devices AGAIN (PIA) for the configuration of my 6 devices out there in the 2nd garage. When i put it online with the 15 code all was ok and no issues appeared to happen. But as soon as i went to upgrade it to the (17) code it quit working again. So, I left it that way for a few hours. Still no communication to host (app on the phone) and I just set app to 15 again and reset the EZLO for at least the 20th time this week. All came back ok again and is working. It appears to me that the 17 code has something going on in it. Of course I have no logs to look at to see and there’s no way to get someone onto it cause there’s no remote switch to turn on. So, it’s just a guessing game. And I’m guessing that the 17 code is messed up. Along with whatever causes that stupid message about setting the timezone over and over when i go to the app. That’s a PIA too. So, please engineering. Update the code to something that works. And FIX that dang Timezone thing! Or just delete the code. We know how to set our times properly !

As having tested it with the 15 code for a day or two I did find that the thermostat was not reporting correct temps to the software. It was paired ok but not sending the temp over. I tried removing it in zwave config and adding back but still same issue. IMO this all has something to do with the time zone hanging as it does when first trying to use the app. It’s hanging the rest of the communications on it. When i didn’t have this issue previously all was ok. As soon as it showed up then nothing has worked correctly since.