Problems with 2GIG DBELL1 on Vera Secure

I’m a long term Vera user with a Vera Secure with many devices on it. Am trying to add a 2Gig DBELL1. The device gets added successfully to the system but the Vera only recognizes the “trip”/“untrip” sequence (pushing the button on the DBELL1) twice and then never again. I’ve deleted and readded it multiple times with the same results. Is there some trick to getting the DBELL1 into the system successfully?

Hope someone can help…Thanks!

PROBLEM SOLVED! (Good enough)…replying to myself here in the hopes that it will help someone else in the future. Apparently, at some point something broke the Vera UI7 built in DBELL1 device scripts. As best I can tell its looking for the “Armed” parameter to be included but its not there. Tried adding the variable manually but didn’t help. Finally, gave up and tried adding the DBELL1 device as a “2Gig recessed Door Contact” in the sensors section of the device list…works great now (and has the armed switch included that was missing from the DBELL1 device definition).

Hope this helps someone else.