Problems Pairing Kwikset - failed at getting secure classes

I’m having an issue pairing 2 new kwikset locks. They just won’t fully configure. I have vera in Wifi Client mode, so I can then unplug her, bring her to the log, plug her back in with the A/C adapter and still have access to her.

I then press the button on Vera2 to pair Z-Wave devices (slow flash) and then press the proper button on the Kwikset. I leave Vera there while the lock and her do their thing, and then the lock shows up in the dashboard. I’ve left Vera there next to the lock for a few hours, yet i’m STILL getting “Failed at getting secure classes”

I can pair anything else, but these 2 kwikset locks are giving me fits. Any other ideas? I’ve tried removing one and doing the same thing again and still the same result. Fresh batteries in the lock and Vera2 is basically sitting within 2 feet of the lock.

I had the same problem. Try excluding from Vera, removing the batteries from the Kwikset, tapping three times on both the Program button and the button you press to add to Vera. Then put in the batteries and try again with Vera about two feet away until it completely configures, secure classes and all. I was about to kill something when I got this advice because I didn’t know about the secure classes taking forever the first time. The removing batteries/pressing button three times clears and resets everything which worked like a charm for me.

Thanks, I tried this exact method and still same issue. I watched closer and noticed that Vera said it was “exchanging security keys” and the lock shows up, then it says something about failed security scheme etc. Maybe something with the latest Beta or due to the fact that my Vera is Pri:NO and has that whole friggin disaster. Yet, I added a schlage lock a few weeks ago and that worked when Vera was in this same state…

Any other ideas?

I had the same kind of problems with a couple of Kwikset locks at my vacation rental.

They had been having some connection problems due to the distance from other nodes and took advantage of the Radio Shack deal to get a bunch of beaming GE dimmers. When I went to the house, updated Vera to 1183, installed the dimmers and excluded the locks, reset them and tried to include them both. Over the next couple of days, I tried lots of things to get the locks paired, removed them and moved them near Vera (tried lots of distances from next to it, to about 6 feet away) and nothing worked. Was about to give up and post a cry for help, but decided to backup and reset Vera to factory settings. After restoring the backup, the include worked first time!!!

Don’t know if that will help in this case, but certainly worth a try.

Ya, this is what I was afraid of. Close to 50+ devices and it’s going to take me a week of pain and suffering. I went through this crap when I got “failed to go into learn mode”. I’ll try again and then maybe I’ll have to bite the bullet yet again and hope it all works out. What a pain!

I’m having the same problem with pairing two Kwikset locks with two Vera2’s (one for each Vera). I had them working fine until I tried to make one Vera a slave to the first Vera. That didn’t work but when I reset the network, I could no longer pair the Kwikset locks - and only the Kwikset locks. The other devices pair up just fine.

I tried the reset as stated above but that didn’t work either. But I wasn’t sure if that person meant hit both the pairing button and program button simultaneously three times or one at a time. I keep getting “security keys” error.

One at a time. I found advice that said to hit the program button three times while the batteries were out but that didnt work the first time so I retried and hit each button three times with the batteries out and it worked the first or second time I did that.

I had to re-pair my one kwikset deadbolt and had some issues with getting it paired back up. Hitting the program button three times right after taking the batteries out (needed to do this a few times) worked. Also when pairing the lock, leave the vera unit next to the lock for a bit to finish up exchanging certificates for security etc.

  • Garrett

I even had some issues with two of mine a week or so back after a heal left them dead in the water and they had similar trouble reconfiguring for hours on end. Not sure what ended up fixing the issue, but I re-powered the whole house and turned off my Aeon HEM (these things suck bandwidth) and then it seemed to go smoothly.

Just my $0.02…

I had the exact same issue; everything seemed fine except there was an error with ‘security classes’ during the pairing. I noticed that the motor sounded a little labored when doing the calibration, so I decided to swap out the batteries that came in the Kwikset box with some brand new ones I had. Everything worked fine immediately thereafter (motor sounded much perkier, and the pairing/exchange worked fine). Seems odd, but the ‘new’ batteries in the box were near dead, and the energizer ‘wrapper’ on one of them was actually peeling. Maybe B&D got duped with fake batteries :slight_smile:

In any case, try a fresh set of batteries, and hold Vera really close to the lock when pairing to see if that doesn’t fix it.

I had the same problem with my Kwikset lever trying to include to my Vera1. I finally had the chance to rebuild from the ground up on Vera2, so I’ll give it another go tonight and see if I am having the same problems again. No problems including other devices that I have, including several Schlage locks.

We have 4 Kwikset Deadbolts and when I first added them, two of them paired fine and the other two had the error getting Secure Classes… It was like that for a week but eventually it cleared…

I think I did the Repair function on the Vera2 more than a few times and now, all my modules work perfectly. I don’t have 50 modules, but around 30.

I finally got my 2 kwikset locks to pair with their respective Veras. I had to first exclude them from their Vera then reset each Vera. Then I could include them. Worked great. Fortunately I only have about 10 devices because everything disappears when you reset. I had tried everything talked about above but this particular order was the only thing that worked.

Im assuming I have to reset the Vera2 and RESET NETWORK to get it back to primary so I can re-add my locks and all the other devices again :frowning:

I just cant get these 2 locks to pair and get secure classes and I’ve tried over and over with all methods over the past week

I got the same error until I programmed a code into the lock manually and then it paired to the Vera2 box fine the first time.

I just installed my first Kiwkset yesterday.

At the first try, I did the recommended process: bring the Vera near the Kiwkset, have Vera in pair mode and then push the “B” button on the Kiwkset. The light flashing pattern on Vera told me that the inclusion was done, so I moved back the Vera to its normal location and attached it to the network. Looking at the Dashboard, the device was there but the pairing was incomplete (still trying to get secure classes).

Then again I brought the Vera and is battery near the device and excluded the device.
At that point, I did again the procedure to include a device, but this time I left Vera there for about 30 minutes. After that time, I moved back the Vera to its normal location and attached it to the network. Looking then at the dashboard, the pairing was done and everything working perfectly.

If I may, what is the model # of the Kwikset lock you’re referring to? could someone please share this info - I looked at the signature on some of yours - dont think you’ve the model # …

I ordered few of 99100-011 Kwikset’s- I was going thro’ the other posts and there was a post that mentions the z-wave button is the one on topmost left and not the program button…Any input on this would be greatly appreciated.

Could someone please confirm which button indeed is the z-wave button on the Kwikset? Thanks for your input…

Yes, the left button on the top is to include/exclude the lock, as is explained in the documentation.

The program button is to program codes on the lock itself, as is explained in the documentation and on the lock itself (at least on the 99100-004).

Thanks @oTi@ :slight_smile: