Problems accessing Public Calendars - token error code HTTP/1.1 400 Bad Request

Good morning,
I’m trying to set up Gcal3 to access a few different public calendars. One, is a public calendar for my daughter’s school district. I want to be able to search for “Schools Closed” as a gc_Keyword, however, I can’t even get that far. When I put the public calendar’s URL into the Calendar ID field, I get a token error code: HTTP/1.1 400 Bad Request in Next Event.

The subscription URL is https://www.fcps.org/about/calendar/feed/ical.ics

I also tried another public ICS for Federal Holidays, and I’m getting the same result. These should both be uncredentialled calendars.

https://www.officeholidays.com/ics-fed/usa

Any advise?

Okay, I think I sort of found the problem, but it sort of still persists.

I discovered that the switch needed to be armed for one. I also appear to have to remove https:// from the Calendar ID field. This does permit GCal3 to fetch the calendar.

The problem I’m seeing now, is that after some period of time, The same HTTP/1.1 Bad Request shows back up.

When I go into Variables, the events do show, so I appear to be able to fetch those events in Reactor, but I’m wondering if this is expected behavior, or there is a bug in the plugin, or if I’m doing something wrong.

I’ve attached the log file from one of these instances in Zip format.
511-GCal3.log.zip (3.4 KB)

Anyone?

@Stuart. Any ideas what is causing this issue?

Sorry I can help much with the GCAL3, as I don’t use it, but a few old plugins suffered from still using http, when they needed to be updated to make https call.

As for the open .ics file, I have used this before, and have been working on some updates, if your interested…

http://forum.micasaverde.com/index.php?topic=6355.0

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules