Prefix name cannot be empty


Just installed AltHue for the first time. I cannot seem to clear the prefix name of “Hue”

I am using a Vera Plus firmware 7.29 and when I go in to the Hue plugin and Advanced - Variaables and try to clear NamePrefix it says its value cannot be empty.

I have also tried clearing “Hue” from the Settings of the Plugin but it doesn’t work either.

Any way to clear the prefix I don’t want any prefix.

Thank you.

I am looking at this, can you try to set the NamePrefix variable to a space character ? ( ’ ’ )

1 Like

I tried a space earlier but it didn’t like that.

If I try your space with the quotes then yes I could set the prefix to ’ ’


However the names of the bulbs still say Hue in front of them.


I cannot simply add a space to the NamePrefix.

I have just learned to live with it. Since I use Alexa to control them anyway, the Vera name is not an issue for me.

Ui7 won’t let you do that you need to set the space with Luup or with altui
Then a reload is necessary for name change to be effective. Just tested on mine and it works fine


OK thank you for looking.

I dont have ALTUI installed how can I set a space with a Luup command?

just use

luup.variable_set("urn:upnp-org:serviceId:althue1", "NamePrefix", "", devID)

It seems to have worked this morning.

I just put a space in the prefix name in the main AltHue plugin settings

you were missing the luup reload probably.
glad it works now

I might just suggest to set it blank by default. I’m not sure there’s any benefit with a prefix, but it can be useful for anyone trying to customize it.

This works great! Not even a space before the name.

1 Like

Hmm I want to try this, but ware do I find luupcoding?

Go to your device, then Apps, Then Develop Apps, and paste the code into Test Luup Code. Change your ID accordingly.

Like this, luup.variable_set(“urn:upnp-org:serviceId:althue1”, “NamePrefix”, “”, 30)

And if it works, the name should be empty?

this is correct.

thanks for the answer, it made it work in the end! Must read on a little about Luup … :slight_smile:


Hello, when I reboot will this solution still work or should I put it in startup Luup, thanks

Just ried this, pasted the code, then went back to the althue device removed the Hue saved it and it reloaded luup and put the Hue back…Am I doing something wrong?

Ok put a . in there and it seems ok now

I didn’t use the Lua code in the end.

I just put a space in the prefix name in the main AltHue plugin settings. Can you not do that?

Ok will try just a space, thanks