Popp keypad

Anyone had any luck with the popp keypad? I can include it, but it shows no responds to pin codes entered in the pad, nor press of the bell button.

I was going to order one.
but will wait for some more feedback on this thread.

where you able to include it on the vera? which one, edge?


I?m also interested - but have no keypad myself. I read that it have two modes, Stand alone and Gateway mode. @drchip - how does it work in these two?

I am on vera edge. Gave up on the keypad, but retried today after having updated vera firmware to 1.7.3830. Its still not functional as should be expected. It includes as generic device and shows as an on/off device. How ever the icon will now show an alert ?wrong pin entered? if a wrong pin is entered on the physical device. No alart if correct pin entered an its no possible to use in a scene, as only scene possibilities are on/off, which is not possible to controll from pfysical device. I also notice that an alert of ?device untripped? is registered if the bellbutton is pressed.

So it looks like the update of the firmware on vera did something, but that its still not completely compatible.

In stand alone mode i have been able to include a popp strike lock, and it works as expected, but i have kot been able to include other locks is stand alone mode (or rather i can include but the locks dont react as expected).

Good news. Got it working. Sort of. Using association on the lock (group 2 in the keypad) and changed params 1 to 0 (default 3) and params 5 to 0 (default 1). Dont really know if params 5 did anything, but param 1 was default to 3 and made my lock open and then close immidiately after that. Downside is that the keypad has to be within very short distance of the lock for it to work and it seems like its only every other time that it works.

Setting params and association was a pain. Had to try multiple times for it to set.

Hi @drchip
Could you, please, describe in more detail the setup you did?

Did you include both the keypad and the lock with your Vera and then changed the association?

I have the Popp keypad and a Danalock V3 lock. I can use the keypad as a controller for the lock but then my Vera system is not involved at all. If I include the lock in Vera it works well but the keypad has the behavior explained above so it cannot control anything through scenes.

I did try to include the lock in the keypad (keypad as a controller) and then to include the lock in Vera. But because with z-wave you cannot have 2 controllers the result was that lock switched to Vera and completely ignored the keypad after that.

Thank you.


I now had time to test some more so here are the results:

Scenario 1: direct inclusion of Danalock V3 into Popp keypad.
Result:This works.
Prerequisites: The lock should be calibrated (2 clicks + rotate + 1 click). On the keypad you should have already a code setup (8 + * β†’ 1 + * β†’ code + *)
Procedure: Press once with a paperclip on the lock button. Wait 5 seconds for the lock to get into inclusion/exclusion mode. On the opened keypad (with the green light blinking) press 4 and then *. The keypad will start blinking green and blue and then both will stop.
Issues: If inclusion is not working, do 2 and * on the keypad while the lock is in inclusion mode. It’s a good idea to reset both devices (10 clicks on the lock and 5 + hold * for 10 sec)
Conclusion: this setup works and it is useful but I am missing the ability to operate the lock from Vera for remote and scheduled operations.

Scenario 2: inclusion of Danalock V3 and Popp keypad in the Vera controller

Result: This does not work for the keypad

Prerequisites: The lock should be calibrated (2 clicks + rotate + 1 click). On the keypad you should have already a code setup (8 + * β†’ 1 + * β†’ code + *)

Procedure: in Vera go to Add Device, chose Generic Z-Wave Device, Next, Next. Click once on the lock. Give it a name and chose a room. Back to Add Device -//- Next. Press 4 and * on the lock. Give it a name and chose a room. Test that the lock operates from the Vera interface. Go to the keypad in Vera β†’ Device Options β†’ (Associations) Group ID: 1 β†’ Add group β†’ Apply changes. Go back to Associations β†’ Set β†’ Tick the keypad β†’ Save changes. Repeat for the lock but chose the keypad at the end. The lock can still be operated from the Vera interface but entering a code in the keypad does nothing.

Issues: If I chose Group 2 or 3 the association on the lock will not work: Failed to save association settings. Only group 1 worked for me. (Perhaps because it is the only group I have in my setup - but it did work on the keypad). I did try to be close (less than 1 meter) between all 3 devices but no change. When the association was in place I did get from time to time time-out errors when locking or unlocking even though the lock did physically turn.

Conclusion: While the association is saved successfully it seems that the two devices do not β€œtalk” properly as they do when in direct inclusion. In this scenario the Popp keypad is effectively useless.

Next steps: I would like to attempt to create a modified version of the generic D_Keypad1.json (or any other already existing in Vera) to bring to the interface β€œON” for a successful key +* or β€œOFF” for * (or the bell). If anyone has Lua, Z-Wave and Vera knowledge and is interested, please let me know.

1 Like

I just purchased the popp keypad and danalock v3 and i am trying the scenario 2 as well.

Popp keypad is still a generic device in Vera secure, i did not yet manage to set it up correctly.

Did you find a way in the meantime for scenario 2 to make it work?