Plugin update Version 1.96

This update add a few new devices:

  • Cherubini and Gaposa Blinds
  • TFA rain sensor

It also fixes some issues with Somfy devices and improves the functionality of other blind type devices.
Speed settings 1 thru 6 added to Lucci Air DC fans.

All the plugin files are included in the attached zip file. The modified files are:

  • L_RFXtrx.lua
  • J_RFXtrx.js
  • D_Fan5.json
  • D_WindowCovering3.json (144.1 KB)


Have done all the updates and now have another problem (still can’t get the Somfy RTS Venetian
blinds to pair) - none of my devices work properly from the Vera. The open/close buttons don’t work, but the slider does (but not fully). Also on the web interface, there doesn’t seem to be a full compliment of buttons

Can you give me a bit more information about the slider operation? What does not fully mean?
What buttons are missing and what from what kind of Somfy device?

I’ve attached screenshots from the IOS app and then the web access via Firefox.

The web access seems to have lost some of the control buttons. The buttons don’t work within either, but moving the slider does activate the devices - Somfy RTS blinds/awnings and curtains - but not fully out/closed on all

sorry, images in wrong order

OK, I have two points to make.

  • There is no position feedback from these devices so the slider control operates based on the time for the device to fully move from open to closed or vice versa. You probably need to set the MaxMoveTime variable for each of these Somfy devices to the number of seconds for that full travel.
  • With regard to the buttons available for each device, I tried to make the UI appropriate for each type of device. Does an awning need both Open/Close and Up/Down?

Finally, I don’t actually have any Somfy devices so I can’t really test the operation properly and perhaps my assumptions about how they work are incorrect.

Any change for the icon location issues with read-only file system updates?

Icon files must be copied to /www/cmh/skins/default/icons/ There are several ways to do this but the easiest way is to use WinSCP. The Vera hub upload process should recognize icon files and handle them properly but at this time it does not.

Looks like it is read only to me. ver 7.31

I’m running the latest firmware 1.7.4970 (7.31). I just copied a .png file there.

Oh okay. I was looking in the img folder which is squashfs based and did not realize creating an icons folder in default added to the ro icons. Thanks!

Thanks, this plugin fixed an issue I was having Adding a Somfy device

I just updated from 1.87 to 1.96. But now my Somfy screen is acting very wierd.
When I push the UP button (imperihome) the screens goes up. Then stops after a few seconds.
When I push UP again, it goes down. Stop sometimes works. Buttons seems to work random. Also up and down is mixed up. The normal remote control works fine.

How can this be solved? Looks like the same issues as EllisO

Update: Also my Brel screens are having problems. Stop doesn’t work anymore, and the same with the Somfy, they react random at up and down or stop just during going up or down.

Update2: Tried different things, but it seems the blinds are uncontrolable. They act very wierd. At first, I choose UP, they go up for about 10 seconds. Then they stop. I click Down and they go UP. I changed maxmove to from 10 to 30. Ok now they go up all the way. But nothing happens when I choose down. Only after some time or maybe several clicks, they finally go down. But WTF now they stop after 5 seconds. I stopped here…

OK - I may have to revert to the old Somfy control methods. Let me look into it.

That or a fix would be nice. Now my blinds are not working automaticly.

Is it possible to just overwrite 1.96 files with 1.87 to downgrade or will that brake things?

Does anyone know how to downgrade?

You can upload older versions of the files. If you have problems after that post them here.

I just overwrote 1.96 with 1.87. All my screens/blinds are working again, up/down/stop.

A few things:

  • I now miss the rfxcom icon for the device. Tried to copy with Winscp again but did help.
  • The blind icon (device) still has the look of the new 1.96
  • maxmove time, was that already in 1.87?
  • Slider doesn’t do anything. Except 0 and 100%. But that was in 1.87 alse th case right?
  • 1.96 has some extra/new files, no problem to let them stay on the Vera?


Upgraded to 1.96 last night and have the following issues (controlling 4 DOOYA curtain motors through a FTXrtx433E).
1/ The new variable “maxmovetime” set at 10s default is causing some issues. My curtains are not all the same width so it made some of my curtains stop midway. Once set to f.e. 30s, all curtains close properly… This negates the slider function, unless you customize each curtain for its actual length
2/ But more importantly, the Close command has to be issued THREE times. After the 2nd time, the icon moves to “closed” but nothing happens till it is issued a 3rd time… (The Open command works 1st time…)

For now I have reverted back to 1.94 which does not have this last issue…

The setting of this variable for each curtain is the intended way for the slider control to work properly.

I’m aware that the close command does not work properly and I intend to fix that as soon as I have some time available. Springtime is a very busy time for me but I’m almost finished with my springtime outdoor chores.