Plugin Update V1.87

This update adds support for the following devices:

  • Novy extractor hood


  • ASP
  • Dolat DLM-1, Topstar
  • Hualite
  • Motostar
  • Screenline
  • Sunpery/BTX


  • HQ Lighting
  • Oase InScenio
  • IT (FA500, PROmax, …)


  • Davis rain sensor
  • Inovally plant humidity
  • RM17xRF smoke sensors

The device panel for some of these will not include all of the commands the device can respond to. For extra commands go to the Managed Devices tab of the RFXtrx and select the device. Optional commands if available will appear in the Command drop down.
The attached ZIP file contains all of the plugin files. The only modified files are:

  • L_RFXtrx.lua
  • J_RFXtrx.js (135.6 KB)


Thanks for your outstanding work to keep this plugin alive and kicking, Tinman!

I’m still wondering a bit why this plugin isn’t in the app store? No problem, just think it should be in the list, and it would be nice with the auto update option. :wink:

The original developer of this plugin had uploaded files to the marketplace but never released it there. Since I don’t have write access to those files I can’t simply update them there. This also prevents me from uploading some files because they have the same filenames as the originals. This last plugin update I’ve posted will probably be the last until after the next Vera firmware release. In the meantime I’ll be working on finding out if I can get this plugin into the marketplace.

Thanks again. Would indeed be nice to have it updated via the apps. Anyway.

Just wondering,after uploading all the files again (over the old ones) do you need to reboot the Vera controller? After uploading and without a reboot, the advanced parameters tabs shows the new version.

In the Vera UI where files are uploaded it defaults to restarting LUUP when you upload files. You may have to refresh your browser but there’s no need to reboot the hub.

Dear tinman, what protocol should I select in UI7 under RFXtrx device protocol settings to get support for IT (FA500, PROmax, …)? IT protocol is not showing up as a selectable protocol in my UI. Many thanks in advance.

Select the AD / LightwaveRF protocol. But the IT protocol subtype is transmit only so having it selected or not really won’t make any difference.

Little Newbie on this again been away for a while :slight_smile: but do i need also to update FW on my Rfxtrx ? i have an rfxtrx433e think EXT ? but not sure :slight_smile:
Thanks for all good work :slight_smile:

You should refer to the User Guide to determine which version of the FW is best for your device and situation. Select the version designed for your device AND for the devices you need to communicate with. I usually update both my RFXtrx transceivers to the latest versions.

Thank You i will Run thru the User guide :slight_smile: do you have two RFXtrx ? to same Vera .
So i think i run the old trunk beta 3 on my vera plus right now , do i just upload to your new V1.87 .
Or will all my devices i have be gone or do i have to update them also ? i have quiet a lot of different brands i i dont remember how to add all of them :slight_smile:


I have two RFXtrx connected through a powered USB hub. You should be able to just upload all of the files for version 1.87. I believe that all of your devices should still be there.

Thank you i will update my RfxTrx first then Upload .

Thanks for all help :slight_smile:


I’ve just updated the plugin to this version (from 1.30) and most of my Somfy devices have stopped responding. The two that still work are the latest 2 additions to the system. When I sort the managed devices by type, these are the only 2 that come up as Somfy RTS, the rest show as undefined category.

What do the altid of the devices that do not work look like?


The altid of one device that isn’t working reads



Modify it to look like WC/RFY.0/00051/00 (note the period after RFY)

Thanks Tinman

modified as suggested, and rebooted Vera, but still no response. All the Somfy devices are now categorised properly within the managed devices of the Rfxtrx, but still only the two latest additions respond. All are working fine from the Somfy remotes


At this point I suggest you enable debug on the RFXtrx, attempt to operate one or more of the Somfy devices that appear inoperable and then view the LuaUPNP.log in your browser (http://your-Vera-IP-address:3480/cgi-bin/cmh/
Look for Error or Warning log entries.

Solved the problem - somehow the RFx had been set to the wrong frequency! The only issue I have now is that the device I deleted when trying to solve the issue won’t recreate properly. Following the Vesternet instructions I can create the device, but when I try and pair it, there is no “program” option for the “run’” command

OK, what device are you trying to create? We’re still talking about a Somfy type device?