PLEG, PLTS, and Public Beta 1.5.622


I have moved up to the public beta of 1.5.622.
I was anticipating the fix for Triggers and Notifications from the PL plugins using both a condition name and the arm or bypassed status. I provided MCV a patch based on 1.5.408. They seemed to have fixed the Notification part … but not the Triggers for a scene.
That used to share common code … they may have changed that and that’s why it’s not working … half steps …

Previously I was concerned about upgrades working properly if I patched MCV code.
I am now confident I can release a MCV patch. You and MCV can expect a fix for this problem in the near future. I will release it here!

The attached file will fix the defect that keeps you from using the PL triggers:
PL has satisfied condition XXX and is Armed

I thought I had released this earlier … It fixes the MCV code to allow more than one argument in an event.

The file needs to be updated in /www/cmh/js/common

Unless you are familiar with remote access tools and Linux file system … this is not a patch for you!

The recent addition of the PL plugins to run a scene directly reduces the need for this.

Question, I’ve updated to v4.5 PLEG, and have the latest Beta 1.5.622, do we still have update the patch per this thread? If so you might make reference to the requirement in you other thread that describes the various changes. I was unaware until I decided to review other discussions. Mike

That patch is only is needed for those that want to use PLEG or PLTS as a trigger for a Scene.
Since both of these plugins can run a scene as part of an action … there is very little need for this patch.
Modify message

This broke just about everything I used to have working with PLEG. Not only can I not trigger a scene, I can’t even get the basics working anymore. I constantly get “Invalid Value Token” messages for just about anything. I have removed all my PLEG devices, deleted all the triggers, and I still have the same issues.

Is there any newer version that may fix any of this? My automation has turned into “turn a light on”, “turn a light off”.

Great plugin, btw… only wish I could use it. :confused:

Maybe you should tell us what version of the pleg plugin you are running. The current version is 5.2. You can update your plugins following these instructions:,14446.0.html

It is very important that you provide as much detail as possible on your issue. Just saying that everything stopped working and not providing more details is not going to help any of us to help you.

  • Garrett

I am running 5.2. I have also put in this cpanel_data.js and that seems to have made some issues worse.

At this point I think I have something partially working, but I still cannot select a scene to run for any actions. They are not even visible. If I click “Advanced”, and then go back to the normal selection, I see the Scenes, but when clicking on them it actually runs the scene.

Actions are typically used instead of scenes.

But if you want to run a scene:

Problem is I needed to run LUUP code, so an action wouldn’t work, and I didn’t see a way to run the code via PLEG, so I needed to use a Scene.

Thank you very much, seems I have it mostly working now.

I seem to have killed PLEG totally. Not sure where to go from here. I was working on some other PLEGs that I added tonight, and things started to go wrong w/ the 2 that I had working fine. I decided (after searching the forums) to do like you do, have one PLEG that handles just lights, another that handles temp, etc…

So I removed all my PLEG’s, and started from nothing. Problem I have now is I cannot create actions on more than one condition. PLEG absolutely refuses to allow me to do anything on more than one condition.

I removed PLEG and PLC entirely, even got rid of the files in /etc/cmh-ludl, and reinstalled, and I am in the same boat. I cleared the cache, even tried from a virgin laptop I had here, and nothing.

When I go to do anything with the second action, it allows me to select whatever I want, but never applies to the action, nor does it save.

If I go to advanced, it does not even allow me to select “add”.

Any ideas?

Thank you!

Are you only having problems with actions ?
Can you create all of your inputs and conditions ?
What type of actions are you trying to add ?
Have you tried to add an action from the Devices tab first ?

Yes, it’s only the actions. I am simply trying to create an action that turns a light off.

I have managed to work through it, but I need to click say “Arm” on a motion sensor, then accept that save it and the next time I go in, I can click anything I’d like. What I have to do to get it to work :

  1. Click the Action “Edit” button.
  2. Click “arm” for really anything, I have been using the PLEG itself as it doesn’t matter if it does get selected.
  3. Click “Finished”, the close the dialog, and save it.
  4. Got back in, same process and edit the action.
  5. Clear the Arm that I previously clicked, and click what I really want to happen.

Also this affects Advanced mode, as when this happens I cannot click “Add” under advanced to even add an action that way. I have to go in and “trick it” first, then it works.

Edit : and yes, inputs and conditions both work as expected. I have tried various different methods to see if I can find something that triggers this problem, but even having a new PLEG with just 2 inputs, and 2 conditions I have the issue. Seems as though anything over 1 condition. I know it’s happening too, as under the column “# of Actions”, it will not fill in anything if the problem is happening. It stays blank.