PLEG on UI7 and Can't connect though LAN

Earlier today I tried to create a PLEG automation to link two dimmers, but ran into multiple problems. All of my PLEG devices have this status “Error getting status of …”, just like dencker in this thread.

The solution provided says to run several update URLs pointed at the Vera. That is from this thread:,14446.0.html

At this point, I discovered I could not able to access my Vera Lite through the local network. I am able to access it though the Vera website, but not though LAN. I verified the DHCP assigned IP is on both the router and the Vera config pages. When I connect to that IP, I am taken to page that says “Redirecting … Main Page” and then it redirects to then the page fails to load. “This webpage is not available”

Regardless, I tried running this update URL anyway with a second window open though the Vera web login. The URL failed to load and no update occurred on the Vera.

I just wanted to link two dimmers, like mentioned in this thread:,28920.msg207074.html#msg207074 Somehow it spiraled out of control.

  • Spark

Turn OFF the secure my Vera in the Vera Settings. Then you can run on the LAN.

Excellent! I can now access my Vera via LAN. Thanks, Richard!

I ran the three update URLs, with success, and allowed each update to completely finish before starting the next. However, I am still having the problem of all PLEG devices reporting this “Error getting status of …” State: undefined, Last True: undefined, Last False: undefined. Is there something I could be overlooking?

Now referesh the browser

I tried refreshing Chrome with F5, then Shift + F5, but got the same error. I even tried a couple different browsers on several different computers and continued to get the same errors.

However, I did discover one slightly inconvenient way to get PLEG to work. The PLEG device will work properly after power cycling the Vera Lite. Any modification to the triggers, conditions, or actions results in status error messages until the unit is power cycled. Again, maybe I am overlooking something something-- I am new to PLEG.

I have been following your Dimmer Linking guide, posted here

In UI7, is it possible to set the action newLoadlevelTarget to {(DV1)}? It doesn’t appear to save any variable other than numbers 0 through 100. When I manually enter {(DV1)} in the advanced section, the PLEG status shows newLoadlevelTarget= , not newLoadlevelTarget={(DV1)}. Clicking “Do it now” just turns the dimmer completely off.

Thank you for your help, Richard. I apologize if the issues I am encountering are very common and simple. I try my best to research the problem before directly asking for help.

Yep you found a bug … regarding setting {(DV1)} in the advanced tab …
I just released a fix earlier today … I will have to wait until that is processed before I can submit another fix.

I think you need to reload VERA (bottom of the Advanced TAB of every device there is a button to reload Vera) instead of power cycling.