PLEG not triggering multi switch

This is my setup

When I am away (Mikeaway) a multi switch is switched on (Test Multi Switch SetStatus7 newStatus7=1) that works
when i am coming home (Mikehome) a scene runs (94) which turns the multi switch 7 off, and multi switch 8 on. Although the condition was true 18:24.794, it did not change any of the multi switches. (7 was on, 8 was off, before Mikehome was triggered). Before i had the scene, i used action to turn the switches on/off, but as that did not work i tried it with a scene, without success. When i just run the scene, the scene switches the multi switch. I cannot see why.

Lighting PLEG
Device ID: 2212013-10-13 18:29:14.578 PLC Version: 5.1

Name Description Last Trigger State

Mikehome (*)Mike is present 2013-10-13 18:24:52.794 false
PingMike Ping Mike is Tripped 2013-10-13 18:25:55.250 false

Device Properties
Name Device Name Device Variable Last Change Value
Mdistance1 ()Mike Distance 2013-10-13 18:29:03.709 0.009
Jdistance (
)Justine?s iPhone Distance 2013-10-13 18:21:58.283 0.014

Mdirection (*)Mike IconCode 2013-10-13 18:29:03.812 100

Name Expression Last True State

Mikeaway Mdistance1 > 2 2013-10-13 18:24:36.467 false
Mikehome Mikehome and PingMike 2013-10-13 18:24:52.794 false
Mikenotaway Not (Mdistance1 > 1) 2013-10-13 18:24:52.778 true
Mcomhome (Mdirection == 75) and Mdistance1 < 2 2013-10-13 14:17:46.957 false

Actions for Condition: Mikeaway
Device Action Arguments
Test Multi Switch SetStatus7 newStatus7=1
Test Multi Switch SetStatus8 newStatus8=0
Actions for Condition: Mikehome
Device Action Arguments
Lighting PLEG RunScene SceneNameOrNumber=94
Actions for Condition: Mcomhome
Device Action Arguments
Test Multi Switch SetStatus3 newStatus3=1

Is the PLEG armed ?

Yep, it is.

Turn debugging on and send me a the log:

Your trigger is named Mikehome. Also your condition is named Mikehome. Try using a different name for your condition such as condMikehome.

That was the problem. Its working now, thanks !


I have emailed you the log, but you can just delete it as the problem has been solved (see above) I had sent the email before this was posted.

That’s a bug as well … I should not have allowed the condition name to be the same.
I will add to the bug list.