PLEG not currently firing logic actions


currently using 1.7.4453 on a veraplus, and finding recently, that even though conditions are marked as true, the corresponding actions are not firing.

To try and combat this, taken a copy of the logic and created a new entry, importing the logic etc, and now this is suffering the same issue. Note, these conditions have not been changed recently, and hence, it shouldn’t be a case of the condition being true before the expected actions performed.

I’ve tried reloading LUA from the editor menu and also tried ‘Reload Engine’, but still seeing the same.

I’m considering a move across to Reactor, but will need to review the logic, as its all nice and neatly packed into individual pleg entries currently, and reactor appears to need to have them split out into particular actions based on a single set of criteria.

Anyone else seeing similar?

I sometimes have a similar situation and the only way to resolve it for me is to reboot the VeraPlus.

For me it is not a PLEG issue, the VeraPlus just runs out of memory and no PLEG actions are performed.

I’m also still on 1.7.4453 but I’m hope that 7.30 will solve this for me, waiting for the “official” release though.

Yes I see this too.

Even if I have a scene that dropp the cache when MemFree come close to 100,000 I still cannot avoid this situation from time to time. Last time it happened was on October 26th so it does not happen as frequent as in the picture all the time.

This is what it looks like for me when it happens:

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules