Please forgive the silly questions....

Hi…i’m brand new to Vera and just getting started. I"m seriously considering doing a “Dummy’s Guide to Vera” blog as it looks like this will be quite the adventure. I am reasonably technical but I’m already overwhelmed by the inconsistency of information avaialble on the various sites. It appears that this forum is going to be my home for the foreseeable future.

So, forgive me if I’m asking some ridiculous questions. I’ll get up to speed quickly…and I’ll commit to helping clean up or add to the help information out there as I will document my journey to competence (i hope)


[ul][li]I can connect to my veralite and have got a camera partially working…but my dashboard looks NOTHING like all the screen shots in the various help sections. I don’t have any options for plug-ins, etc. Are there different dashboards/portals?
I can’t seem to get on to the MIOS site to look at plugins so i’m assuming it’s a separate account. However, I don’t get an option to create an account…what am I doing wrong?
What’s the deal with the “U” versioning? It seems that version upgrades come on a haphazard basis and the user coded solutions are then rendered inoperable?[/li]


[ul][li]Mios/Vera/Mi Casa verde…holy crud it’s confusing. Every page is branded differently and it seems like there are multiple versions of every page or every piece of info. Whatever rebranding/merger/consolidation activities are taking place, they aren’t going fast enough[/li]
Is it just me or is the help info/wiki REALLY out of date?

Are you using

  • ui6 - white and green, Vera logo
  • ui5 - white and blue, MiCasaVerde logo

Take a look at your firmware … (Setup → Firmware Tabs)
If it’s Version 1.6.xxxx you are run UI6 and you are an official Beta Testers … Most of the third party UI5 Developers have never seen this version.

If it’s Version You are running UI5 and most of whats being talked about in this forum should be applicable to you.

I was in the same position as you 2 weeks ago, it has certainly been a voyage of discovery. I think one of the problems with the information is the same with everything on the internet; you have no idea how old it is and things change so quickly that solutions just aren’t current. My biggest issue is with Tasker, so much out there is for the old version which just is different.

I’ll try to help you though. Can you do a screendump of what you’re looking at? There is only one interface that I’ve found, the plugins are off the apps tab and then install apps. You can only get to the external interface if you have set up security on your device but it looks exactly the same anyway. You will need to do that for when you want to use things like your phone off your LAN.

Camera’s were a nightmare for me. I don’t think I ever found it written anywhere but worked out that if you set the camera back to DHCP, a default port of 80 and admin no password then it will discover it itself with the app. Well that worked for Foscam’s. Obviously put the settings back afterwards.

Happy to try and help with any of the basics but thats about where I am right now.

Camera's were a nightmare for me. I don't think I ever found it written anywhere but worked out that if you set the camera back to DHCP, a default port of 80 and admin no password then it will discover it itself with the app. Well that worked for Foscam's. Obviously put the settings back afterwards.

In general it’s best to leave all of the device, including VERA, with DHCP, and modify your router to assign a static/reserved (Different names for different routers) IP address for these devices. I find this to be a good local administration policy even sans Vera.

Vera likes to monitor know devices on the LAN, it does so by watching for the DHCP requests.

Even if the device get’s a factory reset, it will end up with the same IP address in your network.

I keep a file on my computer of all of my IP assignments in case the router dies or has to be reset.

Backups? Ain’t nobody got time for that!

crap…I think i updated the firmware to U16…is there a way to go back? maybe that’s my problem.