Philio 2 in 1 sensor PAT02-B (temp & humidity)

Hi, i just added a Philio 2 in 1 sensor (the PAT02-B) to my Vera Edge / UI7. Did it once as a Generic z-wave (because the philio 2 in 1 is not listed in vera), and once as a Philio 3/4 in 1 sensor. Both resulted in the same configuration and working of the device.

The device works OK but…it defaults the temp setting to Fahrenheit, and I need it in Celcius.
So, shouldn’t be a problem I thought, manual states Variable 5 with 4th bit set switches the device from F to C.
Added Variable 5 as 1 byte decimal with value 8 (it is not predefined as a setting in vera). But de device does not accept value 8 (vera shows message ‘Failed at: Setting user configuration…’), and the interface shows that variable 5 has a current value of 41.

The Vera interface however shows a C (indicating Celcius mode) but switches back to F (fahrenheit mode) after some minutes. And the temp value shown is always a fahrenheit value, even when the interface shows C.

Does anybody know how to get this unit to work in Celsius mode? Tried so many things already…

Issue is fixed.
The problem was in the vera, and not the sensor. Although the Vera was configured to display temperature in Celcius, it did not do it. Switching the setting from Celcius to Fahrenheir, save, and switch it back again to Celcius, save, solved the issue. Vera was now using the correct setting.

Where did you purchase the Philio 2 in 1 sensor? Also have you found the temp/humidity to be accurate?


Inaccurate temperature and humidity and no possibility of calibrating