Phantom Devices

[shadow=purple,left]The Phantom devices are back.[/shadow]

Nine days after resetting the whole Z-Wave network the Z-Wave network crashed again. I looked into Vera after the sunset scene didn’t work yesterday evening. I saw Z-Wave was configuring for at least one hour. After that hour I had 232 new devices in my network. Some of them are motion detectors that I never had before. All my existing devices disappeared.

At the end Vera was unusable and can’t control my lightning and my shutters.

@MCV: this is not fun this is serious. It might be that this is a dongles’ problem. But for me, Vera is a package…

See also:

It took me three and a half hours to set up all the stuff again. ;-(

Hope this will never happen again!

Next weekend next Problem.

After three devices refused service this weekend I found again 86 phantom devices.

MCV: please please do something!

just to show you two screenshots. The Problem is that Z-Wave tries to configure all devices which takes a lot of time and set nighborhoods to existing devices. :-((

Did you enable verbose logging, ‘save’, and then submit a trouble ticket? If so, did the tech support guys tell you what those phantom nodes are?

I just had this same thing happen. Has anyone heard from MCV about it?

Yes. They worked remotely on the symptoms what helped to stabilize the system.

MCV thinks this is a dongle’s problem and will send me one with the new release.

I’m having a similar problem. I keep deleting the devices, they keep coming back. The devices are ghosts of devices in the system. The ghost devices don’t response, but keep coming back.
My Vera is haunted.

@ubiquityman: Is your dongle only a secondary contoller as mine? You can see it at Z-Wave Options. (Role Suc SIS:YES PRI:NO).

No, mine is a primary controller.

Well, than it looks a bit different to me. Do you “lose” some of your real life devices from time to time? This is one of my major problems. Sometimes one of the devices does not respond to Vera. I than have to reset, exclude and include it, what causes a lot of work to redefine all the scenes the device was in.

MCV tech support explained (if I understand it properly) that my problem is that the device still has a node ID and is essentially paired.
It sounded logical at first, but the device just doesn’t work when I configure it.

I reset MCV, upgraded to the latest LUUP firmware and had it working OK.
I started adding additional devices to Vera, and I’m getting the same problem again.
I’ll do more work on it tomorrow and see if I can get it completely resolved.

The LUUP release doesn’t work for me so I actualy try to restore the 616. My Problem with the new release is that my window coverings do not work in this release.

Well, you could try to control your window coverings with Intel’s UPnP Device Spy for Windows with .NET 1.1 (

Device Spy → Vera → ZWave [1] → Window Covering [x] → urn:schemas-micasaverde-com:service:SwitchPower:1 → SetTarget → Invoke

If this does work, you can define a Luup scene, which can be used as a replacement for the non-functional GUI buttons “Open” and “Close”. Example code is available at:

Thank you Ap15e.

I tried that. Switching lamps on and off is not a problem, but activating the shutters didn’t work. Not in Luup sceenes and not sending the command via an URL. MS .net is not an option, because there are only Macs in my house. I think there is a bug in Vera’s code.

So I decided to go back to 616.

activating the shutters didn't work... activating the shutters didn't work.

I would strongly recommend that instead of reverting to 616, you (a) go to Advanced, Logs, check ‘Verbose logging’, (b) try to control the shutters so the logs indicate the failure, (c) go to Advanced, ‘Tech Support’, and submit a trouble ticket. Put ‘for Aaron’ in the comments. I’m the Z-Wave developer. That way it will be fixed, probably within a couple days. If you revert to 616 without doing a trouble ticket, the problem may never be fixed so you’ll be stuck on 616 forever. We don’t have shutters in our test home, so it’s quite possible that Luup can’t control them since they’re not tested. But if we have a trouble ticket with logs, we can fix it right away.

I'm having a similar problem. I keep deleting the devices, they keep coming back. The devices are ghosts of devices in the system. The ghost devices don't response, but keep coming back. My Vera is haunted.

This is a different issue. This is not a bug, it’s Z-Wave’s design, actually. The black dongle contains the Z-Wave chip. In the Z-Wave module, when you pair a device, that device is giving a node ID (2, 3, 4, etc.), and the Z-Wave module itself stores a map of all the devices you have paired. Vera continuously sync’s it’s database of devices with the list in the dongle. You can select ‘permanently remove dead node’ in Vera’s UI which tells the Z-Wave module in the dongle to remove the given node id. But the dongle may not execute that request if it thinks the node id is still valid. So, the proper procedure to remove a Z-Wave device from your network is to carry the dongle to the device, press the button on the dongle for 3 seconds until it blinks rapidly, then activate the Z-Wave device you want to remove. The blue light on the dongle should come on solid to show that it worked. Anytime you have a problem with a device and want to repair it, first do this ‘remove’ procedure. Then when you re-insert the dongle in Vera, Vera should say ‘configuring’ Z-Wave devices. Wait until that stops, then wait another minute or so for Vera to re-sync with the dongle. Then the device will be gone.

I found again 86 phantom devices.

This is a hardware dongle issue. We were supposed to have received another batch of dongles by now with the new Z-Wave modules, but, it seems the shipment from China is held up.

@MCV: Before I went back to 616 I switched on verbose logging, tried some commands and send a ticket to you so you have a chance to work on the problem.

My actual problem is solved now. All devices and scenes are doing what they are supposed to.

MCV, do you guys have an estimated arrival time for the dongles? Held up from China sounds a bit. . . Um. . . scary?

The factory said we’ll have them next Wednesday.