Pan and tilt using Foscam with new UI7?


I recently did a factory reset on my VeraEdge and trying to get everything back in working order.

Apparently Vera changed the way you add cameras in one of the later UI7 FW and the old way of adding cameras have changed. This means my old way of getting my Foscam 8910W and 8918W cameras to work don’t work anymore (

I have managed to add the cameras by “Add camera” → “IP Camera Other IP Camera” → waiting 6 minutes (argh! >:() → “Manually install the camera (advanced)” → choosing a random IP that is shown (the cameras IP was not shown) → choosing “Other IP Camera” under Manual Configuration → setting “http://IPADRESS/snapshot.cgi?user=USERNAME&pwd=PASSWORD” → adding username under “Camera Username” and password under “Camera Password”.

This settings give picture when i press “Test Your Camera Configuration” and add the camera to the Vera.

However, the device created can NOT pan och tilt. It is also not possible to use it as a motion sensor as before.

I have tried to add I_FoscamPTZ.xml in “impl_file” under Params but I then get a “Lua Engine Failed to Load” after reloading the engine. Removing the file under impl_file and reloading luup remove the error message.

Have anyone successfully made a Foscam pan and tilt using the new camera settings in UI7?

I thought you had to use the Foscam plug-in to get PTZ functionality…??

I installed the plugin but I could never create devices using it… Should I do anything else with it?

Hopefully somebody else will chime-in cause i don’t know. :cry:

I have this same issue, down to the very last detail.

These were cameras that worked without a hitch, and since updating the firmware, they have been absolutely useless. I can’t seem to get them set up again, even after resetting the controller.

Also, the Foscam plugin doesn’t add devices. Help would be greatly appreciated.

Pan tilt and motion, upload of security pic. !!!?

I have the same issue with two 8910Ws on my brand new VeraPlus. Tried the Foscam app before I found this thread, no go. Worked perfectly in UI5. Hope someone figures it out.

Could it be that Vera wants to collect a monthly fee to make the cameras work as before?

No, but I need to be a lot smarter. OK pan and tilt is now working. I found several additional threads re: using the I_FoscamPZT.xml file. Since I already had two working cameras I tried a quickie version of the instruction set here:

What I did: First I checked my Luup files. I already had the implementation file in there, probably from my failed attempt to use the Foscam plugin. I looked at the file and it referenced the username and password variables from my already installed device. They looked correct so I added the impl_file, then in variables Commands I added:
I reloaded the lua engine and voila, tilt and zoom.

Thanks to everyone involved in figuring this out. ;D