OpenWrt Curl 7.21.3 OpenSSL/1.0.0d

Hi,
Hope this is the right place for this question. I have looked for an answer on existing threads and I was not lucky.
I have a Vera Lite UI5 1.5.672. I would like to retrieve data about my PV system from Fronius data server, using curl from the Vera shell (curl 7.21.3 (mipsel-openwrt-linux-gnu) libcurl/7.21.3 OpenSSL/1.0.0d zlib/1.2.5)).

curl -X GET “https://api.solarweb.com/swqapi/pvsystems/xxxxxxxxxxxxxxxxxxxxxxxxxxx/aggdata/years/2021/months/10?channel=EnergyPurchased” -H “accept: application/json” -H “AccessKeyId: XXXXXXXXXXXXXXXXXXX” -H “AccessKeyValue: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx”
I get this error:
curl: (35) error:14077410:lib(20):func(119):reason(1040)

This command work on Windows 10 and Android, with newer curl version (curl 7.55.1 (Windows) libcurl/7.55.1 WinSSL and curl 7.73.0 (Android) libcurl/7.73.0 BoringSSL zlib/1.2.11), but not from the Vera.

I have also tried some other syntax found in this forum, but did not help. I.e.:
curl -k https://api.solarweb.com/swqapi/pvsystems/xxxxxxxxxxxxxxxx/aggdata/years/2021/months/10?channel=EnergyPurchased -d AccessKeyId=XXXXXXXXXXXXXXXX -d AccessKeyValue=xxxxxxxxxxxxxxxxxxxxxxx
Same error:
curl: (35) error:14077410:lib(20):func(119):reason(1040)

Not sure if there is a syntax problem on my commands or it is a curl/ssl limitation. Would be great if someone could help me.

Many thanks in advance!

It’s a limitation of the firmware you are on. The curl/openssl combination does not support the ciphers required by the server. Over the years, servers have moved from SSLv2 to v3 to TLS 1.0, 1.1, 1.2, and now 1.3. Some of the older encryptions and the ciphers they use have been found to be weak/exploitable, so server operators have started to disable their use. Since this is done by configuration on the server side, it can happen at any time without notice. If the (firmware) software was up to date, it would simply choose the preferred/remaining options and move on without so much as a whimper, but since your firmware dates back to 2015, and it was probably out of date even then when Vera built it (they seem to not update libraries much and so were/are always perpetually behind), you are, as they say, probably S.O.L. That’s just too far back.

(well past) Time to upgrade.

Many thanks for your answer. Any upgrade recommendation? Is it just SW or I need to change box?

Even the current Vera Edge, Plus and Secure models are lagging in their libraries, with users starting to report issues due to CA certificate expirations and down-rev bundles, and it’s unclear how many more firmware updates there will be (the current 7.32 update in progress has been in Beta/limited availability since October last year, with little communication from the company on its future). I think the world of options is open to you.

I am pretty happy and used to UI5, but I will need a Vera Plus sooner or later, so better to start thinking on the migration.
Many thanks for your help.

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules