OpenSprinkler V3 Help

Hello all, I just got my hands on the OpenSprinkler v3.0 and got it up and running. I tried integrating it to my vera ui7 platform by following the steps listed here: . I followed every step by downloading WINSCP and running it on my Mac via winebottler. I uploaded akbooer’s JSON parser library by dragging and dropping (maybe thats where I went wrong). Then I continued on with the steps by uploading the correct files to the LUUP files. I refreshed my browser cleared the cache and it still didn’t connect, nor do my zones pop up correctly. Is v3.0 even compatible with this plugin? Am I missing some steps? Im not very knowledgable in SCP and LUUP files, so please assist me with this id love to have control via Vera. Thanks!


Is the devices “Advanced” tab visible?
If so, were you able to put your Open Sprinklers IP and password in the appropriate areas?

No that is not visible in the advanced tab. Just the IP address is what I have filled out and available, does it have anything to do with the fact that I changed my OpenSprinkler’s port to 90? I have my IP address written out like this IP address:90.

You should see these tabs in the advanced section.
Your OS IP goes in the Param tab and the password and Zoneids go in the Variables tab.

I had the same problem as you so I had to delete the OS add on and reinstall it. Then I just followed these directions in the first post here.,29977.0.html

I am now able to control each zone of the OS controller with the Vera (On/Off) and enabling and disabling the OS controller does work from Vera. Status and zone label download from the controller are still not working.

Try reinstalling it and follow the directions and see if you get the tabs available.

Reinstalled everything and still ended up at the same spot as before. I have those same tabs available just no where to input a username and password. The sprinkler controller is still showing off manual auto as well on the vera.

Figured it out, when I would back up the LUUP files and download the new ones my computer would put a ‘-2’ beside every files name. When it came to uploading the new files they wouldn’t replace the old files, so there was two copies now. Fixed it by keeping the names of the files the exact same so when it comes time to upload they’d get directly replaced.

hey @Jamr just got myself an Open Sprinkler V3 also and about to go down this path. How are you finding it and does it pull in the Zone labels as yet? Also if you use any of the sensor inputs on the Open Spinkler (e.g. water flow sensor etc) can you pull these into Vera in any way?

I fixed the Plugin to support the new API. I’m traveling for the next two weeks, but I can take a look at JSON responses and try to add support for sensors as well (if not already done).

thanks for the prompt response, now I know it should work I will now give this a swing over the weekend. I read a fair bit of the different OpenSprinkler threads but they were super long so just wasn’t sure if I had missed anything.


I plan to improve things a bit in the future. Right now it’s just a port with some fix on device categories and cosmetics.

No feedback from OS. I can only control stations on or off and enable and disable the controller.

Apologies! haven’t got to this one just yet, will definitely be installing in the next few days :slight_smile:

Massive delay I know but I have finally had some time to get back to doing some work on the HA system.

For the life of me I still can’t get the OpenSprinkler to work with Vera.

Have tried loading the original plugin (tried multiple adds and removes of this)
then loading the files as listed from the first post over here;,29977.0.html

Still no dice, tried loading the extra two files from here as suggested;

No dice, tried following the step by step post from helraiser on that above forum post on the final page, no dice either. Basically either just doesn’t work or if following the full step by step Vera says;
System error : Device: 257. Fail to load implementation file D_OpenSprinkler1_UI7.xml

Is there definitely a way to get it running with an OsPi V3?


I have it working partially with my Vera. I am not sure what I did except for what I documented earlier.
I will try on my test Vera to install the app and see if I can get it to connect.

[quote=“Jamr, post:15, topic:199273”]I have it working partially with my Vera. I am not sure what I did except for what I documented earlier.
I will try on my test Vera to install the app and see if I can get it to connect.[/quote]

thanks mate. not overly stressed as could just send the commands I need to the web API but currently waiting for Vera support to get back to me as to why I can execute wgets from the Test Lua code section but I can’t exectue them from scenes :frowning:

I hope to have time in the upcoming months to rewrite it from scratch. I partially lost interest in it since I moved a lot of my stuff to a custom wrote C# app running on Ubuntu - collecting info from OpenSprinkler and sending back to Vera - in an effort to stabilize my Vera. Maybe with the new Vera firmware coming up, I can move back a couple of things to LUA.

thank @therealdb tbh thats what this plugin needs is a full rewrite from scratch, the mess that it is to try to follow the forum threads to magically make certain versions of OpenSprinkler or OpenSprinklerPi work with Vera is pretty average :slight_smile: (although thats a big number of the Vera plugins haha).

If when you get a chance to do that you can drop a line here that would be great.


doesnt work on my vera plus

Just in case anyone is interested in Open Sprinkler:
I have given up on this product as the V3 unit I have has failed and the manufacture has refused to support it. It seems that OS has givin up on Vera a long time ago.
The unit intermittently started losing connection to my router via WIFI and now will not connect at all even with a WAP less than a foot away from the OS device.
With the add on MIA and the manufacture not willing to help, I am afraid OS with Vera is dead.
Look for another controller although the offerings are slim.