openLuup on Synology via Docker

Hi all. I would like to start a thread dedicated to running openLuup on Synology via Docker. I have successfully downloaded the airedale/openluup/ docker and have it running with AltUI, but am running into the issue of non-persistence after stop/start and limited success with adding additional plug-ins (starting with DataYours).

My initial questions are:

  1. Can anyone share the docker run command that they are using to start their openLuup container? I am wondering if my persistence issue has to do with lack of a volume specification in my run parameters.

  2. For loading plug-ins, I am dropping the files into the /etc/cmh-ludl directory and reloading luup, but I don’t see the plug-ins in the AltUI list after that. Surely I am missing something real simple here and have searched the forums first of course, but to no avail.

Thanks in advance for the help!

And for reference - I am currently using the below to create my container …

docker run -d --name=“openluup” --restart=“always” -e veraips=“192.168.1.3” -v /volume1/docker/openLuup/files:/files:rw airedale/openluup

I also tried the below to try and see if it would help with persistence, but with limited success …

docker run -d --name=“openluup” --restart=“always” -e veraips=“192.168.1.3” -v /volume1/docker/openLuup/files:/files:rw -v /volume1/docker/openLuup/cmh-ludl:/etc/cmh-ludl:rw airedale/openluup

Sounds like a good plan - there seems to be some interest. Sadly, I have NO expertise in this area, so it’s definitely self-help!

For loading plug-ins, I am dropping the files into the /etc/cmh-ludl directory and reloading luup, but I don't see the plug-ins in the AltUI list after that. Surely I am missing something real simple here and have searched the forums first of course, but to no avail.

I have not implemented the data structures which allow AltUI to fully describe the installed plugins. My experience (outside of Docker) is as per the attached screenshot.

If I recall correctly, jcsv75 successfully installed openLuup on a Synology NAS. Although, I don’t have the specifics …

Yep, that’s true. I managed to get OpenLuup running in the docker image provided by Airedale. However, as you found out already the data is not persistent across reboots. I have been doing some reading on this topic and I am sure it must be possible to achieve data persistency according to this info: https://docs.docker.com/engine/userguide/dockervolumes/. Unfortunately my technical skills and time are the limiting factors here.

However I had succes with a slightly differerent approach. I installed phpvirtualbox on my synology NAS, (actually a Xpenology box built on the HP N54L server). Then, with the precious help of cudanet, I got Openluup installed on a virtual machine running Ubuntu. It’s been running smoothly for about a month now and I can take the image and run it on any machine with Virtualbox installed.

I thought about running it directly on the Synology with either Debian Chroot or something similar, but I like the idea of the Docker option for the containment and portability of it. This has started me down a new route where I am attempting to build my own docker container based on a a standard Debian docker image, then customizing it and putting everything into a new Docker build file to share with everyone. I hope to share some good progress in the next week or so!

Ok sounds great. Happy to help testing if needed. I guess the key to making the image persistent is to figure out how to assign a writable volume to the docker image .

Sent from my iPad using Tapatalk

anyone successfully running openLUUP in Syno Docker? Looks like there have been a ton of improvements in Syno Docker in the past year - data should persist across reboots fr as I know.

I would like to see a Docker version of OpenLuup as well, but I would like to run it on UnRaid

Whilst I don’t have a solution to run OpenLuup on Docker, I do have a solution to run OpenLuup very easily on a Synology NAS. The only thing that is needed is a reasonably powerfull NAS and the installation of PHPVirtualbox which can be found here: https://sourceforge.net/projects/phpvirtualbox/. You can then import the ready made virtualbox image from Cudanet and update from there.

I have this running since over a year on a selfbuild Xpenology Nas with 16 GM RAM.

cheers,

Jacques

I have it running on a docker container. When I go to http://dockerip:80 I get “forbidden” should a website be displayed? Or should I do anything els before Altui is displayed? :-[

403 Forbidden
nginx/1.6.2

Edit… following the manual I get:
http://:3480/data_request?id=altui
(this takes about one minute and requires, of course, an internet connection.) If you want
to watch it working you can tail the log with tail -f LuaUPnP.log
This should load a functional ALTUI interface which should run when you access the URL
http://:3480/data_request?id=lr_ALTUI_Handler&command=home#
You will immediately be prompted to upgrade to the latest version (you don?t have to ?
again, it takes about a minute and will restart openLuup.) You should be able to exercise
all the ALTUI functionality through menus, etc., and simply see a single device (ALTUI) in
the system.

But I only see:
AltUI, amg0, Waiting Initial Data

and that never changes…

Is anyone running openLuup in a VM on a late-model Synology NAS, such as the DS218+ (which has a virtual machine manager built-in)?

I’m trying to decide whether this rabbit hole is worth my going down (since I at least have experience installing Ubuntu in all kinds of places).

  • Libra

So you found an old thread … :slight_smile:

And yes, I’m running openLuup on my DS412+, Dockerized. I use (shameless plug) my own docker image for it, vwout/openluup. Read more about in in openLuup on Docker (Hub).

It works out of the box, create a container and off you go. In that case you may however loose data (like your configuration and installed plugings) when upgrading the image. Synology unfortunately does not allow you to create volumes for persistence of data - at least not via the GUI. When you have console access (SSH) this of course is possible.
The easiest in that case is to use docker-compose. When you have root access, you can use the following docker-compose.yml file:

version: '2.3'

services:
  openluup:
    image: vwout/openluup
    ports:
      - "3480:3480"
    restart: unless-stopped
    volumes:
      - type: volume
        source: cmh-ludl
        target: /etc/cmh-ludl/

volumes:
  cmh-ludl:
    name: openluup-env
    labels:
      org.label-schema.description: "openLuup environment with plugins and userdata"
1 Like

I am trying to get this running on a Synology 212+. I had it working while testing a couple of weeks ago. I deleted everything and started over and cant get it to work again. The docker images runs from the GUI. I can connect to console. I am trying to install Alternate UI. I type latest in the update box and click update. Waited for 5 mins. Reload Luup, Hard Refresh the browser. Under version it says Github.latest. When I try to access it i get the message: No handler for data_request?id=lr_ALTUI_Handler.
Is this how it is supposed to install. Any Ideas what Im doing wrong?

If you started openLuup based on a fresh, I think you are running into the issue addressed in the recent topic New install on Raspperry Pi, AltUi not loading. The root cause is described by the author in this post: New install on Raspperry Pi, AltUi not loading, which suggests to use the development branch.

My openluup Docker image uses the master branch of openLuup, which means it does not contain the fix yet.
@akbooer: Any chance that the GitHub fix in the AltAppStore will be master soon (e.g. commit 2020.04.16 ‘master release candidate’?

Yes, very soon. Working on the final tweaks to a 5-th Anniversary edition, but it’s not clear to me why you’re not already using the development version.

1 Like

Hi @vwout, @akbooer and everyone else!

I have successfully gotten openLuup to run on my Synology NAS.
I tried the CLI way, just following the https://hub.docker.com/r/vwout/openluup section “Running” and " Persisting configuration" and now I have openLuup running with persitsance! :slight_smile:

However, I would like to transfer my current Vera Reactor backup file to my new openLuup Reactor, and I can’t find where I should put the file in order to restore it according to Rigpapas instructions (https://www.toggledbits.com/static/reactor/docs/3.6/Backup-&-Restore/).

So… my question is basically; what should I do to be able to upload my Reactor backup file to a place where I can access it from Docker/openLuup/ALtUI? Where do I find this openluup-env volume in the file system of my NAS?

Thanks for all the effort you have put into this, both @vwout, @akbooer and Rigpapa! Really impressed how fast the communication is between the openluup/vera using the verabridge!

Thanks in advance for the help!
Tim

1 Like

I’m glad that things are working well for you, having got openLuup up and running.

I am no Reactor expert, but @rigpapa is the author.

I do note the following in the link you sent:

The Restore button restores the last configuration backup (stored on the Vera as reactor-config-backup.json in /etc/cmh-ludl/ on Vera or the directory in which Reactor is installed on openLuup

and that seems pretty explicit, but OTOH, I also know nothing about Docker! So let’s wait and see who turns up with some real help…

If memory serves, you use docker cp from outside the container. The question is, what directory path inside the container would be the target? I don’t know; that’s a question for the container creator. You could also docker attach to the container and wander around until you find the container’s plugin directory (running find / -name L_Reactor.lua should expose it pretty quickly).

I’m not aware of a file uploader in ALTUI, so… paging @amg0… is there one? Can there be? @akbooer, does your new built-in UI have one? This would really be the most consistent and user-friendly approach, IMO.

Hi!

Thanks for the quick answers! Yeah, my plan is to do a Reactor Backup, download it to my computer, edit the json to add the 10 or 100 to the device id:s, upload it to docker/openluup/where reactor saves it’s backup files, and restore a backup, basically migrating my Reactor-logic. The Reactor part should work… Or at least without changing the device id:s, which would be my plan B.

Thanks!

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules