Opening vaInit...

Hey Friends -

I’m having an issue with VeraAlerts and was hoping for advice.

I’m running UI5 and getting “Opening vaInit…” when trying to edit my alerts. Is it because I forgot to turn Auto Updates off? (I did that for PLEG, etc) I see that I’m at 7.11 which is stated to only be for UI7.

How do I downgrade?

I followed these instructions:,15065.0.html

This got me back to 6.43. Does that sound correct?

I have the same problem.

Latest version of firmware on a VeraLite.

Have uninstalled/reinstalled the app - same error appears:

Error executing function vaInit(): Cannot read property ‘Init’ of undefined

I just experienced a very similar, if not the same, issue following a Vera firmware recovery and restore. The Vera alert icon was missing, showing only the generic blue gear(?) and missing almost all the tabs under the device properties. Clicking any tab would trigger the opening vainit message and nothing further would happen. There did not appear to be any errors in the log.

It seems probable that the issue stems from some sort of version conflict. My restoration process used an old backup that had not disabled automatic updates on the RTS apps and they all upgraded and broke. I then restored again with a more recent backup with autoupdate unchecked. This reverted all the apps to the appropriate older versions, but Vera Alert continued to not function, instead producing the ‘opening vainit’ problem.

The final resolution was to restore Vera to factory default and then again restore the newer backup. At that point everything started working as expected. However, the icons on Vera Alert and PLEG devices remains the generic blue gear, so something is still not quite right, but all functionality seems to have been restored.

When Vera upgrades it’s firmware … it sometimes deletes plugin files.

If you have the latest Versions … then a power cycle reboot … should restore the Icons for PLEG, PLTS, and Vera Alerts, Day or Night