Only power light after upgrade

Hello All, this is the second time i face this issue with Vera secure controller.

I connected my new Vera Secure for the first time and it asked for an update, i started the updated and left it for more than 3 hours. when i came back, only the Power light was steady on, and the rest of the lights were off. I can’t login to the device and it is unresponsive. i tried to reset it (30 seconds rest button using pin) and it restarted to the same thing, only Power light is on and nothing else.

can somebody help please, isn’t Vera Secure supposed to be the most stable one among them all?


In the same boat here, I installed the latest firmware as prompted by the latest version android application and now only the power LED lights up, appears bricked. Powering off and on again gives same results.

Scanning the network shows that there is nothing responding on the usual IP address it uses.

Troubleshooting advice would be greatly appreciated.

@trogdor i recieved my replacement Vera yesterday, i contacted support and they connected to my old one and tried to work on it but it seems it was damaged beyond repair. i suggest you contact them by phone and try, it might work instead of waiting for a new one to arrive.
for that prepare a laptop that has wifi and lan port, connect your Vera through lan port and connect to internet through wifi, the support will create remote session and try to revive your vera.

hope that helps,

Hi guys, the tech support got in contact with me and suggested resetting with 8 presses of the reset button. I think before I tried 6 presses.

The 8 press reset worked, and after quite a while my vera plus showed signs of life. Conveniently it kept it’s configuration so no settings were lost in the reset.

Cheers to support, I’m impressed that I’m dealt with as an overseas customer.

1 Like

Thank you for the update and the kinds words.

I’m glad you’re back on track.