Odd Veraplus behavior on network

Yesterday, I spent time setting up a DHCP server on my synology NAS. I wanted to move the functionality off my Linksys router as it seems to get confused after running for awhile and the network map gets the wrong mac addresses to the wrong device. (this is a whole separate story). I am not sure if offloading DHCP will help or not but it can’t hurt. It is an experiment.
Before doing this I did some research and to use the router’s guest network, DHCP has to be on for the main network also. So I learned out to have 2 DHCPs in the same network by not having overlapping ranges and basically setup the router’s range to be a very limited use range of 1 IP with a reserved address.
This all went very well and I have DHCP reservations for every device on my network. I rebooted the devices and each picked up its new ip fine. I reconfigured my Home Assistant config file for the new IPs as well. At this point, everything is going smoothly.
The only issue I had at all and it is odd and cost hours to get working with a workaround. I am hoping someone can explain it so I can learn and/or not have to do the workaround. When restarting the VeraPlus to get the new IP, it didn’t seem to come up. I panicked thinking it bricked as I had a veralite do that. I did the press reset 3 times to reset the network settings. Still nothing. I eventually opened a terminal window and started a ping and put it aside on the screen. I could see the lease being reset for 1 day in the synology DHCP server window. It appears to be getting an IP but not setting it. I then saw in the terminal window that it started pinging then stops. I get about 11 pings about a minute or so after a reboot of the veraplus, 11pings, then back to no reply. This is so odd.
It was getting late and I finally “gave up” and thought maybe I would just put the veraplus back on the router’s DHCP server. I increased its range from 1 to 2 and I noticed pinging in the terminal windows again. Huh?? It had the ip from the synology NAS as it should and is now on the network just fine. I could get to the web interface and everything. So shaking my head and thinking it just decided to work, I put the routers DHCP range back to 1 as I originally wanted to do. The veraplus stopped responding to ping. Huh? So I put the router’s DHCP range back to 2 and veraplus starts pinging again. That is crazy, right? I am not making any changes to the veraplus nor to the synology during this. And the DHCP range on the router when at 2 IPs is .2 and .3 and the veraplus is getting .21 from the synology DHCP server. So why on earth would changing the Linksys DHCP range affect Veraplus’s ability to talk on the network? And why is every other device also fine.
I know this may be some some down in the weeds obscure oddity but if anyone has any insight I would appreciate knowing more about this network behavior and how to overcome it.

Just the first of potentially many guesses here, but when I set up DHCP, I consider it best practice to keep its pool of addresses separate from the IP’s I assign/reserve for specific network devices.

For example, while my router can dole out IPs from its DHCP range .100 to .150, any reserved addresses will be in the .1 to .99 range.

Not sure why a conflict would occur in the setup you described, but unless I misread, you limited DHCP to a single address AND reserved that same address (per router rules) for your Vera. Meanwhile, back on Vera, she’s asking for an IP (because Vera is still in ‘DHCP’ mode?) and likely not being given one … because it’s reserved?

Thank you for taking the time to reply.
I am sorry if I wasn’t clear and will edit my post, when I said “reserved IP” I meant via DHCP reservation. That way each device has the convenience of DHCP but gets a known and consistent IP, which is needed when configuring devices to talk to each other such as with Home Assistant.
The single DHCP reservation I have on the router’s DHCP server is for another router. I have all my cameras on a another network with a static route between them. It keeps that traffic off my main network. So essentially the router’s DHCP server is enabled and not really doing much at all.
The veraplus is getting its ip correctly from the synology’s DHCP server with its DHCP reservation setup.
The super odd thing is the veraplus won’t talk on the network unless the router’s DHCP range is increased to 2 which should have absolutely no impact on the veraplus because even then its is not getting its ip from that DHCP server.
So is this problem because the router’s DHCP needs to be greater than 1? (doesn’t seem like any other device cares)
Is it because the router’s DHCP server should not be “at capacity” and unable to serve another address? (again, doesn’t seem like any other device cares)
Is there some other reason that I don’t know enough about to even speculate?

1 Like

No, are you very sure there is no other device looking for an IP from DHCP? The symptoms you describe would be pretty much perfectly explained by two devices trying to use the same IP.

But it may also be a bug in either the Vera’s firmware or the some kind of conflict with Synology’s DHCP implementation


HI, catman. All of my ~33 devices look for DHCP and all are defined with MAC listed in DHCP reservations. And there are no conflicts there. The veraplus is picking up its ip and lease from the synology DHCP server as defined in the server. It just won’t talk on the network unless the router’s DHCP number of clients is altered as described. That should be completely unrelated, right?
The one thing I may not have been clear on before is the router’s DHCP servers number of client is 2 with a range of .2 and .3 (I want this to be clients of 1 and range of just .2). The synology’s range is .10 thru .199. There is no overlap and I am trying to get the synology to be the main DHCP server. I would simply turn off the DHCP server on the router but apparently that must be on for the guest network to issue ip on that network. They are tied together, hence the “trick” to try and limit the range on the LAN side to just 1.

Possibly…read on

I’m beginning to get a sense. This would be a really bad idea in a professional network environment.

Try this as a thought, you can probably test it. Which DHCP server is faster?
The Vera comes on line a hollers for an IP.
It’s going to take one from whichever DHCP server supplies one first (see why two DHCP servers is a bad idea?)
It’s possible that when the Vera is not pinging on the IP reserved in the Synology it may be assigned the only IP from the router.

This may not account for why you get about 11 pings back from the Vera on boot.

If it were me, I’d set the IP on the Vera.

Also, generally not a great idea to use the same range for reserved IPs by DHCP as dynamically assigned IPs. Not entirely clear if you’d done this. (See above about being really really sure you haven’t got something that’s grabbing the Vera’s IP)

Definitely weird one, but cheap networking gear does weird things. Hell expensive networking gear does weird things!


you just said something I was not aware of…
If I understand what you wrote correctly, are you saying I can have DHCP reservations outside of the DHCP pool? I assumed reservations had to be defined from within that pool. If that is the case, I want the DHCP pool to be basically 0 (or 1 as I think that is the minimum) and have everything handed out by MAC and DHCP reservations. Let me see if that is even possible with either the router or the synology.

You should be able to have reservations outside the pool.

There’s a couple of issues with having DHCP reservations in the pool, not least it might be that your reserved address has been given to another device. Simple to block in the server (and it may even be in the RFC, but I just don’t know)

My DHCP pool is from 60-99
My reserved IPs are 6 and 51-55…


well holy cow… that works. I just tested with a ttgocam (esp32 cam) with ip .210 which is outside the pool range. I have been doing networking stuff for like 30 years. I don’t claim to be an expert in DHCP though; I never knew you can have reservations outside the overall pool. I have always setup my home network with a DHCP range (number of clients) and then make reservations for certain devices from within that pool. This was worked for me across 5 different Linksys routers and also the vera2, vera3, vera lite, and now veraplus (mentioned specifically since this is a vera forum).
This is a game changer for me as I want devices on my home network to always get the same ip so when I am looking at logs I know which it is by ip, etc. I also don’t want devices that are unknown to me to be on the network (DHCP obviously doesn’t prevent that but it won’t help them connect easily by just giving them an ip :smile: )

I have some more experimenting to do :smiley:

Thank you!!


Will it resolve your actual problem? :smiley:

Unless you do this stuff professionally as it were, you learn what you use. It’s just that I led people that had to use a lot more than most…

Depending on the quality of your gear you should be able to block unknown devices, if it’s really a concern


I don’t know if fixes the problem but it is an alternate way of setting things up that may make the DHCP server more efficient. Maybe I was even confusing it. I will do some playing around tonight and see if things improve with the veraplus.

1 Like

I did some more testing. The linksys router does not support DHCP reservations outside the range. So I did some research and it appears I wasn’t as crazy as I thought. Maybe I am but not on this… LOL
Linksys documentation says it has to be within the range and in fact proven on my router. Some googling on the subject and apparently MS windows server used to allow but then MS stopped allowing it also because it was “bad practice”.
Several online forums have the subject and people have differing opinions about it. So who knew, right?
And apparently there are plenty of routers that do support it, so cool.
And the synology DHCP server allows it. cool for me.
I think it is pretty cool for this reason: I have a network plan in excel and I group my devices to things like Infrastructure, Mobile, IOT, Docker (macvlan), etc. I then plan ranges for those out of the whole range, so like IOT devices get .70-.80 out of the actual entire DHCP range served. Now this is just a plan but I do put the device into DHCP reservations as we discussed but this leave gaps in the available IPs that I actually don’t want served as I also mentioned because I want to limit available addresses overall. So my next experiment is to make the range something small and then do all my reservations outside that range. I then would never have a device pop up with .76 as an example which in my plan should be an IOT device.
and… still not sure about the original problem but I am not done playing around yet :slight_smile:

Thank god! I thought it was just me :smiley:

Interesting about some not allowing it. I’ve not consciously seen one that doesn’t, but there we are. Certainly my Zywall does (as discussed) but that’s a full on commercial Security Gateway. You Synology as well.

Let us know how it goes?


1 Like

Just stating for the record that I generally avoid ever assigning STATIC (fixed/reserved) IP addresses from the range of DYNAMIC (expected to change!) IP addresses whenever I set up a router. Prevents confusion for me as well as my devices, plus anyone else administering the network behind me.
My Google WiFi router handles things best, IMHO, by permitting me to convert an address first granted by DHCP, into a Reserved address, so it stays put.
Lastly, I’ve always felt the best way to exclude unwanted connections is by blacklisting the devices’ MAC address or whitelisting those I know and trust. But be careful, that can also lead to getting locked out, LOL!

1 Like

Sensible policies for a happy life. My Zywall allows me to do exactly the same by ticking a box on a device that’s got a DHCP assigned address. But of course, that’s from the pool :wink:


1 Like

To add a little fuel to the fire, I never assign static address from within the pool in my Unifi setup.

ie I set the DHCP pool to be .100 - .254, but all my reservations are .2 - .99 That gives me 98 addresses to assign to static devices and then the DHCP can assign the other 154 address to devices dynamically.

This helps prevent me from goofing up and assigning an IP address that DHCP wants to use.