NX-584 Enrollment


I have just purchased and connected an NX-584 module for my NX-6 Alarm panel. My intention is to integrate with my Vera2 Controller. Can someone help with the steps I need to follow for enrollment of the device through the alarm panel? I understand and get good results from the following instructions:
To enter the Program Mode:
Enter [*]-[8] (all of the function key LEDs will begin to flash).
Enter the “Go To Program” code (default is [9]-[7]-[1]-[3]). If the code was valid, the
Service LED will flash, and the function LEDs will illuminate steady, indicating the device
to program should be entered.
Enter the address of the NX-584, which is [7] [2] followed by [#]. At this point, the Armed LED
will illuminate while it is waiting for a programming location to be entered

What I need help with are next steps and what the programming locations are. I have no idea what this means:
Enter the desired programming location followed by the [#] key.
The Armed LED will begin to flash while a programming location is being entered. If this
is a valid location, the Armed LED will extinguish, the Ready LED will illuminate, and the
binary data for the first segment of this location will be shown on the zone LEDS.
If the desired location is the next sequential location, press the [POLICE] key.
If the previous location is desired press the [FIRE] key.
If the same location is desired press the [AUXILIARY] key.

Hi dwogan,

I recommend that you use the Caddx forum for questions about this alarm system. I saw your post over there already but it was a bit vague so I wasn’t able to usefully respond. This post is more specific so we can probably achieve more with it.

If you’ve got as far as you have then you’ve already physically connected the NX-584 and you’ve enrolled it with your NX-6. Good.

Next you’ll need to refer to the NX-584 installation manual, which should have come with the module. If not, you can find countless PDF copies online. It’s about 12 pages long. I’m going to refer to it in my message.

You need to go through each of the memory locations of the NX-584 and make sure that the settings are correct. It sounds to me like you have the LED keypad instead of the character LCD keypad, so I’ll tailor my text accordingly.

Referring to page 7 of the PDF:

Go to location 0: [ 0 ] [ # ]
Ensure that LED 1 is OFF: Press [ 1 ] to toggle it if necessary.
Save: [ * ]

Go to location 1: [ 1 ] [ # ]
Read the baud rate from the lit LEDs. For example, leds 3 and 1 on are binary 00000101 = 5 meaning 19200 bits per second. You can change this value by pressing a number 1 to 8.
Save: [ * ]

Go to location 2: [ 2 ] [ # ]
Ensure the first set of LEDs are ON: 2 5 6 7 8. Press the matching number(s) to toggle. Additional LEDs may also be on.
Save: [ * ]
Ensure the second set of LEDs are ON: 1 3. Press the matching number(s) to toggle. Additional LEDs may also be on.
Save: [ * ]

Go to location 3: [ 3 ] [ # ]
Ensure the first set of LEDs are ON: 2 4 5 6 7 8. Press the matching number(s) to toggle. Additional LEDs may also be on.
Save: [ * ]
Ensure the second set of LEDs are ON: 1 3. Press the matching number(s) to toggle. Additional LEDs may also be on.
Save: [ * ]
Ensure the third set of LEDs are ON: 3 5 7. Press the matching number(s) to toggle. Additional LEDs may also be on.
Save: [ * ]
Ensure the fourth set of LEDs are ON: 4 5 7 8. Press the matching number(s) to toggle. Additional LEDs may also be on.
Save: [ * ]

Go to location 4: [ 4 ] [ # ]
Note down which LEDs are on for completeness.
Save: [ * ]

Now you need to exit out of programming mode by pressing [ EXIT ] two or more times.

Your next challenge will be to connect the NX-584’s serial port up. There are many conversations about that already on the above-mentioned forum; it seems to be the most common stumbling block. Read them. In particular pay attention to discussions that mention “jumpers”.

Thank you, that was very helpful!
I’ve gone through the rest of the instructions on connecting the NX-584 to my Vera 2 but get the message “Caddx NX584 Security System[16] : Failed to set up interface” in the device list. I’ll check jumpers, etc.

Still no luck. I’ve connected to the NX-584 with putty and don’t seem to get any data from it.

Spelling out what I think you’ve done, so that we agree we are talking about the same thing.

You’ve connected the NX-584 to your main panel, and the LEDs on the NX-584 {are/are not} blinking.

You’ve configured the NX-584 to operate at {number} bits per second, in binary mode.

The jumpers on the NX-584 are in {positions x4}.

You’ve connected the NX-584 to a real computer using {describe the chain}.

You’ve walked past a security sensor to trigger some output from the NX-584 serial port and you see {describe} in the PuTTY window.

Sorry to insist on so much detail, but these days I assume that this is the first time that a user has ever connected an RS-232 device.

No I’m sorry for not providing any details! I’m sure “It doesn’t work” won’t help!

I have connected the NX-584 to the main panel (NX-6v2).
The LED’s on the NX584 are as follows:
DS1 and DS4 blink. DS6 is solid.
I’ve configured the NX-584 from my keypad per your earlier instructions. I’m showing LED’s 2 and 3 lit for the baud rate which I believe is 38.4k bps.
The jumpers on the NX-584 are as follows:
J7 and J9 are default. (J9 Jumper furthest from the DB9 and J7 closest to DB9)
J10 and J8. I’ve tried every configuration I could. Both close to the DB9 and furthest from the DB9 connector as well as alternating on the board.
I’ve connected the NX-584 to a computer using a USB to Serial adapter. I used the Prolific USB to serial driver for Vista and when I connect COM7 is recoginzed. I then open a PuTTY session, open a door, and don’t see any data. The PuTTY window just has the cursur in the upper left corner.

One thing to mention. My alarm system was here when I bought the house. I don’t have any idea what the PIN is to activate/deactivate the system. The door chime works when opening doors/windows.

That’s all good information. From the LEDs on the NX-584 it confirms that there is no problem between NX-584 and panel. Instead the problem is between the NX-584 and the computer. Exactly what, that’s still to be decided.

Perhaps the USB-to-serial adapter is at fault. Aside from driver issues, they might not be getting enough current from the USB host (the computer) to step up to the 12 volts that RS-232 needs. I had one that would just not transmit until I inserted a powered USB hub in between. All the while it happily insisted to the computer that there was no problem. Just no bytes being transferred.

Next?and you’ve glossed over this so I have to guess?is the cable or plug you have in between the USB-to-serial converter and the NX-584. You must have something because the NX-584 has a male DB9 plug, and so do all the USB-to-serial adapters I Googled for pictures of. If that cable swaps transmit-and-receive pins, or RTS-CTS pins, or not, then you have to compensate for it, or not, with the jumpers on the NX-584. Or the cable is just plain broken.

Speaking of jumpers: by far the most common configurations are to leave all four in their factory setting positions, or move them all to the opposite positions. Moving just some of them is almost certainly wrong, unless you have additional knowledge of the pin crossover in the DB9-to-DB9 cable.

Or there’s a small chance that something on the NX-584 board itself is fried. But only conclude that when you’ve eliminated the other likely culprits.

It won’t matter that your alarm is disarmed for testing. The NX-584 reports every zone change no matter what the partition’s arm state is. You should see some text in the PuTTY window when you open the door.

Try messing with the jumpers again based on my advice. Try beefing up the current you supply to the USB-to-serial adapter by using a hub with a good power supply. After that you will be reduced to replacing one component after another. In the past it’s been about 50% the USB adapter, 30% the cable. 20% some other bit.

And THEN you can connect to Vera. Which may result in a new set of problems. But that’s future talk.

I think my problem may be what you experienced with low power on the USB connection. I’ve been using my laptop on battery. I just tried my laptop while plugged in and now see traffic in my PuTTY session. I’m seeing:
I think I might be getting closer!

I do have a USB to serial adapter and a DB9 gender bender.

That’s a bit better. Not what I expect to see but at least you’ve got something. You should be seeing stuff appear every 1.5 seconds. That’s the retry period if the computer doesn’t acknowledge a packet. If you get text appearing at a faster rate then there may be interference introducing noise onto the serial line.

You might like to experiment by going back to the keypad and switching the NX-584 temporarily to ASCII mode. At least then you’ll know that you’ve set the baud rate right, because you’ll start to get readable text in PuTTY. Naturally you will have to switch it back to binary before you attach it to Vera.

This is what I’m seeing when I changed over to ASCII mode:

Should I see anything different when opening/closing a door?

[quote=“dwogan”]This is what I’m seeing when I changed over to ASCII mode:

Should I see anything different when opening/closing a door?[/quote]

That’s good. That’s a System status message, which it’s repeating until the computer acknowledges the message. Since you’re not sending the magic acknowledgment packet it’s continuing to send the same message over and over. Which is masking any zone status messages from you opening the door.

It’s time for you to put the mode back to binary and plug in the Vera. Note that Vera’s USB port is borderline with supply current so you might need a USB hub.

So close but so far! I get intermittent connectivity. 2 days ago I noticed the NX=584 was discoverd properly in Vera. I started adding zones manually and during the third zone add I went right back to “Caddx NX584 Security System[18] : Failed to set up interface.” I’ve tried adding a powered USB hub but get the same results. It seems to load OK after several Lua refreshes then drops back to the failed to setup interface error. Any other ideas?

The serial protocol is stateless, so the plugin should behave the same each time. Intermittent failures are usually because of hardware. Here are some things to try.

Use a slower serial speed. Personally I use 9600 bits per second.

Swap out components, specifically the USB-to-serial adapter and the gender changer. They may have pins that only mostly connect. Or that particular USB-to-serial adapter may have a firmware bug. If you were using a Prolific adapter, try an FTDI one or a Silicon Labs one.

Turn on Debug to the Luup Log in the main device’s Configure tab, then catch the serial conversation in the Luup log (you’ll need SSH access to get to this file) while you press the Vera Reload button. This will definitively show if there’s an issue with noise on the line forcing bad checksums and retries.