Not receiving alerts on android - LAN mode - Possible fix

Here is a little background on the issue I was having with Vera Alerts running in LAN mode.

I have a Droid Charge running JellyBean, HTC Thunderbolt running ICS (previous phones), and a Nook color running Jellybean that I was using to play a beep when any of my doors opened. When I first set everything up it worked great and was very reliable but about a month later started having issues with the phones not able to receive the alerts from the Vera. After putting Vera Alerts in debug, looking at logs, trying different ROM’s and kernels on the phones I would get the same issue of Vera Alerts on the Vera not able to connect to the phones. The only way to get the phones to work was to disable WiFi and re-enable it and that would only last a few minutes and you would have to cycle WiFi again. I was about to give up until I ran across a post on an Android forum about an issue with WiFi not working properly. The poster stated that his WiFi showed connected to router but he couldn’t access the internet until he cycled his WiFi. FINALLY, someone with the same issue that I am having and it looks like there is a solution. The solution was to take your router’s WiFi out of mixed mode (in my case N+G mixed) and set it to N or G only.

I haven’t thoroughly tested this fix to say it’s an Android OS bug, phone Wifi chipset issue, or even the DD-WRT firmware running on my Linksys E2000. It’s just strange that every other WiFi device in our home worked great when the router was in N+G mixed mode but the Android phone’s running Vera Alerts could not receive packets from the Vera. Whatever the issue may be my setup is working again and I’ll keep my router in N mode only from now on.

I have the same exact issue with my set up. Unfortunately, trying this work around didn’t fix my issue :cry: