No Z-Wave?

I just got a Vera V2 and tried to install it.
However, in the dashboard it says:
ZWave: No Z-wave

I tried to ignore it and tried to get it to recognize some z-wave devices so I hooked the V2 to the battery pack, waited a minute for the z-wave light to turn on and then pushed the z-wave button on the back to get it flashing.
However, the light just went off and did not start flashing… After about a minute it turns on again.
Do I have a faulty unit or am I messing things up myself?

additional info:
Z-Wave device info: undefined
port: /dev/tts/1

When tryinhg “reset z-wave chip” under advanced:
Command failed: Z-Wave not ready

Tried UI2,3,4 now. All seem to have the same problem. It looks like the internal Z-Wave does not get detected.
Is there Any way to force or reset it?

What version firmware are you using.
I would go back to UI-4 and start from there.

I would try including devices directly from vera using the PC interface , Vera on ac power not using the battery.

I Think there is a bug as several folks have complained about this. I have not had the time to replicate this myself.

If you get it working let us know. In any case dont go and power it down submit a ticket under the advanced / tech support tab. Vera will send info and may log the problem.

I am now back on:
Still the same problem. (ZWave: No Z-Wave)
It looks like there is no way that Vera (v2) detects the internal Z-Wave.
I am upgrading/downgrading with factory reset. So it should not keep any old settings.

I also got an AEON USB Z-Wave stick to play and experiment with. The stick has no trouble in detecting the z-wave devices around the house at all. Vera also does not detect any devices when I use AC power and the build in setup It never detects any device in step 1…Which seems correct as it also does not seem to see the internal z-wave

Another thing I noticed is that it gives an error message every now and then when it tries to save data:
“Error saving data, status code: 503”

I think you are using the wrong firmware type meaning it’s for VERA1

I don’t know what kind of issues that might have made I have always used the correct firmware for the device. TRX is Vera1 and squashfs is for Vera2

but you should be using this:

If you have problem loading that firmware there is a recovery tool

Thanks, fixed it and everything is working now… :slight_smile:

What was the problem and how did you fix it? Always helpful for those of us who may run into this problem. Thanks.

There was a bug in versions prior to 1.1.1047 where the Zwave chip wouldn’t always get flashed. If you had a unit that delivered with 1.1.1008 (which most do) then you had a high chance of seeing this problem. In later versions they either fixed the Zwave chip flashing logic or put in some kind of retry method.

Not sure what caused the initial problem.
However, after it failed to work I tried various firmwares to see if that solved the problem and this for sure made it worse.
Mainly because I loaded firmwares that ended with .trx and those are for Vera 1 boxes and are not meant for my Vera v2.

I do not see why there was no safety check and why it did accept V1 firmwares. Once the V1 firmware was on it, it refused to take the V2 versions so I had to do the recovery which worked and brought it back to life…

Well, at least somewhat back to life. I now often have “Failed at: Purging Associations”. It does have moments when everything looks fine. Also the link between the V2-UI4 and ivera on the ipad does not seem that smooth…
I will try it without ivera for a bit and see how that goes. (although I dont have a handset at the moment)