New Vera3, pretty much unuseable

So, the Vera3 was delivered this afternoon. I had gone ahead and installed 2 switched outlets ahead of delivery so I had something to talk to when I got things going. I will be adding other devices once things work as they should. After unpacking, plugging in, etc I went ahead to make my first connection to talk to the vera. i typed in, was taken right in to the device and was able to add a switch to control. AWESOME! that is the only thing that works though.

I cannot log in to the unit to do anything else, it says I dont have permission. I went through and registered of course and it then looks for my unit and says it cant find it. I click the link for it to search again and it says it finds it, then I click the link to “go to device” and it takes me back to my device and says I dont have permission, then bounces me back to the initial log in and find my device page.

Advanced settings just sits on a loading screen indefinitely (max i let it try for was 45 minutes while making some food). trying to add an administrator user under preset modes also yields a loading please wait that never goes away. I cannot change anything, I cannot do anything, other than turn on and off the lamp plugged in in my living room. Help?!

For more clear info… I get taken to to Login once logged in. I get the message “Could not find an unassigned Vera on your network. Please click here to help you detect it.” and “No devices have been added to this account”

I click the “click here”

It takes me to “” and I tell it I have a Vera3

it takes me to “Let's find your Vera - Firmware update” and I click next because it is plugged in and I am using the internet through the vera right now to make this post.

it takes me to “Select a device - Firmware update” with a device listed w/ serial number and external IP. I click “setup”

it takes me to a page saying my firmware is up to date running 1.6.641 and i click “go to unit”

It takes me back to my unit but this time from my external IP address.

if I try to do anything I get the log in screen and then told “this user is not allowed to control this device”

at this point go back to the top… it is a cycle

I am also beginning to think my vera is registered to someone else…it has a user “sjledet” and of cousre it says it cant fin an “unassigned vera” on my network.

How is your vera connected to the internet?

Have you tried contacting support?

Please send me a private message with your vera serial number and the information on the back.


I tried reaching support. I got a reply email at 03:34 EDT also asking for the serial number.


You are awesome! Thank you for your help. I am now able to get in and around this thing to begin my work on it.

As a note to anyone that finds this while searching later because you have the same problem. Apparently this unit had been previously registered to someone else, it was associated with another account. It was reset to allow me to take over it. If you have this problem, get mcv.vlad, or tech support to reset and then follow their instructions.