new vera2 wont power up

I just received my vera 2 and get nothing when i plug it in. I hate to think its DOA but considering all available options, I dont know what else it could be. Just wondering if im missing something or if anyone has heard of this before?

Any lights at all? Also which power adapter did you use? The smaller one is for the battery.

nothing at all. i used the larger power supply in a plug that i know is hot. tried multiple plugs and even the battery option that comes with it. nothing at all. I cant believe that a brand new unit with no moving parts would do this… and with no power, there is no way to connect to it in any way.

So maybe charge the battery and see if it comes up with that attached. At least then if it does you know what it is, and can perhaps get a replacement one sent, or use a spare one from somewhere else for the time being. If it come up on battery then you could at least start to set things up and get to play with your new toy briefly!

I charged the battery pack for 10 hours and tried it as well. no joy. nothing.

Sounds like you just have to wait for a new one then, as without lights its sounds dead as a dodo!