New install on Raspperry Pi, AltUi not loading

I just installed openLuup on my Raspberry Pi, fresh install. I followed the PDF directions, and I’m getting the following when I go to the URL (IP:3480)

No handler for data_request?id=lr_ALTUI_Handler

What happens if you go to


I get an about page with your username on it :slight_smile:

OK, a bit more information:

  • if you go to the Devices pages from the openLuup menu, which devices do you see?
  • were there any error messages during the install process?
  • what version number are you running (It’s at the bottom of every page.)

I suspect that the issue is related to some recent GitHUb URL redirect changes, and a new version of the AltAppStore plugin is required to fix it. The easiest way is to go back to the install process (in a clean directory) and install the latest development version, by using the command:

lua5.1 install.lua development

This should completely fix the issue.

Okay, confused here. I don’t know how to get to the openLuup menu.

I followed this guide

I made got through part 3, Making openLuup run at system boot time. I’m running this on a Raspberry Pi, so I followed the instructions in the appendix for Raspberry Pi
I’m getting stuck when I go to Linking to Vera, because the AltUi on my Pi is giving me that error when I click on the link.

Going back to a clean directory, the lua5.1 install.lua development command didn’t work for me.

root@raspberrypi:/etc/cmh-ludl# ls
root@raspberrypi:/etc/cmh-ludl# wget
–2020-04-14 16:31:34--
Resolving (…
Connecting to (||:443… connected.
HTTP request sent, awaiting response… 302 Found
Location: [following]
–2020-04-14 16:31:34--
Resolving (…,,, …
Connecting to (||:443… connected.
HTTP request sent, awaiting response… 200 OK
Length: 2315 (2.3K) [text/plain]
Saving to: ‘openLuup_install.lua’

openLuup_install.lua 100%[============================================================================>] 2.26K --.-KB/s in 0s

2020-04-14 16:31:34 (9.56 MB/s) - ‘openLuup_install.lua’ saved [2315/2315]

root@raspberrypi:/etc/cmh-ludl# lua5.1 install.lua development
lua5.1: cannot open install.lua: No such file or directory

So sorry, a typo on my part. The command should obviously be:

lua5.1 openLuup_install.lua development

I’ve just tried this in a clean directory. It works.

I should have caught that as well.

Even though the service was stopped, it thinks there is another instance running.

root@raspberrypi:/etc/cmh-ludl# lua5.1: openLuup/init.lua:277: openLuup - is another copy already running? Unable to start HTTP server on port 3480
stack traceback:
[C]: in function ‘error’
openLuup/init.lua:277: in main chunk
[C]: ?

Not sure where the web server config is for this is located.

Just visit


to stop the running instance (which is the original install, without AltUI.)

Okay, great. I just restarted the Pi, and that did it as well.

I installed with the dev tag, and now it’s coming up as expected. Thanks for your help. Now to play around and see if I can develop my first app.

1 Like

OK, that’s great news.

Worth, perhaps, taking another quick look at the openLuup User Manual just to see if there’s anything of interest for you there.

Good luck.

I have a specific purpose in mind. I have a Kwickset Kevo deadbolt, that doesn’t exactly have an open API. The SmartThings and Home Assistant crowd developed a python script that can lock and unlock the deadbolt, and get it’s state via reverse engineering. I got the script to run on my Pi, however, I need a way to call the scripts and turn it into a virutal switch for Vera, so I can lock my doors in different modes via Reactor or similar. I think openLuup is my only hope. Since openLuup is on the same Pi, I would think running a python instance from openLuup should be pretty easy. Pretty sure that’s how the Haas folks do it.

1 Like

Interesting! Let us all know how you get on. Don’t hesitate to ask for openLuup help (or any other… the forum is a great resource.)


I also need some help. I would like to install openluup on my pi where Z-way is already running.
The installation always fails with the message “removing of ‘www/altui/altui*’ is not possible. File or folder not found”.
If I call “ip:3480” in the browser, just a single line on the top will be displayed “Waiting Initial Data”.

What did I wrong?

You can ignore the error. i have it on mine.

Have you configured vera_bridge or installed z-way?

I suspect that this is a permissions error in on the file or folder, but I’ve never seen it.

What version of openLuup have you installed? Would recommend that you use the latest development branch version. Since you’ve presumably done nothing to configure the system yet, you could simply start over with a clean cmh-ludl/ folder and run the install script with the additional parameter development, thus:

lua5.1 openLuup_install development

Thanks a lot for your reply.
I tried as you advised. But the result is the same. I tried to install with “sudo” also.

This is where logs become useful.

Go to


with the correct IP.

Go to the logs menu, and look at both the Startup log and the regular one. Any errors there?