New Ezlo plus Stuck at Set Up

Set up wired after the wireless setup failed. Router shows the ezlo has an ip address, and I can Ping it. Lights on front of the device constantly flashing. On the Vera app it shows “Connection OK” with green light. Click on the green “Connect” icon I get “Error there was a problem with the connection to the controller. Please check the internet connection…” I have power cycled it twice with the same result. My Vera plus unit works fine on the app. Not real impressed with the Ezlo so far. Any suggestions gladly accepted

Here is my suggestion, wait a little it may be updating firmware. I find Ezlo to be very slow at moment and have had my own issues over last couple months since my Vera died. I find that when you think it’s “hung up” it may be updating itself. The fact you see it with ip address is good. What is color of light on front of unit or is it blinking

The light actually appears orange/blue. I did a factory reset and still have same issues. The wired set up requires scanning the bar code since the Ezlo was not automatically recognized. I’ll let it sit for awhile to see if that helps.

I am hoping to use the Ezlo to replace aging Vera units in rental properties. May need to re-think

You may want to take a quick read through this New Firmware it may help moving forward.

You may also want to do a reset if unit was previously used

Also found this, may be helpful. Ezlo plus cycling color lights - #3 by Benvolio36

Thanks for the links! I checked them but am still stuck with a non- functioning device. It looks like it is DOA.

Sorry to hear that, did you try a factory reset?

Factory reset twice. Checked EBay for a Vera plus; None!

Hello @clawmd,
We are really sorry for the inconvenience you are experiencing. We have opened a support ticket to gather information on this issue and get it solved as soon as possible. We look forward to your reply.
Kind regards!

Hello @clawmd.
We are checking this issue now.
What is the serial number of your hub?

Serial# 90000783.
Will arrange phone call with tech support.

Still no solution. Currently the device displays a red color regardless of the action; factory reset does not change it. I suspect it has “bricked.”

Sounds like my vera plus might suddenly have some value. I will let everyone know if I decide to let it go. Sounds like some people could really use it. I have been following in case there was going to be a Ezlo replacement, but it doesn’t sound like it.

I have been attempting to get support (via email) for my new Ezlo Plus controller. I was elated to find that I could link it to my existing account - concurrent with my existing Vera Edge controller. I was further successful at pairing my two thermostats. Yeah!!! Unfortunately, that’s then end of my good news.

I have not been able to get my new controller to pair with any of my other devices (of which there are many!). Even the simplest GE smart plug will not pair. Yes, I unpaired them from the Vera Edge, before attempting to pair them with the Ezlo Plus. An example is the JASCO/GE ZW3103 Smart Dimmable Switch - of which I have 6!

Vera support has been useless, if they even respond. I finally got them to respond via a threat, and request for a refund. They quickly responded to that, indicating that they were sending my request to the RMA department.

I have indicated, repeatedly, that I just need to help getting the new controller set up, and running with my existing devices. That includes after they indicated that I would get an RMA (which I have yet to see.

I am very sorry if I am posting in the incorrect area. I am pretty desperate at this point! I have been with Vera since early 2015, and really don’t want to change. What do I need to do, to get somebody’s attention?

we’ll make sure you have some support! Sorry they have been slow…not acceptable.



We are ordering right now and as soon they arrive, we will integrate them into our system.
We are regularly updating list of newly integrated devices and also taking an integration request from our customers.

We will need some time to deliver them and integrate, but we will do our best to help you.

If you have any other devices that can’t connect to Ezlo platform, please inform us and we will also investigate this case.

Thank you,
Ezlo Integration Team.

Hello @David_Forsberg,
What is the serial number of your unit?
Can you add more details about the issue?
Was the inclusion process finished completely or the unit stuck in the middle of inclusion?
Also, it would be great to make a session together to get access to logs.
Check your pm please.

Did you get yours working?

I just connected my ezlo plus. My first few attempts via wireless and wired didn’t work, the unit would only blink orange. It finally connected and I got it added to my account, but it’s offline. That’s different from your issue but could be the same underlying problem.

Edit: Correction. It’s offline on the website dashboard but I can connect via the phone app but unable to update any settings.

Never got it “online” in the phone app. I’m able to get into the config settings using SSH and it appears to be functioning. Nobody has been able to figure out how to correct the issue by editing the accessible files on he device; not even the guys who developed the firmware. I will be returning the unit. Hopefully the issue is rare. Your issue may very well be related. Difficulty with initial set up is discouraging. I will update this post if I have any solutions.

Thanks for the reply. Offline and inaccessible via web login but Online via phone app. Doesn’t make sense. Initial setup back in the old vera lite UI5 days was kind of a pain too but definitely feels more discouraging now. My vera lite still works great but ran out of space and even though it will still control some devices, the devices themselves disappeared from the UI. I was hoping this would be an upgrade that could last another 5-10 years for me and I like the move to linux. BUT I’m concerned about the accessibility more now after this initial setup. At least you can return it. I bought mine on ebay and unfortunately didn’t get around to attempting install until after the return period.

I’m just going to leave mine plugged in without doing anything else for a few days and report back then.