Netatmo[103] : Startup Lua Failed


I did install the netatmo plugin via install aplication it says Current Version: 4.20160128. Vera plus with latest firmware + UI7.

I did reqister my system to netamo web site and did get values for (username,password,client id, client secret). I did enter them to device variables (text input checked).

Now I am getting the error “Netatmo[103] : Startup Lua Failed” what am I missing?

You should get an “authorisation error” with wrong credentials, IIRC.

This looks like an install configuration error… where did you load it from (MiOS store?)

Yes mios store. Should I delete and reload the plugin?

Do you have the skill to download the latest from GitHub?

I can try. 8)

  1. I did copy the zip file from github
  2. upload loop files to vera via Apps -> develop apps -> load files -> upload
  3. copy icons (that where missing) to /www/cmh/skins/default/icons

reboot twice

same error still

I did study the log file and I decided to change my “station name” to “weather”. It used to have national characters .

reboot and It WORKS ;D so that was the problem.

0 03/22/17 19:30:30.706 luup_log:103: Netatmo: admin.unit = 0 <0x76ee3520>
50 03/22/17 19:30:30.706 luup_log:103: Netatmo: admin.pressureunit = 0 <0x76ee3520>
50 03/22/17 19:30:30.707 luup_log:103: Netatmo: admin.windunit = 0 <0x76ee3520>
50 03/22/17 19:30:30.707 luup_log:103: Netatmo: station name: Weather <0x76ee3520>
50 03/22/17 19:30:30.708 luup_log:103: Netatmo: module name: Indoor <0x76ee3520>
50 03/22/17 19:30:30.708 luup_log:103: Netatmo: module name: Outdoor <0x76ee3520>
50 03/22/17 19:30:30.709 luup_log:103: Netatmo: creating child devices… <0x76ee3520>

My other vera that has only plugin from mios store works now also.


Hi, I also get this error: Startup Lua Failed. I downloaded from apps in UI7, put in all the information, but cannot get it to work. Any advice? Not sure if I understand the fix above, can anybody explain?


Do you have any non-alphanumeric characters in your password?

Thanks for the quick reply. No I have small/big letters and numbers.

Does the name on the app created at the connect site have anything to say?

No, nothing at all.

Did you have a problem with getting the latest files from GitHub?

I just installed the app though the Vera UI7 interface. Not sure how I do it manually? Is it in the Apps, develop apps, Luup files and then upload file? Do I upload all the .xml, .json and .lua files in that folder?

Thanks for any help

Tried a bit more - do not understand how I upload the files and get the plugin without going through the Apps in UI7.

But I removed the app and reinstalled it, rebooted the vera, then put in my username, pw, client id and clientsecret. It still doesn’t work but now it just says:
“Netatmo : Authorisation failed”. I have checked the username and pw a million times and it is correct. The pw has only large and small letters as well as numbers. The username is my email address. So where should I go from here?

Ah, the username may suffer from the same issue. This is an encoding error that I have never got to the bottom of in the API.

What do you mean? Its not possible to have a username which is not an email address is it?

Finally it WORKS!!

My previous username at Netatmo was "" and since you mentioned that it might be the same problem with special characters for the username as well I change to another email address "" - and now it works! Thanks for the help. ;D

That’s great! Sorry for the inconvenience. Must dig into that properly some time. Good luck.

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules