Neo CoolCam SOS Keyfob device (Z-Wave)

A Neo CoolCam SOS keyfob device just turned up here from China.

First I tried as a test, to add the device to the Ezlo Plus that didn’t go well see here.

No down to business on my production Vera Plus hub running Vera firmware !

The device was added as a Generic IO device with on / off buttons, so not a good start.


I then changed the following items in the devices Advanced - Params tab:


From: urn:schemas-micasaverde-com:device:GenericIO:1
To: urn:schemas-micasaverde-com:device:SceneController:1


From: D_GenericIO1.xml
To: D_SceneController1.xml


From: D_GenericIO1.json
To: D_CentralSceneController1.json


From: 11
To: 9


No change remains as: 0

The device then looks like this instead:


I then noticed that a child device had also been created as a motion sensor device.


The red SOS button is actually tripping the child motion sensor device.

So these are how the buttons map to the button numbers in Vera

Looking at the “Parent” device and the “Select Scenes for device buttons”

I then saw this:


There are 4 buttons on the keyfob, however enter 3 and click the Save button.

I then saw this:

I then assigned some of my existing Toggle scenes as a test:

After reloading the Luup Engine and pressing the buttons on the keyfob the scenes do run OK.

Note: When you press a button on the keyfob a red LED lights up and the keyfob also bleeps.

So what to do with the SOS button? I have already setup a “Panic Button” scene, so I renamed the motion sensor child device.


And in my “Panic Button” scene I added this motion sensor as the trigger to run the scene etc.

Now where is the battery indicator icon ?

Looking in the parent devices Advanced - Variables tab, I could not see any BatteryLevel variable. So I rebooted Vera from the Settings - Net & Wifi menu. After Vera had rebooted and after refreshing the web browser, the parent device and the child device were still not showing a battery level indicator.

And looking in the parent devices Advanced - Variables tab, I still could not see any BatteryLevel variable.

So let add one, in the parent devices Advanced - New Service tab, add a new variable.


New Service: urn:micasaverde-com:serviceId:HaDevice1
New Variable: BatteryLevel
New Value: 0

Click the “Add” button and then the “Reload Engine” button.

The parent device then looked like this:


So can we now poll the keyfob to get the current battery level ?

In the parent device go to Advanced - Commands tab and press the “Poll Now” button then press the SOS button on the keyfob 3 times quickly.

It should say it has successfully polled the device.

If this is correct then the supplied battery is already very low ?


I did purchase already a spare battery as they are an unusual not readily available battery type CR3032 and I wasn’t sure if the keyfob would come supplied with a battery or not.

I put in the new battery and reloaded the Luup Engine and now its showing as 100%


Testing the supplied battery with a battery tester, it is showing as full power so maybe its still good.

Attached is the user manual for this keyfob which I didn’t read :smiley:

Looks like there are some parameter settings you can set, I will take a read of the manual later and update if there is anything I think might be useful.

Keyfob manual.pdf (2.0 MB)

OK this might be interesting:


I wonder if you set parameter 3 to a value of 1 instead of 2, could the red SOS button be then used as a standard scene controller button ?

I’ve set the parameter:

I then for now removed the SOS button as the trigger in my “Panic Button” scene.

I then change the “NumButtons” variable on the parent device from 3 to 4 buttons.

And set button 4 to run some other Toggle scene temporarily.

When I press the red SOS button it didn’t run my “Fireplace Toggle” scene as I hoped it might.

The child motion sensor does still trip however.

When I press button 2, I see this in the log:

Device_Variable::m_szValue_set device: 552 service: urn:micasaverde-com:serviceId:SceneController1 variable: sl_CentralScene was: 2 now: 2 #hooks: 3 upnp: 0 skip: 0 v:0x1270318/NONE duplicate:0 <0x76b42520>

When I press the red SOS button I am not seeing anything like that. I see this instead:

ZWaveNode::HandlePollUpdate_Alarm node 104 device 552 v1type: 0 v1level: 0 source: 0 status: 255 type: 10 event: 2 parms_len: 0 parms: 2 code: (null) <0x76b42520>

So the red SOS button still appears to be acting as an Alarm Alert event.

So this parameter 3 is not working as I expected.