My Notes on remote access for UI6

I spent a lot of time like other to figure out all of the details of connecting to the UI6+ MCV remote access servers.
Attached are my notes for finally succeeding. I hope you find them useful.

There is some assumption that you already know about UI5 access and are familiar with the MCV requests you can make of your Vera.

thanks so much richard !
did i mention we all love u ? well we do :smiley:

To add to Richard’s notes. You can also ask me questions as well. I am more than willing to help others understand the MMS authentication.

  • Garrett

We love you too garrett :smiley:
im gonna give it a try to translate this into .NET so if anyone needs that just ask :slight_smile:

Yep @Garrettwp helped me understand a few detail.

Great notes! Very clear, and well explained.
I’m trying to hit the auth URL you give, from code, and I’m getting 404’s. Here’s the URL:

(obviously with the username / hash changed).

Is that server live at the moment?



  • Garrett

I just checked and autha11 works.

autha works now but does conform to the long term rollout strategy when they have to increase servers to handle demand as well as fault tolerance.

My notes are based on the most recent spec … After @garrettwp fought his way through the process.

Thanks both - using makes sense assuming they’re going to loadbalance later.
I’m still getting a 404 with that server though, so I must be doing something wrong; does my Vera have to be running UI6/7 before this will return a valid result? I’m still on UI5 at this point, and was more wanting to get a head start on playing with the new authentication mode.

UI6+ accounts are different then UI5 accounts.
You can create an account for UI6+ at … but without a device on UI6 you will not be able to get very far … you should be able to authenticate your account without a Vera.

Ok, that also makes sense. I created an account, and unfortunately still get the same result.

Possibly I’m doing something idiotic, so a couple of questions:

  • Would you expect to see the JSON string if you tested the URL in a browser? I’ve tried both code and browser, and get 404s.
  • I’m assuming that there shouldn’t be angle-brackets around the username / hash in the URL, right?
  • I’m also assuming that the hash is the hex result from the hash, is that right?
    I.e. on this page:
    …my hash should be the same as the SHA-1 entry?

Otherwise, I’m assuming that possibly the account takes a while to roll through the system.

…and boom, I figured it out, I was in fact doing something idiotic (I’d missed the seed, which you clearly spelled out!).
Thanks for the help!

There are a lot of steps and a lot of little details to get right … that’s why it took @garrettwp a while to get this working (he took the lead) … even with the MCV documentation it took me a while and some help from @garrettwp … that’s why I wrote the notes.
Let me know if you want to improve upon them … I can update a modified version.

Well thanks to you both for putting it together. It’s people like you guys that make MCV’s product usable for the rest of us!

That was really, really helpful and detailed.

I’ve added remote UI6 support to an existing iOS library using your instructions. Here is my fork on github:

Once I get everything cleaned up and add support for local access, I’ll request a merge to the main fork.

How did you find/get the PasswordSeed? Why is it static?

Because it’s defined in the spec!!!

After their last update, has anything changed on authentication? I had this implemented and working but now it is returning:

WWW-Authenticate: MMSAuth error="invalid session"

NOTE: That the original notes need some changes as a result of MCV server changes: gets changed to: gets changed to:

[quote=“RichardTSchaefer, post:19, topic:181032”]NOTE: That the original notes need some changes as a result of MCV server changes: gets changed to: gets changed to:[/quote]

Thank you.

Could more have changed? I’m running UI7 Firmware v 1.7.388.

I get the MMS Session Token for all servers just fine, but when I start making calls and/or requests I get nothing back but errors.

For instance:<PK_Device>/port_3480/data_request?id=variableget&Variable=PK_AccessPoint 

Gives me the error: “(403) Forbidden” even as I’m pretty sure that I have and is using the right MMS Session token that I gor back from “” and is using it correct in a MMSSession header .

Similar but a little different error messages with::

https://<Server_Account>/account/account/account/<PK_Account>/devices where <Server_Account> = “”. Again I get the MSS Session Token for the server just fine, but I can’t access the server anyway. The error I get is the error: “(404) Not Found.”

The "funny part is that if I obmit the “/devices”-part and only do a request like this:


I then get a json string back that looks like this:

{"PK_Account_Parent":<xxxx>,"PK_Account_Parent2":1,"PK_AccountType":5,"PK_Oem":1,"Server_Event":"","Server_Event_Alt":"","Server_Account":"","Server_Account_Alt":"","Phone": [{"PK_Phone":<yyyyy>}]}

Any ideas? I’m pretty stuck here :frowning:

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules