My EZLO Plus can not tell time

My EZLO Plus can not tell time. When I received our new EZLO device, I started by setting up a number of devices and scenes to match several of those that I had on our Vera Plus, but quickly found that none of them operated when they were scheduled to operate. Manual events worked great. Timed events? No!

While trouble shooting, I pressed the “reset” button on the EZLO Plus, not realizing that it would wipe hours and hours of my work, but it did. DON’T DO THAT, if you don’t want to start over!

Here is what I’m experiencing.

SCENES BASED ON SUNRISE - I have scenes created that start with a “Before sunrise”, “At sunrise” and “After sunrise”, and EVERY ONE OF THEM, without exception, executes an HOUR AND TWELVE MINUTES LATE! Since I started over, four days ago, this has been 100% the case.

SCENES BASED ON SUNSET - I have scenes created that start with a “Before sunset”, “At sunset” and “After sunset”, and EVERY ONE OF THEM, without exception, executes NINE MINUTES LATE! Since I started over, four days ago, this has been 100% the case.

SCENES SET TO RUN AT A PARTICULAR TIME EACH DAY - I have several scenes created that start at various times of the day, and EVERY ONE OF THEM, without exception, executes FOUR HOURS AND TWENTY-ONE MINUTES LATE! Since I started over, four days ago, this has been 100% the case.

I am at a loss!! I’ve added a couple from time to time over the past four days, but every one of them acts exactly the same! I have stopped my migration project until the developers can figure out how I can fix this problem. They are working hard to help all of us, but I’m not sure the EZLO is going to be in our home, to stay. And with Vera devices no longer available, I quite frankly don’t know where to turn. Let’s pray their talent pulls us thru and we end up with a good product that will work well!

Sounds suspiciously like your unit is set for the wrong time zone. When you were first setting up your unit did you enter the incorrect time zone and later try to change it.

No, it was set for Denver for the first several days and then definitely set to Denver again, after the accidental total reset of the device four days ago. I wish it were that easy. Every time re-connect, it shows Denver in the time zone box. So we can rule that out.

Hello @k7jv

Since you’ve already verified that your location settings are correct, please make sure to also grant access to the location settings on the Vera app to have an accurate reading.

If this doesn’t solve the issue, we have also created a support ticket to further investigate, please check your email.

We’ll be pending for your reply.

Access has been set to “Always” from the beginning.

I must be lucky, my time related scenes run fine. Hopefully they still run fine after the weekend as then the daylight saving time kicks in. Are you running the latest firmware ( 2.0.10.1452.10)

@SaraV , will you share the findings here so others can find it when looking for similar issue?

No, I guess not. Mine is 2.0.9.1382.15. But there doesn’t appear to be any way to update it in the app. Is there s way for the user to do it?

@k7jv It should update automatically if you power it off and wait a minute before powering it on again. Not sure on that minute might be even less.

Edit:

  • Power cycle your Ezlo Plus controller or
  • Unplug the ethernet cable, wait for 10s, plug it back into the Ezlo Plus controller.

Hello @k7jv and @ranneman,

We found that when adding the location at first set up, sometimes the system doesn’t get the correct latitude and longitude of the location, making the time wrong for scheduled scenes.

Most of the times, it can be fixed by switching the location to “Always” access on the cellphone’s permissions for the mobile app.

Some other times, it needs help from tech support to change these settings directly on the controller, this is what we did to @k7jv 's controller and we’re waiting for his confirmation to verify if the issue was fixed.

About the upgrade, it is pushed from the server side so the user doesn’t need to do anything to force it.

I don’t understand how the location of my cell phone could change the region setting on my hub? I also doubt whether that makes sense, travelling to different timezones would/could impact my hubs region setting? Can somebody please explain.

Just trying to understand how this works.

This is just for the app to be able to make the changes, you can afterward revoke the app’s access to your location if you don’t want it to have that permission granted.

Regarding the firmware update, I’ve re-booted it a couple of times now, in the past cay, and there have been no updates installed. I don’t see where I can do anything to make it happen, either, on any of the menus. Too bad. Maybe updating the firmware would solve some of the other deal-breaker issues I’m dealing with. Dang!

Hopefully support is able to fix it for you. Curious what happens to my hub over the weekend regarding DST.

Please message @Oleh with your serial number as he requested on Beta - Ezlo Linux fw v.2.0.10.1452.10 for Ezlo Plus, Ezlo Secure controllers - #6 by Oleh so he can check why your controller is not updating.

Okay DST works fine on Ezlo Plus :wink:. That is better than what I remember from my first Vera Lite experience in 2012. It messed up DST and needed some lua code to get it fixed. Some history on this in below link.

Fantastic! Glad that went well for you. My EZLO Plus made the time change ok, but the events are still anywhere from an hour late to almost 2 ½ hours late. And my firmware STILL won’t update. So after several weeks now, my EZLO is still not “in service” as it doesn’t do anything right except for manually executed ON/OFF commands. IT DOES WORK WELL WITH THE ALEXA, though. Yay! But as for scheduled events, it is totally not in service! I have several events scheduled to run each day, but they are not “convenience” events to do things we want done when we want them done. They are only “test” events to determine if the clock logic is working correctly. IT IS NOT, AT ALL! Not one scheduled event has occurred when it was scheduled to occur. I’m so bummed!!!

Did you by any chance message @Oleh as suggested a few posts above this one?

Is this something that happens only when you’ve set a specific time, or also when you use sunrise/sunset as the scheduled time? I need to know this to create the internal ticket for engineering.

Thanks

Hi, Leandro

I think Sara in your group is on it. To answer your question, I have three scenes that are scheduled based on sunrise. One is set for 2 minutes before sunrise. One is set for sunrise. And one more is set for after sunrise. I have four that are scheduled based on sunset. One is set for 10 minutes before sunset. One is set for sunset. And two more are set for after sunset. One of those is supposed to run 15 minutes after, and the other 20 minutes after. Finally, I have four scenes that are programmed to run at specific clock times, across the day. All of these scenes are scheduled to run every day. I’ve been tracking, based on actual sunrise and sunset times, the times when each event is supposed to happen and when the actually do happen. The sunrise based events consistently run about 2 hours and 22 minutes late. The sunset based events consistently run about an hour late. And the time of day events consistently run a little over two and a half hours late.

I also have nine more inconsequential scenes that I created to check to see when the 20 scene limit gets removed. Right now, twenty is the maximum number of scenes that can be progreammed. At that point, the “+” is “grayed out” so no more can be added.

My firmware is out of date, and there doesn’t seem to be any way to update it. I really wonder if bringing my firmware up to date might fix all of these problems.

Like I said earlier, my Ezlo Plus is not working for us at all, with the primary reason we have a scheduling controller. We are still relying on the old Vera Plus that is doing the work for us. I can’t move anything important to the new Ezlo controller until these issues are resolved.

YOUR TECH SUPPORT TEAM HAS BEEN AMAZING!!! You are all staying on board with me and working with me to get it right. I’m so thankful of that. I just hope that we can get to the bottom of why my unit fails to perform as designed and intended.

Thank you, Leandro. Cheers!

1 Like

You’re in great hands then. She’s one of our level 2 support engineers and I trust she will do all in her power to help you sort this out.

This does sound like something I’ve been working on for another customer as well, so hopefully, with the report to engineering I made for that customer, it will be solved for all units presenting the same issue.

Thank you for your kind words about our work. We do the best we can with the tools at our disposal to help our customers, and even though sometimes the issues cannot be solved directly by us but instead depend on the input of the developers, engineers, and so forth, we try to help you get a solution as soon as practically possible.

1 Like

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules