My experience Vera3 UI5 to UI7

First, why did I upgrade? Wanted to install some newer devices that either weren’t supported in UI5 or problematic. I was very happy with UI5.

I have upgraded two Vera 3 units from UI5 to UI7. Both times the same problems cropped up.

The firmware upgrade itself went fine. In both cases, overnight I had some battery devices get marked as “Can’t detect device.” Tried waking devices up manually, no good. Put a ticket in on the first one, was told it was fixed, yet the next day I had an Aeon 4 in 1 and a older Express 3 in 1 not detected again. Excluded them, added them back to the system. Tweaked polling / wakeup to suit me (one had equal wakeup and polling times, other had polling higher than wakeup) That was not how they were set before the upgrade. Things finally settled down.

Same problems with second unit. I had to go back and change polling/wakeup times on several devices. This time my Everspring door sensors and a Express 3 in 1 showed the “Can’t detect” after an overnight. In this case I rebooted the vera and they popped back on line. If this happens again and a reboot fixes it will put a ticket in to see what support says.

Neither unit has more than about 12 devices each.
Both devices are running 1.7.760

What irritates me the most is one of these is at my cabin, so I just can’t stay here for days on end trying things out. Yes I have remote access, but sometimes you have to go hands on with devices. Hoping UI7 settles down as I spent a long weekend doing the upgrade (well, I did other things too!), but still not feeling good that everything is working 100%.

I had the same exact situation with the same exact sensors in UI7.

I resorted to plugging in the 4-1’s with direct power and re-adding them to vera as new devices. I have had no issues other then ONE of the sensors seems to be triggered by direct sun light (I think). I will be troubleshooting that issue next time I am on scene.

I realize this does not answer your question. I also realizing plugging in the 4-1 might not be an option. If it is, then I would suggest trying it. When the device is added as a direct power 4-1, I believe the vera uses different settings that would be impractical for a battery set up.

Good luck.

I made sure my 4 in 1 was on USB power when adding it back in (in both cases). Its good to see a lot of us have had the same things act up. Too bad things aren’t a bit more stable UI7 wise.

Figured I would add my 2 cents to all the upgrade comments out there. In my case it was a bit painful but I think things are settling down.

Guess one piece of advice to those reading this. Don’t assume you will upgrade and not have to tweak things. Then again anyone thats been using Vera already realizes this… ;D


Just to clarify. I keep my Aeon 4-1’s plugged in and DO NOT switch back to battery power after adding. I am lucky with outlet placements. :).

Oh yeah, one more oddity. One of the two Intermatic CA3000 switches became unpaired that night as well. Saw it flashing blue/red (which looks to me more like white/red). Had to add it back to network.

Quick update:
So my second Vera 3 is not happy. Nightly 3 to 5 battery devices drop off the net and then come back on later in the morning. Have opened a ticket as this seems to be a problem for many people even on other hardware platforms.

Do you need UI7? I’ve been thinking about this a while. Am sort of happy with UI5. I only have 2 battery sensors but essentially stopped tinkering and spending with Vera until I work out whether to go with ST or UI7. I would like “home” etc but heck it. Thanks for sharing!

@dinkeldorf , yes I needed UI7. I had held off for a LONG time as UI5 was fine for me. I wanted to add some newer devices and could see in the forums either they were a pain to setup or would not work well/at all in UI5. Believe me, I was in no rush to upgrade and was checking the forums every so often to see how UI7 was going.

Latest update. Both of my Vera3s have stopped their nightly gripes and are not longer losing track of battery devices. I opened a ticket on my second Vera but have heard NOTHING on it. One of my everspring door sensors went from 98% to 1% battery in about 5 days. (I verified polling/wake up times were at like 4 or so hours. Its not a door that was used much so not sure if coincidence or not. Not sure why they settled down as I had given up on tweaking things. (maybe that helped… LOL)

Great info & perspective. Good for you. I will add another fence to sit on: Vera + & Echo too now. What’s funny is all my family wants is a built in display.

I am way too paranoid to ever have an Amazon Echo sitting there listening to everything going on in the room… :-X (Even if it had a mute switch) ;D

And I spoke too soon on my second vera finally being stable… just checked it an after behaving for 4 days straight, I have 7 devices showing “Can’t Detect Device” now. Yay UI7!

I wish I had the knowledge to help. This kind of disruption can be maddening. Hopefully tech support gets with you soon.

They finally did this afternoon… so thats a few days waiting on this response. I told them I have already paired/unpaired and it did not help". Ticket churn, yay!

"Thank you for contacting us,

In this case we suggest to unpair and then pair again the devices. Sometimes the old configuration keeps not needed information and can lead to this.

Please try this and then let us know the results."

For what its worth, things have slowly calmed down and gotten better. I had one battery operated device get set with some crazy wakeup / poll times, killed battery within days. Tweaked that to a more sane setting. MCV said they made some changes to my Vera3 config but have no idea what they did. Have not had any devices drop off in over a week now and all seem to be working. PHEW! :o

In the beginning though it was crazy after the initial upgrade, glad I rode it out.

Your experience mirrors mine. First month or two crazy things happened. Unexplained things.

I dropped a few apps/plugins that seemed like a good idea to have.

Tweaked, filed support tickets.

I have not had any issues for many, many months.

Glad it worked out.

I hope I will at some point have the same experience. I thought I was getting close, filed a ticket to fix an unresponsive lock. Came home to a Vera stuck in a constant reboot loop.

If I ever have to rebuild my system from the ground up, I’ll probably consider other options.

It seems im in the same boat.

The update had to be done as we could not login remotely, it tanked and Tech Support kindly did it.
But after that, we lost 2 the AEON 4-1 sensors, and mostly all units.

We changed the 4-1 sensors with fresh batteries and re added them. They seem to be working now.

But every now and then the unit just reports it Cant detect a device, we simply click on the GUI, ON and after one or two retries it works, turn it off, and the warning goes away.

the problem is, this is not my house, the owner just calls me pissed because the lights did not come on at the right time.
If clicking remotely on the GUI to toggle the light status, helped. Why cant the unit re poll or re test them?

can we/they write a "self healing " program to run , say at 3 AM , just to make sure everything is on board?