More VOI/Alexa integration issues?

For the past month there have apparently been issues with the VOi/Alexa integration. For example, a new device I added to my Ezlo Plus has still not shown up for use in alexa, nor can I control a new WiFI based device via VOI. I have been told (over a month ago) that this was a known issue and “would be fixed in the next few days”. Ok, fair enough.

At least over that time, controlling existing devices on my Ezlo Plus via Alexa (“Alexa, turn on curtains open”, for example) continued to work. Until last night, that is. Since last night, even that has stopped working (“Curtains open is not responding”). I have restarted my Ezlo controller a couple of times without any change. Is this yet another symptom of the same problem that “will be fixed in the next few days”, or is this a new issue?

Just as a follow-up, the Alexa —> Ezlo failure has continued all through yesterday and into today for me. For what it’s worth, Alexa is still correctly controlling devices on my Vera Plus, it’s just the control over devices on my Ezlo Plus that has failed.

I’ve restarted a couple of times already, should I try removing/re-setting up the integration? I don’t want to, as that would break the various Alexa routines I have that rely on Ezlo devices, but if it’s the only way to restore access, so be it.

I wouldn’t do that, there is a good chance you won’t be able to get it setup again at all.

All this stuff is mainly broken now for voice assistants and VOI.

I dare not touch my Google Home setup for fear of losing what I have now.

And VOI does not work for me at all at the moment.

1 Like

“Locations not found” is the pop up message I see in the Android Vera mobile app when trying to text chat with either Alexa or Google Home.

It wouldn’t surprise me at all if that was the case. I’ll leave it for now.

Yeah, I haven’t seen VOI working for almost a month now, along with new devices not showing up in Alexa. The Alexa control of existing Ezlo devices, however, had remained fairly reliable until the day before yesterday. Thus this query - I wasn’t sure if this was just a new manifestation of the existing issues, or a completely new (and potentially fixable) issue.

In iOS I am currently getting “Something is wrong. Please check your system and try again”. A couple of weeks ago it would respond with “ok” like its worked, but nothing would happen.

Can’t comment on that. Don’t think I have any devices paired to an Ezlo hub in Alexa.

I do have some devices from my Vera Plus in Alexa and as you said that seems to still work OK currently. I just asked Alexa to turn on a Switch Plug and it worked alright.

As for new devices appearing in Alexa, the last time I added a new device on my Vera Plus after exposing it to Alexa via the Vera voice assistant setup portal web page thing, it didn’t appear in Alexa initially it took a very very long time for it to eventually show up and appear.

I don’t use Alexa I just have one old Echo Dot here for testing stuff. I mainly use Google Home speakers and Chromecast devices etc.

1 Like

I just added a Fibaro Wall Plug that is paired to my Ezlo Plus into Alexa and it does work. It also added into Alexa quickly this time.

When I ask Alexa via voice command to turn it on and off it works.

EDIT:

I then added the same Fibaro Wall Plug from the Ezlo Plus hub into Google Home and it seems to be working OK in there as well.

Although several times when asking GH to “update devices” it said there was a problem with either or both the Vera and Ezlo services.

I had to ask it to update devices several times before it worked and the new devices I added or removed were actioned.

1 Like

Ahhh, so it was just my device. With that in mind, I went to home.getvera.com, and the manage alexa ezlo option. Last time I went there, it was a mess of duplicated devices, but thankfully that apparently has been fixed since then. Clicked “finish” (without making any changes), and I suddenly got a message from the Alexa app stating that “23 new devices have been detected”.

Unfortunately the 23 “new” devices (including things like “PAASAuthentication” which I have no idea what it is…part of NuCAL perhaps? No matter.) apparently replaced the existing devices, meaning that I have to go through and set up all my Alexa routines again. Oh well. At least it’s working again!

And some people wonder why I claimed Ezlo devices weren’t ready for prime-time yet… :crazy_face:

Yes seems they fixed the duplicated devices in the Manage Alexa portal page.

Sucks you have to do your routines again.

PAASAuthentication appeared on my system as well. I thought it might be related to Vidoo but maybe not.

Also the plugin devices HTTP Manager, TCP, UDP etc also appear now in the Manage Alexa Ezlo portal page.

I guess we would want some plugin devices to go into Alexa, but probably not those ones.

Also it ticks everything in that page by default. Under the Manage Alexa Ezlo one I had to un-tick everything other than that Fibaro Wall Plug. As I didn’t want anything else going in to Alexa.

1 Like

I’m just setting up an Ezlo Plus. I successfully linked to my Alexa account. “Chat with Amazon Alexa” doesn’t respond to anything. I also see the “no locations found” popup. A big reason for trying to upgrade from Vera Plus to Ezlo Plus was the EZLO VOI function. Since this has been going on for over a month without any resolution or even acknowledgment, I might just return it.

VOI is still beta functionality and is not production yet.

Be a little patient and give them some time.

Really? I didn’t see anything about that on their help pages: How to get started with Ezlo VOI, How to chat with your voice assistant using Ezlo VOI

With all due respect, the information page for the Ezlo Plus (Ezlo Plus | Smart Home Controller - Ezlo Smart Home) states:

Scrolling further down the page, I find that VOI has an entire “tile” dedicated to it with the title “Uniting your voice assistants”, stating

So yeah, they are clearly marketing it as a feature, and as such it should either be working, or it is false marketing.

I’m perfectly willing to cut companies slack for bugs even in production code (as long as they acknowledge and fix them!), and even more so for beta products (I EXPECT bugs there!), but when a primary, prominently stated/marketed, marque feature of a shipping product is DOA for months on end, I for one start to loose patience.

This is also one of many reasons I still maintain that the Ezlo line is not ready for prime time.

Of course, at the present time a significant portion of the Ezlo support staff is in a country that is under invasion, so I’ll cut them all sorts of slack for that! :smiley:

Mostly everything is in beta or alpha.

Yes I agree with you both that they have it on their marketing blurb and that may be misleading.

But it’s all still in development in reality.

Last update I had on VOI was we would have something new and working end of January I think it was. They were migrating to new cloud infrastructure / platform.

Obviously that hasn’t happened yet and now the devs are in a war zone, all time scales have gone out of the window.

@kkl

Send it back if your not happy with it.

Voi will come, it has worked in the past but is not currently working now.

They also have “Nucal” integrations coming (similar to ifttt) for various cloud based devices and services.

Yikes! They’ve got an office Kharkiv (https://ua.linkedin.com/company/ezloinnovation?trk=ppro_cprof). I had no idea.

Not officially. They removed “Beta” from the EZLogic web interface about a month ago, when it went to version 1.0. The Ezlo Plus hardware - which is what is advertising VOI - hasn’t been in “beta” status since before April of 2021: https://community.ezlo.com/t/ezlo-plus-is-still-in-beta-correct/217455/3:

Personally, I disagree with this assessment, but the official word is no, it is NOT in beta. I agree it is still under heavy development, but OFFICIALLY speaking, it is production, not beta. Sorry to disagree! :slight_smile:

That was very optimistic.

Not sure who approved that statement at the higher levels.

The Web gui is still in beta as far as I am concerned from my usages of it.

1 Like

I wouldn’t run my production unit on an Ezlo hub today.

If they claim its production? Then I’d disagree.

I won’t be migrating my Vera Plus for an Ezlo hub for at least 12 months from now if not longer.

And that also depends on 3rd party support on Ezlo hubs with the Home Remote dashboard app.

MSR logic engine supports Ezlo hubs today which is one saving grace.

1 Like

Completely agreed. Unfortunately, neither you nor I are arbiter of what is or is not in beta, and if Ezlo chooses to say their devices are not in beta, then I kind of feel they they are responsible for backing up that claim with function.

That said, I do like the progress I’ve seen, as well as the vision laid out by leadership, and as such I will continue testing out their product to the best of my ability :slight_smile:

With the DSC plugin being at least mostly functional at this point, I’m hoping to begin moving the bulk of my devices over in the coming days, and we’ll see how it goes!

1 Like

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules