MiOS App Beta

This is the very first release of the Ezlo MiOS app with the following features available:

  • Create a new account by using your email address
  • Login into the MiOS app by using VeraMobile credentials (username + password)
  • If you forgot the password, you can reset it anytime.
  • Link your Alexa or Google account
  • Use the Ezlo VOI™ feature without having to buy an Ezlo controller.
  • Create a scene to control both Alexa and Google connected devices.
  • Create custom dashboards and control devices connected to Alexa and Google from one place.

Known issues:

  • Change password for newly created accounts is not working for now. Please use the password sent to the email when account is created until next release.

For all the Android users that signed up for beta you should have received the email with the link to download the app.

The iOS app is awaiting approval, once approved all iOS beta testers will receive an email with the link to download and install the app. This should happen within the next 24 to 48 hours depending on the approval process from Apple.

Here you can download the Beta Test Guide for Ezlo MiOS app:
Ezlo MiOS - Beta Test Guide-2.pdf (1.1 MB)

You can see how to create and customise a dashboard in this video.


great, meanwhile can someone share with us some screen shots… thanks

I just installed it, we see the Ezlo cloud appear with the controllers with VOI, otherwise apart from changing the color green to blue I do not see any change with the VeraMobile application.
Caméra not work

Yep and the same glitches :smiley:

I added some devices to dashboard, and with in seconds they vanished., and now the edit icon has vanished, and i can not re add any devices.

Is this the same old shit or a brand new app?


Green to blue LOL that made me laugh.

I’m tiring of the promises and lack of apparent progress.

Im sure building a “brand new” Linux FW that breaks all our current excellent 3rd party plugins, and simple Luup Requests, so actual decent front end 3rd party dashboard control apps also break, yet this new FW is sill based on Open WRT is very complex. So is backend stacks for Zigbee and Z-Wave.

But end users wanna see flashy front end GUIs. That look amazing and stuff that actually works.

Both web based GUIs and mobile app dashboard GUIs.

Perhaps I am being too impatient or optimistic?


if this is the same app i am going to be so disappointed, what have all these years of Ezlo taking over Vera resulted in. All it seems like is half baked ‘alphas’ of software, that are still far behind what has already been done by the old owner of Vera. Almost every new release of any testing software I have been let down by mediocre releases that bring minimal changes to test out. I will for sure not be upgrading my VP to the new Ezlo FW when its available because I will be given poor performing apps that IMO are the heart of home control. There are now more than ever wayy better 3rd party solutions that beat almost all of Ezlo’s work, namely a new app me and @cw-kid have been testing called The Home Remote that blows any dashboard that Ezlo has done out of the water.

Edit: I am not trying to bash anyone’s hardwork at Ezlo, just a little let down by the things coming out I have very little hope left


I have a feature request can I have a dark mode and grey accents?

Not green and not blue :grin:


for me it’s the same as VeraMobile, but it’s more responsive than before, less than a second of latency.
Try there you will see, I have imperihome but that does not prevent me from seeing the VeraMobile and Mios application

here is a little feedback
-01: the creation of a dashboard does not work: during creation, several models are available, portrait or landscape orientation, once chosen, you must press the + to add a device or a scene and there nothing goes back in the choice: everything is empty
02: VOI does not work: I added my Google home with my account but I cannot do anything. I tried to add Alexa but couldn’t, I can only have one system: or Google or Alexa …
So either I don’t understand anything, or there is a problem with the application.

were you able to add device and scene to the dashboard?

yes, but they vanished seconds later. then was unable to re-add. force closing the app this morning and restarting brought added devices back.

Also there is only option for the new dashboard, no sign of my all ready configured vera dashboard.

I would also add the tiles in dashboard are 95% white space and no dimmer slider or on off button. You have to click tiny chevron icon to bring up controls. The tiles do not layout in any reasonable viewing orientation. The lay out sucks big time.

All together not impressed

I entered my identifiers and everything worked: my VeraPlus is going back well. I received my alerts and notifications like on VeraMobile.
the tile system is not great because you have to click on it to access the few commands available. still unable to access device parameters too

1 Like

Here is what is important to note:
Same old shit with New shit in it.
what is that New Shit?
What you see as dashboard is the “New Architecture”. Seen the movie “Aliens” where they eat the body from within…thats what we are doing…We first inject the New Architecture into old body (app) then this New architecture starts taking over functionality.
What is this new functionality? Its a whole new platform based on NativeScript that works with all types (ios/android/web).
So instead of replicating everything on this architecture…we decided to inject this architecture into old one and start offering things that the old one didn’t offer, like a fully customizable dashboard. Now that we have launched it, next stage is, what other functionality will be added to this new architecture next. Virtual devices, camera, scene creation and so on. So first launch the base…than expand…It was a big step to combine this new technology into current Apps to provide continuity while opening up this new platform to everyone.
This is going to be Improvement with every release kind of progress vs one release progress.

I’ve added the Beta Test Guide for Ezlo MiOS app in the post, with the features that can be tested.

Here is a video that shows how to create and customise a dashboard written in NativeScript from the current application.

1 Like

Hi @Ioana
what to do when you have Alexa AND Google home?

OK first look this morning.

As Melih said above this is the VeraMobile app plus the new nativescript dashboard.

I am confused however.

So in the Vera mobile app they have what they are now calling “Dashboard Pro” in this Mios app.

This one the dashboard you have seen in the VeraMobile beta releases.

Then they have added the other new nativescript dashboard.

In the dashboard settings you can switch between them.

However there is a problem in here.

The Lounge, Kitchen and Page Selection items are all dashboard pages I created in the Ezlo Dashboard Configurator app previously.

However I can only select one dashboard page in the Mios app Dashboard settings. I cannot just select them all.

So that doesn’t make any sense.

Also when I select the Lounge one for example, it looks like this.

It looks similar to the lounge dashboard page I created in the Ezlo Dashboard Configurator app but it’s different.

One device is missing in the middle and other devices are not even devices I ever added to my lounge dashboard in the Configurator app, yet they are now there in this new Mios app.

Like Upnp Event Proxy and WHS DLNA Squeezebox.

These are plugin devices I have on my production Vera Plus.

Lounge dashboard page in the Mios app

Lounge dashboard page in the Ezlo Dashboard Configurator app

This is not what I was expecting at all.

I was under the impression we would be getting a brand new app, a dashboard app, like Imperihome.

What we have here is the VeraMobile app with two dashboard architectures in it.

I dont know what direction Ezlo are going in now with all this? It seems a mess.

Ah so you have to use something else to make a new dashboard? Not great that. We should be able to do all of this on the App directly.
why not add a button next to the dashboard settings button to simply switch to others, as if they were shortcuts to them, a bit like imperihome pages?

In addition if a third party single developer can make a decent dashboard app how can a whole team of developers not?

I think I am going to stick with learning “The Home Remote” as an Imperihome replacement and prey the dev makes it work with the Ezlo FW Http API in the future?

if not then I’ll be looking at other HA platforms I think.

No idea what they are doing totally confused now.

Look for the Ezlo Dashboard Configurator app thread.

Or you can go here for the Web based version.