MimoLite and Garage Door Plugin Questions

Hi All,
Newbie here. Just installed the MimoLite to my Liftmaster garage door opener. I also installed a magnetic contact that is closed when the magnet is next to it. First, I installed the MimoLite with the P5 jumper removed before ever applying power. It paired fine the first time and the device was seen as a light bulb icon binary on/off device ID=101. If I press the light bulb, the garage opens/closes fine. Next, I installed the MimoLite Plugin. It installed as device ID=103. I don’t see any children devices after installing this as others have stated before. I’m using UI 1.7 firmware .2414. I then installed RichardSchaefer’s “Garage Door” plugin fine. I put in deviceID=101 for the devswitch as the parent. I put in deviceID=103 for the devsensor.

Now, if I press the Lock/Unlock icon, it will open and close the garage door just fine. However, it appears the sensor status is always the opposite. In otherwords, when the magnet is close to the switch, it states “Unlocked” and when the door is open it states “Locked”. Any quick fixes for this or any ideas of what I’ve done wrong. Thanks in advance for your help.


Hmm. Well oddly enough, it seems as though things are working correctly today. Maybe the Vera needed to re-synchronize itself overnight. I’m now getting a green indicator on the Lock icon in the My Shortcuts area on the smartphone app when the door is closed and a red indicator on the Lock icon when the door is open. I think it’s working correctly now. However, I thought I was supposed to see multiple child devices after installing the MimoLite plugin but I’m not seeing that.



Well I seem to still be having some issues here with the MimoLite and Garage Door Plugin. I’m sure it’s something I’m doing stupidly as a newbie. What appeared to be working for about 2 days has now failed again. I was getting an error for the MimoLite unit that said something along the lines of “User setting configuration”. So, I unpaired the MimoLite. Uninstalled the MimoLite Plugin and the Garage Door Plugin. Then, I re-paired the MimoLite without any issues. This created the MimoLite “Binary Light Bulb” again as device ID 107. I then rebooted the VeraPlus for good measure and all seems ok after the reboot. Next, I installed the MimoLite Plugin and then I rebooted the VeraPlus again and all seems ok and I’m now seeing the 3 child sensors I never saw before for the MimoLite. It listed them as “Binary Sensor” Device ID 110, “Generic Sensor” Device ID 111, and “Pulse Meter” Device ID 112.

Finally, I installed the Garage Door Plugin and it created the Garage Lock with Device ID 109. I rebooted the VeraPlus again for good measure and all seems stable. I then put in a Device ID 107 for the “DoorSensorDevNumber” and Device ID 110 for the “DoorSwitchDevNumber”. Keep in mind I also have wired in a standard Garage type magnetic door contact that is closed when the magnet is next to the switch. I then rebooted the VeraPlus one last time after entering the two Device ID’s for the Garage Door Plugin. After the reboot, I verified the Device ID’s were what I had put into those variable fields.

The next thing I did was to manually use my original wall mounted garage door opener to ensure it would open and close the door still. It did. Now, on the smartphone it shows the Garage Door Lock with a green circle with a 1 inside and has “Unlock All” to the right. If I press “Unlock All”, the garage door starts to open and the circle goes red and says “Unlocked Door” and the spinning icons happens. Once the door is fully opened, it now says “Locked Door” and has a green circle with a 1 in it. Shouldn’t that circle stay red because the door is now open? It’s as if everything is reversed. This has been the bane of my existence and hoping you all can see the error in my ways before I try and give this the “Wife Approval Factor”. Any thoughts are much appreciated.


You have the devices backwards …
The Sensor - 110 should be DoorSensorDevNumber
The Light - 107 should be DoorSwitchDevNumber

Hi Richard,

Thank you for your prompt reply. I tried switching the device ID’s and still no go. So, I took the Hail Mary approach and started over completely from scratch a 2nd time with in-pairing, uninstalling the plugin’s etc. This time around after ensuring the correct device ID’s were entered into your plugin, things now appear to be functioning as one would expect. I will monitor this for a few days and if all continues well, start to show the wife as she is the one who wanted this capability and I naively said “sure, no problem let me do some research and get that set right up…”. Thanks again Richard for your confirmation and for taking the time to develop the plugin.


[quote=“RichardTSchaefer, post:4, topic:195505”]You have the devices backwards …
The Sensor - 110 should be DoorSensorDevNumber
The Light - 107 should be DoorSwitchDevNumber[/quote]

Richard, you should just shamelessly plug your app because it works… I had it up and running in about 30 minutes and that includes connecting and installing the MiMOlite low voltage relay (tilt sensor was already installed on my door) Only one thing I’d like to suggest and that is your garage door app use garage door open/closed icons instead of a lock icon. That would be frosting on the cake!

I’ve tried to use this MiMOlite Garage Door app twice now and both times it has borked my system. I had to get Vera Support to get my controller working yesterday with the MiMOlite Garage Door app and am awaiting them to kick it in the pants again right now. I’m done with this app although I had high hopes for it.

It could be that it is conflicting with Richard’s Garage Door App but I don’t see why it would be. After I got my controller back on line yesterday it wasn’t associated with the MiMOlight or the Tilt Sensor and when I tried to do that, the app lost a lot of the inputs in the Advanced screen, which is what prompted me to delete it and try installing it again, which resulted in the Vera Plus going out again. I will be writing a review of this app in the app store very soon and it isn’t going to be a good review.

My unit has been recovered by Vera Controls and here’s the email I got from them:


I have managed to connect to your unit using the access code you had provided. I had successfully restored your unit and removed the mimolite plugin.

Please do not re-install this plugin until further updates because there have been done some changes in the API used by the plugin which will crash your unit.

Thank you,
Have a nice day.


Alex B ▾ Customer Care Advocate
Vera Control, Ltd. ▾ Smarter Home Control

Just to close the loop here, almost 2 weeks now and all continues to function quite well. Thanks Richard. Even works after upgrade to latest firmware. Happy wife now, happy life :slight_smile:

Thanks for the update. I’m working now to incorporate it in a “scene” using PLEG so that if nobody is home AND the door is open it will close automatically. UI7 does “OR” okay but any other conditional logic requirements are just basically not there.