Mi Casa Verde. Please respond.

JOD. Oct 8, 2010: My Vera 2 is sat idle due to this error message. "Add new devices now… Failed to go into learn mode. Retrying…Add new devices now… Failed to go into learn mode. Retrying…Add new devices now… Add/Remove: ZWave network failed to go into learn mode. Aborting… Wait 1 minute and try again.

MCV: Oct 13, 2010: Generally, when that message appears, your Vera is not the main/primary z-wave controller. Can you check under Z-Wave Device > Options and see if it’s set to PRI:YES ? Or, check the infopanel message, where you see “Failed to go into learn mode”, to see if it tries several times and none of the attempt is successful.

JOD: Oct 13, 2010: Master SIS:YES PRI:YES.

JOD: Oct 18, 2010: Any update on a fix?

MCV: Oct, 18, 2010 Momentary we haven’t find a clean fix for this, but i think that in our next firmware release this will be fixed. Our team is still working on this.
We’ll notify you as soon as we have

My patience are reaching a breaking point with the lack of concern, where is my Aeon SmartSwitch ordered Sept 14th, 2010? Anne has not replied to any of my emails.


Hi JOD - did you ever get any response on this or an estimate as to when it will be fixed? I just ran into this problem myself which has put pretty much halted z-wave deployment in my house - I can’t add any of the new equipment I purchased.

No response to the post but did get exchangea few emails back and forth but no fix.
The end result was to start from scratch. The sad part is i’m back using Vera 1 and the dongle which actually was a ALOT easier.
I am just now finishing up a complete redo of my system. Excluded & included all devices, sections, rooms, plugins, scenes, camera’s etc… It’s been a chore and has taken 63hrs so far but expect to be done tomorrow night.
Vera 2 is still waiting on a fix.
Do you have the dongle available to you? If so, if ou dont want to wait for a fix, back up your system and restore it to the dongle and then add your other devices with the dongle and then restore it…


I do have a vera1 and an external dongle.

So I should try backing up my system (under the Advanced>Backup section) and then choosing restore, including checking the “Restore Dongle Firmware” checkbox, and this should get me around the “failed to go into learn mode” issue?

It’s what I would do.
On the Mios “Toolbox” taskbar:
Under the “Z-Wave Device” tab, advanced tab “Backup Dongle”
When completed.
On the Mios “Toolbox” taskbar:
Click “Advanced”
Click the “Backup” tab.
Create backup.
Restore as you indicated.
Dont forget to take your Vera 2 out of service as both units would be on the same network.
Good Luck…


I don’t have a Vera 2 (just a Vera 1) but I gave the backup/restore a try, including a full backup and restore of the dongle.

Unfortunately, I seem to have the same exact issue where the zwave network fails to go into restore mode if I try to add a device via full power inclusion, and no errors whatsoever (but the device doesn’t add) if I carry the dongle around.

I’m a little confused. My OP was that I was using a V2, my 2nd post was I had reverted back to a V1 because it was easier to include the devices with the dongle than to go through the process of full power inclusion with the errors I had with the V2.
When you said you had the same issue, I was under the impression you were using V2 and woud restore that to a V1. Should I now assume you are using UI2?
Why would you do a backup / restore of the same data you are using to the same unit?
I’m also confused about your comment of the device wont add when you carry the dongle? Gonna need a bit more info. New or existing device? Wont add to the dongle or to the UI? What UI are you using?
I havent heard of UI2 going into learn mode errors…
At this point in time it appears the error of going into learn mode is being caused within your FW/data, I dont believe its a hardware issue.


Ok, I’ll start from the top - I think I was just trying to rush things in an effort to resolve this issue, which is preventing me from adding the final three devices to my zwave network (which is currently about 65 nodes).

I only have a Vera1 running the latest UI4 code.

When I try and add new devices via full power inclusion, I get the exact same error message you mentioned at the beginning of this thread, namely :

""Add new devices now… Failed to go into learn mode. Retrying…Add new devices now… Failed to go into learn mode. Retrying…Add new devices now… Add/Remove: ZWave network failed to go into learn mode. Aborting… Wait 1 minute and try again. "

This is a new error message that just started with the last device I tried to add. I’ve added other devices since I last upgraded my firmware, but I now seem to have hit a limit.

If I try to add devices by carrying the Vera1 dongle to the device, that doesn’t work either - I don’t get the error message, but the new device is also not added when the dongle is plugged back into the Vera1.

I think I’ve hit some sort of bug related to a limit, as I haven’t changed firmware recently and I’m using the same method to add the same type of devices (Leviton switches) that I have always been using, only now it doesn’t work.

Understood. No need to do the backup / restore with this setup.
I agree there is some limitation with regards to error msgs and the number of devices. Maybe someone else can comment with the same errors and how many devices you have…
Was your system a fresh install or have you been up and running for a while and then decided to add more devices?
I’ve seen some odd stuff since V1 UI2. 1st the dongle issue and was told to use the Aeon to inlcude, backup and then restore to the TrickleStar. Over time I think I had some corrupt data doing that which I then carried from FW to FW and ended up with a backup of 622kb and all the other issues. With my fresh install that same network is now at 247kb…I do believe the issue is with the FW but how to get around it is where I think we are now in waiting for the next release. I think MCV has hit the wall for as fix as this is not an isolated issue.


Mine is an existing setup that has been running UI4 for a while. I added most of the equipment while it was at UI2, but I’ve probably added about 15 devices with no problem under UI4 until I suddenly ran into this issue.

I’d consider removing and re-including everything, but I dont really understand the nature of the bug and so I’m worried I might run into it again, only this time after adding even fewer devices. Plus removing and re-including my 5 schlage locks is just about the last thing in the world I want to do again.

I can tell you from experience that with a fresh install you can add all your devices and setup your scenes and be OK.
However, if you try to add devices later you will run into the same issue again. I dont know what the cause of the problem is but it was pointed out to MCV over a year ago with UI2 and about 75 devices with no resolution. It is still being pointed out to them after a recent beta test of a potential FW release revealed the same issue.


I may cry for a little while and then decide to do this as I do not envision adding any additional zwave nodes after this last round (all my switches, thermostats, and locks have been replaced…agreeably I would still hope MCV finds and deploys a fix for this)

If I go through setting up my whole wave network again, is just doing an exclude of all existing devices and the hitting the “reset zwave network” button under the “advanced” tab of the wave toolbox icon the best way to get back to square one?

I’m not advocating you reset your network and start from scratch, what I am saying is it’s one option to get you to where you want to be, unless someone has another option for you. Anyone?

Excluding all your devices and resetting the network should be all you need to do. Is it the best method? That depends on who you ask.

Failing to go into learn mode and No Z-Wave dongle are issues that should be on the top of MCV’s fix list.
My thinking is this is a device qty, software limitation built in intentionally to help move MCV into phase 3 of their plan, but that’s another topic…


I’m curious… ;D

What are you referring to JOD?

Ok, so my problem may not be exactly the way I originally thought it was…erp.

Apparently, this issue (zwave network failed to go into learn mode) is only affecting me with the newer Leviton VRCS2/4 scene controllers (the ones that also control a local load).

I just added a few Leviton RZC03 devices to my network with no problem.

I’ve reset the VRCS2/4 devices and excluded them from my network, but no luck - I still get the “Failed to go into learn mode…” each time I do a full-power include and then hold one of the switches. I’ve tried to reset the device and add it as a controller first (holding both switches) and I’ve even tried to ignore that part and just add it as a regular on/off node (just holding one switch until amber), but no luck either way.

That cannot be a true statement.

Vera needs to go into learn mode before you attempt to add a device. Therefore, Vera has no idea of what the device IS until the button is pressed on the device.

Until we know the real casue of the failed to go into learn mode I think you just got lucky in being to add more devices.


I just added 5 Leviton RZC03 devices that had never been on my network successfully.

I did a full-power include (which always starts fine and shows “Add new devices now…”) and then hit the on/off button on the RZC03. As soon as I hit the on/off button, Vera found the node and started adding it, which is the exact point that I get the “Failed to go into learn mode…” when adding the VRCS2.

I think it is still a Vera problem, but somehow the VRCS2 is triggering it where the RZC03 does not. It doesn’t really make sense to me that I can add one type of device (the RZC03) but not the other (VRCS2), but I’ve tried it with multiple of the same model type (I have 2xVRCS2 and 5xRZC03) and it always finds the node but fails to go into learn mode with the VRCS2 but always succeeds with the RZC03.

Its a weird problem, and I don’t understand it.

I’m running 1.1.1062 UI4

I had 56 devices added when I ran into the error for the first time, and now that I’ve added the 5 RZC03 devices I’m up to #61.

I too get this error message. I have Vera 2 with the 1047 firmware.

I was thinking at first it was the Schlage Lock that was the problem. So I spent hours and hours with an unlocked front door as I removed the lock and brought it to Vera, resetting it, excluding it, and nothing I would do works. But the error message “Unable to enter learn mode” seems to come up BEFORE I start pressing any keys on the dismounted lock to include it – so it’s definitely not appearing to be the lock. (The Lock never migrated when I “upgraded” from Vera 1 – it took a while for me to notice why the door entry was no longer triggering lights until we entered the winter season with the early sunsets.) I don’t have a very large network, but have added a few items to it since, a couple of plug in lighting controls for some lamps and that.

But it seems I too have been bit by the adding a few items bug and getting the Failure to Learn error.

It’s just incredibly frustrating that there’s nothing I can do about it. And I need to get this lock issue resolved soon.

I have a ticket open, but wondering how long it will sit open with no acknowledgement. Will it be like the rest of the tickets I’ve opened in the past with MCV and just fall into the black hole?

I wanted to circle back on this topic since I finally got it resolved, although perhaps resolved is too strong of a word as it may come back again and the resolution required me resetting up my entire z-wave network.

First of all, it turns out I was encountering two separate problems that had the same error message - specifically “failed to go into learn mode…”

One of the problems was just that it was difficult to add my VRCS2/4 load+controllers correctly. The full power include method didn’t work well for me, but carrying the dongle to the node did (after I reset my whole network - see below for the second problem)

The bigger problem, and the one I think you probably have, was that I was running into the “failed to go into learn mode” while trying to add any node to my Z-Wave network. The only thing that worked for me here was to exclude every z-wave device in my house and then reset/erase the z-wave dongle, then re-include all the z-wave devices in my house. The whole process took about 8 hours, but now I can add new z-wave devices again, and I no longer have the “failed to go into learn mode” problem.

The most frustrating thing by far was MCV tech support. Obviously, before spending 8 hours of my time to work around an MCV bug I wanted at least an acknowledgement that they were aware of the bug, and some statement as to whether or not they felt that resetting the z-wave network would fix the problem. It took me over a week of daily emails to get any kind of acknowledgement that it might fix the problem. The majority of the responses were as if someone had only partially read my support case and were just offering up a basic boiler plate response. One of the responses from MCV was just generic instructions on how to add a z-wave device to Vera, even though the ticket I opened provided the specific error message that no one should get when trying to add a z-wave device, and demonstrated that I was already doing things correctly (I had at that point already added about 60 nodes to my network and didn’t need a basic tutorial on how to generically add a node).

My suggestion would be to email them every single business day. If a business day or two goes by without a response, open a new ticket referencing the first one. I can’t tell you how frustrating it was feeling like MCV wouldn’t take 5 minutes to provide me with a clear response to acknowledge that the 8 hours I was about to spend doing a workaround (which I found on the forums, not from MCV) might actually work. I sent three emails over the course of three days pleading with them to affirm if my 8 hour workaround for their bug had a chance of working before I wasted my time, and I heard nothing back until I opened a new ticket, and the response I got was only partially satisfactory - it didn’t address if they knew about the bug or when/if a bugfix was coming.

It’s really frustrating to feel like 8 hours of my time isn’t worth 5 minutes of MCV’s undivided attention.