Manual routing

Hello,

My garage is about 25 meters away from my house, I installed a fibaro relais to operate the garage. Unfortunately vera has difficulties talking to the fibaro relais :frowning:

A wallplug which is capable of routing is installed 2 meters higher (switches the outside light) does have a fair connection to the vera, although it is also via another wallplug I believe, (when I do a stress test of this wallplug just above the fibaro relais vera says this:

Download : Starting stress test of node 35 Sent 10 direct pings, 0 were ok, average 200ms Sent 10 pings, 10 were ok, average 200ms Sent 10 polls, 10 were ok, average 1400ms

I want now that the fibaro relais goes via the wallplugs, if possible first try a route via wallplug 1 and if it doesn’t work , via wallplug 1 & 2. I have read somewhere this can be inserted , but I cannot find the thread anymore.

The questions I have:

  • The fibaro relais has 3 devices, parent, e1 and e2 , I only use the e2. Do I put the manual routing on the parent or on the e2?
    *Each device has a device numer and a node number, which number do I use for the manual routing?
    if I want to go from: vera>wallplug1>fibaro. and routing 2: vera>wallplug 1>wallplug2>fibaro how do I insert this?
    If I remember the other thread I read well it was something like this:20,20.35

Wallplug 1 has device #40 , and ID 20
Wallplug 2 has device #89, and ID 35

By the way, when I click the explain “button” next to the “manual route settings” I go to an empty wiki page … not very helpfull>

Oh yeah , I tried to “heal” the network as well, this didn’t change anything.

For another routing problem, I want to insert a manual route, first trying directly , than via Y ,is this done with a “0”? like:0,20.35

many thanks,
Cor

I finally found it:

For reference;
0= starting from Vera , between the devices a “.” and between the second routing a “,”.
It is the “ID” number , not the device number!

0.20,35.30.36

2 more questions:
-How many different routes can you manually insert?
-When I do a stress test, vera says: “direct pings” and “pings” what are the different between those to? I guess when I have a manual route via another device there is no “direct”, although Vera still says for example “direct pings 7 out of 10”

Thanks,
Cor

Hi Cor,

Many thnaks fro this - this will prove very usefull for me.

Can i just confirm that where I have “neighbours” on a device if a heal fixes nothing I can add this manualy forllowing the format you propose and Vera will use this instead?

I will see if I can find answeres to your questions in the inetesrt of information sharing :slight_smile:

Many thbnaks for this post.

Hi Cor,

I just had the same questions a few days ago and found the answers on the forum. The advice was to have a look at the format of the automatically set routes. Your description is O.K. indeed you use the node ID’s for routing. The x’s in the autorouting settings indicate that a route has failed. The manual routing settings are also explained on the wiki:

http://wiki.micasaverde.com/index.php/ZWave_Debugging#Manual_routing

You describe a route starting with 0. to indicate a direct link between vera and a node. Isn’t the 0. implicitly added to all routes? I.e. all routes are described as starting from the vera. Isn’t 0.20 the same as just entering 20?

Regarding you question to direct and indirect pings, it is still possible that vera pings the node directly and uses either manual (if set) or auto-routes for the indirect pings.

@ APT: about the 0 , I haven’t used it myself ,but I read that somewhere. Initially I thought the same as you, but maybe it is for this routing option; first try directly , if it doesn’t work , than try the alternate routing.

0,20.35

But that’s what i think , if it is correct , i don’t know.

Cor

AFAIK, you can have 4 nodes in between Vera and the destination; hence the notation [font=courier]n1.n2.n3.n4[/font] for manual routes, specifying the intermediate nodes. A 0 (or 255) for [font=courier]n1[/font] is used to indicate to attempt a direct transmission from Vera to the destination node.

The manual routes that are automatically determined by Vera, appear to be limited to 4. The manual routes that can be set by the user, I think is just a single one. That is, anything after the comma is ignored.

@Cor,
Rather than the nearby switch, is there a device that is closer to being in the center between Vera and the relay, and try attempting a manual route through that?

@oTi@, Oh… only 1 manual route… that would explain why my try-outs are not working as I want it to be. I inserted:

20,20.36.35,36,36.35, that is 4 different routes, But if I understand you correctly, vera only will look now to the route vera-node20-desination… not the other routes I inserted. When I did a stress test with this, and removed the first route ,“node20” but used the route 20.36.35 , the ping was much better, which i thought was wierd. But it makes sence when you say you can only insert 1 manual route.

I have moved the wallplug outside the barn now and put the electronics from that wallplug in a watertight case, and moved the fibaro switch a bit higher as well… i think a metal roof-drainage system was not very helpfull getting the signals where they needed to go. it does work ok now , not super, when I heal I get 2 stars and the pings are acceptable as well.

One little isue, I opened another thread for this, here a copy paste, I doubt it is possible , but it would help:

My garage is a bit far away from the vera, I have installed some wallplugs to extend the range and the range is okay-ish, there is a bit of delay , but it works.

The problem: I use to open and close my garage door a fibaro relais FGS221, and have set the parameters 3 to 1 and parameter 4 to 60. Basically ,I simulate a "springloaded button push"of 1 second with this. Since the vera doesn’t get a confirmation from the relais on time , it goes for a retry. Since everytime the first try worked fine, just the confirmation took a bit long , the garage door closes due to the retry again (is a second button push) :-/

How can I change something that vera does not go for a retry , at least not within for example 10 seconds. Can this be changed somehow?

Your help is appreciated,
thanks,
Cor


[url=http://forum.micasaverde.com/index.php/topic,13471.msg100332.html#msg100332]http://forum.micasaverde.com/index.php/topic,13471.msg100332.html#msg100332[/url]

Cor

The garagdoor is now behaving… the manuel routing solved the problem. ;D

I am trying to give a fibaro 3in1 sensor a manuel routing ( see attachment) , I will try to use this as a scene trigger device, ( to open my garagedoor), This manuel routing since I want to try to use it in my car to open the garagedoor. (The ultimate goal is to have to of these devices together in 1 case to operate on 2 different mesh-networks).

But it doesn’t want to configure, it keeps on saying “waiting for device to wake up”, I left it about a day next to the vera3, and today half of the day near the device of the manuel routing… it somehow cannot connect …

Any ideas?

Thanks,
Cor

My 3-1 Fibaro Door/Window sensor is giving also me a headache. Figured out the pairing difficulties thanks to many other posts here. Outside tmp-button + many clicks on the inside button is the key.

But I still have connection problems. Near my Vera it works fine but in my garage it does not (where I also have an Everspring battery powered sensor up and running). I will try the manual routing when I get back home. But that should really not be necessary, should it?? I mean that is the main point with the whole Z-wave mesh-thing, the network should just work. If I look in my 3-1’s neighbours, there is only a “1” which is the Vera if I am not mistaken. Does anyone else have neighbour picked up? Is it a bug in the sensor or in the Vera???

Battery powered devices do not repeat (act as neighbor nodes) the z-wave command to other z-wave devices unless they are powered all of the time. If you have no other devices near the 3-in-1 device while it is in the garage (e.g. light switch, etc) you may very well experience issues with reliability. I suggest that you make sure you have another z-wave device near by to see if that helps with reliability.

  • Garrett

Yeah, that is what I did. I moved the device into the house where I have many powered Z-wave units. I excluded, reset, included, polled, configured etc. I never get anything in “Neighbor” ecept “1”…

Do you have “neighbors” ?

And just to clarify, my other battery powered (Everspring) unit finds neighbors when sitting in the garage.

Hi @filifjonkan

Forgive my need to reiterate this, but the Fibaro device needs to be awake to ‘exchange’ configuration data with Vera, so the updating of neighbours (also button on Device Options tab) should be done when it’s fully awake.

  • I’m not familiar with the Fibaro 3 in 1 but I would assume pressing the button wakes it up fully, maybe for an extended period, even more than the scheduled wake up via Vera.

If the above does not help, ave you tried a heal?

Other options are to extend the antenna on Vera or the Fibaro module.

Hi again,

My 3 in 1 Fibaro Door Motion sensor have been doing fine in the garage for two complete days very soon.

I did try a heal and I am sure the healing process went well, at least did the report list all my devices. But the 3 in 1 did still not have any neighbors and operation away from the Vera was not good, until…

…I did as the thread creator, I added a manual route via a powered unit closer to the garage and updated the unit.

So until someone tells me their 3 in 1 Fibaro actually can find neighbors I will believe there is a firmware problem with it.
My box is marked “V2/1 EU 28/02/13”