Manage alexa not show any devices or any scenes

hi under my account i see my controller and can connect to it .
i have echo dot and try to connect the vera controller to it and under “manage alexa” menu i see no devices and no scenes
also try to connect from alexa app and after connecting to my vera account i got message “no controller found”
how can i connect to alexa ?
i have the alexa plugin installed in my controller also tried to remove and reinstall it

This is a Vera hub right? Not an Ezlo one.

In the Alexa app I assume you have the Vera skill, have you tried reconnecting / linking that to your Vera account?

Also that web page at can be hit and miss sometimes. Try logging out and back in again then going to the page for the Manage Alexa.

Hi tried this few times, logout login unlink and link back the skill, even opened other user and connect the vera plus to it and nothing , no devices and no scenes in manage alexa

I just checked my “Manage Alexa” page on the site and I do still have my devices and scenes showing in there OK.

Which kinda rules out a wide spread issue.

Can you do a screenshot of the Manage Alexa page, is it just all blank?

Mine looks like this.

this is mine

no matter what i do still no devices and no scenes

Strange don’t think I have seen that issue before.

@Leonardo_Soto can you open a ticket for him please.


Try deleting your browser cache or try a different browser maybe ?

tried all browsers and diffrent computers and still the same
seems like my manage alexa isnt sync in any way with my controller

Hi @fastest ,

I’ll take a look at your controller.


i did restore to one of my online backup and now i can see in manage alexa scenes and devices
i see scenes with names question marks , probably because its in hebrew and i changes few names of scens but manage alexa not refresh these names , its seems manage alexa not sync with changes i do in controller

this is what i see now - devices with hebrew names shown ok , scenes not .
changing scenes or devies name in the controller devices menu not change manage alexa names

You can also create a custom name for Alexa right next to the device name. Is that option working?
Can you try disabling and enabling the skill to verify if that updates their names?

Also, I sent you an email asking for some information we would need to investigate further.

i added the user to my controller
the problem i cant see the name of the scenes . there isnt a way to sync the controller name and manage alexa names ?
also i disabled and enabled the skill in amazon app more then 10 times nothing changed

in my controller there is a scene called - big window
i cant see it in manage alexa or from alexa app after unlink and link the skill
also any new scene i add wont added to any way - manage alexa or alexa app

Thank you!
Let me take a look and I’ll let you how it goes.