Making a single x10 lamp module work

While i’m still trying to learn Altsteon, I wanted to just see if I could get a single x10 lamp module to work. I’ve tried to enter the address from both the settings/insteon tab, as well as the devices/add devices tab.

the device will show up, but will not work when I send a command to it. I’ve even tried plugging it in directly by the PLM to ensure that it’s not on a circuit too far away.

Any ideas how to get this to work.

I am an old x10n’r making the transition to (or should I say attempting) to Veralite. I also have a bunch of insteon. I can say I am a little frustrated but let me see if I can help you out.
Do you have a device to read x10 code off the powerline. A great piece of test equipment.
Is the PLM working? I would verify that first.
Did you have a working x10 network before? Are your phases bridged appropriately and are your Vera commands making it across the phases?
IS Vera working with other devices? Maybe your problem isn’t with X10?
Sorry, lots more questions than answers but trying to narrow down your issue.

I set up X10 a while ago. Here are the steps. They are not very precise as I forgot the exact name of the pages, but it works.

1- Enable Insteon support on Vera (go to Add Device page then press Add button for Insteon X10 device. Enable Insteon support on the comming page) . Then reload. It tells you Insteon not ready on the top of the page, which is fine.
2-Connect your PLM, then assign the USB port to the Insteon module on the serial setup page. Reload. If you have done it correctly you wont get any error message and it shows Instean is setting up on the top of the page, while reloading.
3-Go to Add Device page, press Add button for the to add Insteon X10 device. A new page will show up. On the new page, go to add X10 device and select the proper address nd device,e.g. A03. Reload.

PS. PLM cannot read the X10 command from the line, but I can turn on/off x10 lights.