MAC adress changed!!!!!!

Hi

Having had severe problems login on to my vera edge via getvera.com I finally noticed that the MAC-adress noted under the Vera box does not match the MAC-adress that the vera reports to the router as shown in the router hosts list. The last digit on the box is an 8, but the reported MAC-adress in the router host list is 9.

I’m beginning to get really fed up with my vera edge!

How do I fix this without having to start all over with setting up a new unit at getvera.com?

And how the h-ll did this happen?

So, some further fault finding revealed the following.

I tried to register a new controller at getvera.com. No controller was found on my network. Though the vera edge is there, I just downloaded some plugins to it just to test, worked fine.

So I tried to add a controller manually, using the MAC adress noted on the bottom of the unit. It then responds that the unit is already registered, and doesn’t even try to find it as far as I can tell.

I then tried to register it using the reported MAC adress, with a 9 at the end. It then says the combination of serial number and MAC adress is invalid.

When the vera edge was first installed (or perhaps some time later, but I don’t think so) I gave the vera edge a static IP in the router, and the static IP was at that point registered using the MAC adress ending with a 9 !!!

So, from the looks of it, the MAC adress has always ended in 9, at least as far as the router is concerned.
So how can my vera edge then be registered with the ending 8, and be reported as invalid with the 9, and how come this has worked previously?

This is a bug in the VeraEdge firmware affecting a number of units. Enable support in your VeraEdge.
(Setup -> Customer Care - scroll to the bottom and click the ‘Enable’ button under remote access) Copy the acccess code and paste it in the form you get when you click on the ‘Contact Customer Care’ button a bit farther up. Describe the issue with the MAC address and make sure the Vera is on and connected to the internet.

Vera support will remote in and resolve the issue for you. After that you can disable remote access.

Ok, 1000 thanks!

I just noticed that if I connect the vera with the ethernet cable the MAC-adress becomes the one ending with an 8.
The 9 appears when using wifi, it seems.

But I still cannot login to it even when connected via the ethernet cable.

Also, I just updated the firmware, which didn’t help and wasn’t mentioned as a known issue. Pretty bad if it is a known bug, not to inform about it.

But what exactly is the bug? I assume it should be different mac-adresses on the ethernet and wifi connections(?)

Each network device has a unique MAC address hence the 2 for the wifi and Ethernet devices. Here is a place you can look up MAC addresses: http://aruljohn.com/mac/28F36675706D

The bug is that somehow Vera is confused about it’s MAC address. It should identify itself by the one on the bottom but instead identifies itself with one that has the 1 digit difference. I believe the Vera servers identify a Vera by a combination of it’s serial and MAC and as yours is producing the wrong combo, it’s confusing the servers as it can’t find that data in it’s list of authentic units. My VeraPlus (first batch) had the same issue and support remoted in and fixed it. No more issues since.

Well, whatever, something is wrong. And the label should show all MAC-adresses, and Vera homepage should not return an invalid message for any of the valid adresses.

I’ve sent an email to the support and also requested it via the vera edge Customer care.

In the end it turned out that I had one account for UI7 and one account for UI5, they both had the same email, username and password.

No wonder, actually, because I had no idea I had two accounts, or that you could even have two accounts.

I have the vera edge, and didn’t have anything before, so I have no clue why I even have a UI5 account or how I got it. But I assume it was registered when I tried to sort out some other previous problem trying to get things to work, when I have been requested to logon using some other portal.

Yepp, the people at vera have a lot of stuff to sort out, that’s for sure.