Luup.inet.wget not working for me

Hi, can someone point me in the right direction why the luup.inet.wget("… call is not working for me anymore?
I am am running Vera Plus with version 1.7.4453, enabled potentially unsafe lua code in the security tab.

Assuming you did not have a typo in your post above, it looks like you made a typo. You should use luup.inet_wget instead of luup.inet.wget. Are you sure it used to work as you wrote it?

Thanks rafale77, I used luup.inet.wget before and it worked.
I tried your luup.inet_wget but this also does not work

Your syntax should not work. Not sure how it did in the past. I use this call very extensively and it has been working fine. I am guessing either your call syntax or your url has an error in it. Or some how your network is blocking it.

@rafale77, are you sure about this? I’ve never heard of inet_wget. Luup.inet.wget is documented, however. And here’s a quick test on 4453:

08	06/03/19 10:06:53.940	JobHandler_LuaUPnP::HandleActionRequest argument Code=luup.log("luup.inet is " .. tostring(luup.inet),2)
luup.log("luup.inet.wget is " .. tostring(luup.inet.wget),2)
luup.log("luup.inet_wget is " .. tostring(luup.inet_wget),2)
02	06/03/19 10:06:53.940	luup_log:0: luup.inet is table: 0x18c62d8 <0x725fe520>
02	06/03/19 10:06:53.940	luup_log:0: luup.inet.wget is function: 0x18c70b8 <0x725fe520>
02	06/03/19 10:06:53.941	luup_log:0: luup.inet_wget is nil <0x725fe520>

I created a new scene with only luup code:

local weather = “clear”
local status, result = luup.inet.wget(““”&priority=-1”)

This does not work, however when I enter this in Test luup code screen, it works.
I am out off options…

Have you looked in the log file to see if anything is being logged there?

I am embarrassed… excess of confidence as I am so accustomed to this expression format. I stand corrected… I just checked all my codes and they are all with a dot. They all work though.

I found a solution to the problem, replacing the " in all the scenes solved the issue.
This must have been introduced with the latest firmware.

Doubtful, but it is the case that if you copy-paste code a lot, some editors that are commonly used (particularly on Macs) will replace the standard ASCII 34 double quote character with “curly quotes” that are more typographically pleasant to look at. Unfortunately, those curly quotes aren’t code-compatible, so that immediately corrupts the code. In my estimation, this is probably the most common reason that code copy-pasted from these forums fails when it looks perfectly fine–the difference between the correct quotes and the curly quotes can be very difficult to spot.

There you could be right, I use a MAC also sometimes.

Any word processor can cause the problem. Best to use Notepad or equivalent simple ASCII text editor. As @rigpapa points out, the way the browser renders the quotes can be difficult or impossible to spot .

This is correct… the infamous quotation correction which comes with the enriched text format most text editors default to. I don’t think this had anything to do with the new firmware either. I have made this mistake many times before. If you use ALTUI to edit your lua code it should help you catch it though.

this will help, thank you all

Yes, or LuaView, if you don’t need everything else that ALTUI provides.

Notepad ++ and EditPad Lite are excellent free text/code editors. EditPad Pro (paid) is an excellent Windows code editor.