Luup Execution in Scenes -Stopped working

Hey,

Out of the blue, no changes, no updates all of sudden LUUP execution in scenes stopped working?! I can do a LUUP reload in develop apps, but cannot run this command:

os.execute([[curl -X PUT -H “Authorization: Bearer XXX” “https://dev2.mittsmartahus.se/api/0/scenario/YYY”]])

I would be immensely grateful If someone can provide a quick answer.

Between August and now, something has happened without out me doing anything, sw update or new scenes

Have you verified that the url is still valid?
if you log in to your controller (you failed to mention what controller you are using), and execute the curl comand there - does it work?

Hey, Yes it is, I can run it separately from IOS shortcuts as an example. The actual Vera scene also runs, but it seems that it does not fire away the code

VeraSecure

have you tried logging in to the vera secure and execute the curl command from the command line? running it from anywhere else than the vera itself does not say that much…

have you looked in the LuaUPnp log file (found in /var/log/cmh) to see if there are any errors there?

what device is triggering the scene?

what version of vera secure are you running?

I have run the command from Develop Apps without luck. Log file I have no idea where to find :face_with_monocle:

1.7.5187 (7.31)

The thing is that I have not changed anything. In the old days when you put corrupt code in the scene, the scene could not run when activating it manually

It’s entirely possible that either the certificate on the site has gone bad, or a CA certificate on the Vera itself has expired (in which case we’ll be seeing a lot more posts like this). But one quick thing to try is adding -k to your curl command. This will accept all certificates and not verify them, but does not affect encryption strength.

It’s also possible that your target has reconfigured its server to drop lesser hashes and encryptions. In this case, try using each of these in turn (one at a time, not all at once) and see if one of them works: -1 (dash one), --tlsv1.2 (dash dash etc).

If the target site has limited connections to TLS1.3, you’re done, because the OpenSSL in that firmware won’t support it. This is highly unlikely, though, as a restriction this tight would create problems for tons of clients.

I would also recommend you try all of this by issuing the curl commands in an SSH session, on the command line of the Vera, and with the -v option. This will give you additional diagnostic information that you cannot easily see with os.execute(). Just copy-paste the curl command and all its arguments into the shell, edit, and submit.

Edit: I just tried your request myself on my Plus. It’s the CA certificate. Using -k gets it working again.

Rigpapa: LOVELY to see Your name here :star_struck: My Veras have been running like Rockets for years now, so havent even signed on this fora until today.

Will check later, and again, great to see you here !

1 Like

@rigpapa You sir, are my hero! Back to Rocket mode again. One happy dude!

THANKS!!!

1 Like

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules