Lua Startup Failure


Upgraded to yesterday. Goto check Vera and I see an error with one of my PLEG. On the PLEG it is saying “Lua Startup Failure” , on the the top of the landing page on Vera it is saying "Not Registered - Exceeded Free Limits!, when clicking on that specific pleg to check the registrtion it says Error executing function plc_Register(): Cannot read property ‘replace’ of undefined. I have registered PLEG. The other 2 plegs are working properly. Any thoughts?

upgraded to

If you upgraded from UI5 … you must UPGRADE the plugins … even if you are on the latest version.
The upload will load the appropriate Version specific files.

Sorry Richard. I have been using it on UI7 for at least 6 months now. Just upgraded from the last UI7 firmware.

I guess I am the only one who has this problem. Weird.

There was an upgrade for PLEG for UI7 a couple months ago.

I did upgrade it. I think I was the first one to report the error after upgrading a few months ago.

I think these are all up to date:

Programmable Logic: Current Version:7.47
Program Logic Core: Current Version:7.48
Program Logic Event Generator: Current Version:7.47

If two are working then you have a PLEG with corrupted data … You will have to re-create it.

Thanks, recreating the PLEG solved the issue. Anyway to export a PLEG? That was a long one to recreate.

Hi Richard,

Same error is back again. Did not install anything new, nor change any configuration. Thoughts?

I will need to see the Log files.
In settings for the PLEG More … set the LOG to the VERA Log File.

Then monitor the log during a restart … send me the log and a status report.