Locks are not triggering events anymore...


I have 2 Yale RealLiving locks (deadbolt and lever). I can’t pinpoint a specific event, but out of nowhere they stopped triggering scenes. I’ve tried deleting both devices and re-adding them. I can open/close them from the GUI, I can set up new codes, but whenever a code is punched into either one of these locks, a corresponding scene is no longer triggered. I even tried setting up notification on each lock: whenever any code is entered - notify me, but nothing happens…

Please help! Any troubleshooting ideas? Where and what to check?


Hmm. Odd. You might try sending z-wave exclusion signals, and then factory defaulting the actual lock.

Z-Wave exclusion should flush the programming from the radio module in the lock.
Factory defaulting should handle the rest of the processor.

Once re adding it to the system, wait for all the special associations and such things to finish and stabilize. If it’s still a problem, there’s something amiss with the Z-wave programming of the Vera itself. This seems likely, if BOTH locks crapped out at the same time.

Is there a particular message in the the Lua logs that should appear whenever a code is entered into one of the locks? If I could confirm that the message does appear, but Vera does not respond, I would definitely know who the culprit it…

So, if Vera is at fault, what would you recommend? Can factory defaulting of Vera be avoided? There’s so much stuff I would have to configure…

Shoot, I’m not sure.

You might try some of the Z-wave options, like repair, rebuild network, etc in the Z-wave Settings menu. Just be sure to take backups of the Z-wave and basic configurations before you start poking.

Your guess is as good as mine, but some minor thing buried in there is going to annoy you until you fix it by accident.

Thanks. Will do.

Do you or does anyone know what should appear in LuaUPnP.log, if anything, when a PIN code is entered into a Yale RealLiving lock?

I think this is what you want here;

04 10/14/13 18:30:11.843 <0x2b4f7680>

After this came the reactions from my various scenes.

So I SSHed in, and typed;

tail -f /var/log/cmh/LuaUPnP.log | grep “^04”

Then use a code to unlock the door, and you ought to get what you are looking for.

Thank you!